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Why this chapter

Computers are an integral part of our lives. Wherever we are sitting in our homes, working in the office, driving on roads, sitting in a movie hall, staying in a hotel, etc.— our lives are directly or indirectly affected by the computers. In this era of information, we are dependent on the storage, flow and processing of data and information, which can only be possible with the help of computers. The purpose of this chapter is to introduce you to the ―computer‖.

INTRODUCTION

Nowadays, computers are an integral part of our lives. They are used for the reservation of tickets for airplanes and railways, payment of telephone and electricity bills, deposit and withdrawal of money from banks, processing of business data, forecasting of weather conditions, diagnosis of diseases, searching for information on the Internet, etc. Computers are also used
extensively in schools, universities, organizations, music industry, movie industry, scientificresearch, law firms, fashion industry, etc.

Definition of Computer
The term computer is derived from the word compute. The word compute means to calculate. A computer is an electronic machine that accepts data from the user, processes the data by performing calculations and operations on it, and generates the desired output results. Computer performs both simple and complex operations, with speed and accuracy.
Speed, accuracy, diligence, storage capability and versatility are some of the key characteristics of a computer. Computers have several limitations too. Computer can only perform tasks that it has been programmed to do. Computer cannot do any work without instructions from the user. It executes instructions as specified by the user and

does not take its own decisions.

HISTORY OF COMPUTER

Until the development of the first generation computers based on vacuum tubes, there had been several developments in the computing technology related to the mechanical computing devices. The key developments that took place till the first computer was developed are as follows—
· Calculating Machines ABACUS was the first mechanical calculating device for counting of large numbers. The word ABACUS means calculating board. It consists of bars in horizontal positions on which sets of beads are inserted. The horizontal bars have 10 beads each, representing units, tens, hundreds, etc. An abacus is shown in Figure 1.1
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Figure 1.1 Abacus
· Napier’s Bones was a mechanical device built for the purpose of multiplication in 1617ad. by an English mathematician John Napier.
· Slide Rule was developed by an English mathematician Edmund Gunter in the 16th century. Using the slide rule, one could perform operations like addition, subtraction, multiplication and division. It was used extensively till late 1970s. Figure 1.2 shows aslide rule.
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Figure 1.2 Slide rule
· Pascal’s Adding and Subtraction Machine was developed by Blaise Pascal. It could addand subtract. The machine consisted of wheels, gears and cylinders.
· Leibniz’s Multiplication and Dividing Machine was a mechanical device that could both multiply and divide. The German philosopher and mathematician Gottfried Leibniz built it around 1673.
· Punch Card System was developed by Jacquard to control the power loom in 1801. He invented the punched card reader that could recognize the presence of hole in the punched card as binary one and the absence of the hole as binary zero. The Os and 1s are the basis of the modern digital computer. A punched card is shown in Figure 1.3.
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Figure 1.3 Punched card
· Babbage’s Analytical Engine An English man Charles Babbage built a mechanical machine to do complex mathematical calculations, in the year 1823. The machine was called as difference engine. Later, Charles Babbage and Lady Ada Lovelace developed a general-purpose calculating machine, the analytical engine. Charles Babbage is also called the father of computer.
· Hollerith’s Punched Card Tabulating Machine was invented by Herman Hollerith. The machine could read the information from a punched card and process it electronically.
The developments discussed above and several others not discussed here, resulted in thedevelopment of the first computer in the 1940s.




THE COMPUTER SYSTEM

Computer is an electronic device that accepts data as input, processes the input data by performing mathematical and logical operations on it, and gives the desired output. The computer system consists of four parts•(1) Hardware, (2) Software, (3) Data, and
(4) Users. Theparts of computer system are shown in Figure 1.4.

Hardware consists of the mechanical parts that make up the computer as a machine. The hardware consists of physical devices of the computer. The devices are required

for input, output, storage and processing of the data. Keyboard, monitor, hard disk drive, floppy disk drive, printer, processor and motherboard are some of the hardware devices.
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Figure 1.4 Parts of computer system
Software is a set of instructions that tells the computer about the tasks to be performed and how these tasks are to be performed. Program is a set of instructions, written in a language understood by the computer, to perform a specific task. A set of programs and documents are collectively called software. The hardware of the computer system cannot perform any task on its own. The hardware needs to be instructed about the task to be performed. Software instructs the computer about the task to be performed. The hardware carries out these tasks. Different software can be loaded on the same hardware to perform different kinds of tasks.

Data are isolated values or raw facts, which by themselves have no much significance. For example, the data like 29, January, and 1994 just represent values. The data is provided as input to the computer, which is processed to generate some meaningful information. For example, 29, January and 1994 are processed by the computer to give the date of birth of a person.
Users are people who write computer programs or interact with the computer. They are also known as skinware, liveware, humanware or peopleware. Programmers, data entry operators, system analyst and computer hardware engineers fall into this category.


Block diagram of Computer
The computer system hardware comprises of three main components —

1. Input/Output (I/O) Unit,
2. Central Processing Unit (CPU), and
3. Memory Unit.

The I/O unit consists of the input unit and the output unit. CPU performs calculations and processing on the input data, to generate the output. The memory unit is used to store the data, the instructions and the output information. Figure 1.5 illustrates the typical interaction amongthe different components of the computer.
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Figure 1.5 The block digram
Input/Output Unit The user interacts with the computer via the I/O unit. The Input unit accepts data from the user and the Output unit provides the processed data i.e. the information to the user. The Input unit converts the data that it accepts from the user, into a form that is understandable by the computer. Similarly, the Output unit provides the output in a form that is understandable by the user. The input is provided to the computer using input devices like keyboard, trackball and mouse. Some of the commonly used output devices are monitor and printer.
· Central Processing Unit CPU controls, coordinates and supervises the operations ofthe computer. It is responsible for processing of the input data. CPU consists of Arithmetic Logic Unit (ALU) and Control Unit (CU).
· ALU performs all the arithmetic and logic operations on the input data.
· CU controls the overall operations of the computer i.e. it checks the sequence of execution of instructions, and, controls and coordinates the overall functioning ofthe units of computer.
Additionally, CPU also has a set of registers for temporary storage of data, instructions,addresses and intermediate results of calculation.

· Memory Unit Memory unit stores the data, instructions, intermediate results and output, temporarily, during the processing of data. This memory is also called the main memory or primary memory of the computer. The input data that is to be processed is brought into the main memory before processing. The instructions required for processing of data and any intermediate results are also stored in the main memory. The output is stored in memory before being transferred to the output device. CPU can work with the information stored in the main memory. Another kind of storage unit is also referred toas the secondary memory of the computer. The data, the programs and the output are stored permanently in the storage unit of the computer. Magnetic disks, optical disks and magnetic tapes are examples of secondary memory.
Booting

To boot (as a verb; also "to boot up") a computer is to load an operating system into the computer's main memory or random access memory (RAM). Once the operating system is loaded (and, for example, on a PC, you see the initial Windows or Mac desktop screen), it's ready for users to run applications.

Hot Booting
Hot booting is done when computer system comes to no response state/hang state. Computer does not respond to commands supplied by user. There are many reasons for this state, only solution is to reboot computer by using the Reset button on cabinet or by pressing a combination of ALT + CTRL + DEL keys from keyboard.

Cold Booting

A cold boot removes power and clears memory (RAM) of all internal data and counters that keep track of operations, which are created by the OS and applications when they run. Erratic program behavior is often cured with a cold boot, also known as a "hard boot."



INTERACTION BETWEEN CPU AND MEMORY WITH INPUT/OUTPUT DEVICES

The computer as a machine consists of different components that interact with each other to provide the desired functionality of the computer. As a user of the computer, we need to be aware of the main components of the computer, their functions and the interconnection betweenthe different components of the computer.

A computer consists of three main components—(1) Input/Output (I/O) Unit, (2) Central Processing Unit (CPU), and (3) Memory Unit. The computer user interacts with the computer via the I/O unit. The purpose of I/O unit is to provide data and instructions as input to the computer and to present relevant information as output from the computer. CPU controls the operations of the computer and processes the received input to generate the relevant output. The memory unit stores the instructions

and the data during the input activity, to make instructions readily available to CPU during processing. It also stores the processed output. C

CENTRAL PROCESSING UNIT

Central Processing Unit (CPU) or the processor is also often called the brain of computer.

Function of CPU
CPU executes the stored program instructions, i.e. instructions and data are stored in memory before execution. For processing, CPU gets data and instructions from the memory. It interprets the program instructions and performs the arithmetic and logic operations required for the processing of data. Then, it sends the processed data or result to the memory. CPU also acts as an administrator and is responsible for supervising operations of other parts of the computer.

Functional parts of CPU
CPU (Figure 1.6) consists of Arithmetic Logic Unit (ALU) and Control Unit (CU). In addition, CPUalso has a set of registers which are temporary storage areas for holding data, and instructions. ALU performs the arithmetic and logic operations on the data that is made available to it. CU isresponsible for organizing the processing of data and instructions. CU controls and coordinates the activity of the other units of computer. CPU uses the registers to store the data, instructions during processing.


The CPU is fabricated as a single Integrated Circuit (IC) chip, and is also known as the microprocessor. The microprocessor is plugged into the motherboard of the computer (Motherboard is a circuit board that has electronic circuit etched on it and connects the microprocessor with the other hardware components).
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Figure 1.6 CPU

Arithmetic Logic Unit
· ALU consists of two units—arithmetic unit and logic unit.
· The arithmetic unit performs arithmetic operations on the data that is made available to it.Some of the arithmetic operations supported by the arithmetic unit are—addition, subtraction, multiplication and division.
· The logic unit of ALU is responsible for performing logic operations. Logic unit performs comparisons of numbers, letters and special characters. Logic operations include testing for greater than, less than or equal to condition.
· ALU performs arithmetic and logic operations, and uses registers to hold the data that isbeing processed.
Registers
· Registers are high-speed storage areas within the CPU, but have the least storage capacity. Registers are not referenced by their address, but are directly accessed andmanipulated by the CPU during instruction execution.
· Registers store data, instructions, addresses and intermediate results of processing. Registers are often referred to as the CPU‘s working memory.
· The data and instructions that require processing must be brought in the registers of CPU before they can be processed. For example, if two numbers are to be added, both numbers are brought in the registers, added and the result is also placed in a register.
· Registers are used for different purposes, with each register serving a specific purpose.Some of the important registers in CPU (Figure 1.7) are as follows—
· Accumulator (ACC) stores the result of arithmetic and logic operations.
· Instruction Register (IR) contains the current instruction most recently fetched.
· Program Counter (PC) contains the address of next instruction to be processed.
· Memory Address Register (MAR) contains the address of next location in thememory to be accessed.
· Memory Buffer Register (MBR) temporarily stores data from memory or the datato be sent to memory.
· Data Register (DR) stores the operands and any other data.
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Figure 1.7 CPU registers

· The number of registers and the size of each (number of bits) register in a CPU helps todetermine the power and the speed of a CPU.
· The overall number of registers can vary from about ten to many hundreds, depending onthe type and complexity of the processor.
· The size of register, also called word size, indicates the amount of data with which the computer can work at any given time. The bigger the size, the more quickly it can processdata. The size of a register may be 8, 16, 32 or 64 bits. For example, a 32–bit CPU is one in which each register is 32 bits wide and its CPU can manipulate 32 bits of data at a time. Nowadays, PCs have 32–bit or 64–bit registers.
· 32-bit processor and 64-bit processor are the terms used to refer to the size of the registers. Other factors remaining the same, a 64-bit processor can process the data twiceas fast as one with 32-bit processor.
Control Unit
· The control unit of a computer does not do any actual processing of data. It organizes the processing of data and instructions. It acts as a supervisor and, controls and coordinates the activity of the other units of computer.
· CU coordinates the input and output devices of a computer. It directs the computer to carry out stored program instructions by communicating with the ALU and the registers. CU uses the instructions in the Instruction Register (IR) to decide which circuit needs to be activated. It also instructs the ALU to perform the arithmetic or logic operations. When a program is run, the Program Counter (PC) register keeps track of the program instruction to be executed next.
· CU tells when to fetch the data and instructions, what to do, where to store the results, thesequencing of events during processing etc.
· CU also holds the CPU‘s Instruction Set, which is a list of all operations that the CPU canperform.

The function of a (CU) can be considered synonymous with that of a conductor of an orchestra. The conductor in an orchestra does not perform any work by itself but manages the orchestra and ensures that the members of orchestra work in proper coordination.

MEMORY

The computer memory stores different kinds of data like input data, output data, intermediate results, etc., and the instructions. Binary digit or bit is the basic unit of memory. A bit is a single
binary digit, i.e., 0 or 1. A bit is the smallest unit of representation of data in a computer. However, the data is handled by the computer as a combination of bits. A group of 8 bits form a byte. One byte is the smallest unit of data that is handled by the computer. One byte can store 28, i.e., 256 different combinations of bits, and thus can be used to represent 256 different symbols. In a byte, the different combinations of bits

fall in the range 00000000 to 11111111. A group of bytes can be further combined to form a word. A word can be a group of 2, 4 or 8 bytes.

1 bit = 0 or 1

1 Nibble = 4 bits
1 Byte (B) = 8 bits

1 Kilobyte (KB) = 210 = 1024 bytes 1 Megabyte (MB) = 220 = 1024KB
1 Gigabyte (GB) = 230 = 1024 MB = 1024 *1024 KB

1 Terabyte (TB) = 240= 1024 GB = 1024 * 1024 *1024 KB

1 Petabyte (PB) = 250= 1024 TB = 1024 * 1024 * 1024 *1024 KB

Memory is logically organized as a linear array of locations. For a processor, the range of the memory addresses is 0 to the maximum size of memory. Figure 1.8 shows the organization of a16 MB block of memory for a processor with a 32-bit word length.
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Figure 1.8 Organization of memory

MEMORY HIERARCHY

The memory is characterized on the basis of two key factors—capacity and access time. Capacity is the amount of information (in bits) that a memory can store. Access time is the time interval between the read/ write request and the availability of data. The lesser the access time, the faster is the speed of memory. Ideally, we want the

memory with fastest speed and largest capacity. However, the cost of fast memory is very high. The computer uses a hierarchy of
memory that is organized in a manner to enable the fastest speed and largest capacity of memory.The hierarchy of the different memory types is shown in Figure 1.9.
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Figure 1.9 Memory hierarchy

The internal memory and external memory are the two broad categories of memory used in the computer. The internal memory consists of the CPU registers, cache memory and primary memory. The internal memory is used by the CPU to perform the computing tasks. The external memory is also called the secondary memory. The secondary memory is used to store the large amount of data and the software .

Cache Memory
· The data and instructions that are required during the processing of data are brought from the secondary storage devices and stored in the RAM. For processing, it is required that the data and instructions are accessed from the RAM and stored in the registers. The time taken to move the data between RAM and CPU registers is large. This affects the speed of processing of computer, and results in decreasing the performance of CPU.
· Cache memory is a very high speed memory placed in between RAM and CPU. Cachememory increases the speed of processing.
· Cache memory is a storage buffer that stores the data that is used more often, temporarily, and makes them available to CPU at a fast rate. During processing, CPU first checks cache for the required data. If data is not found in cache, then it looks in theRAM for data.
· To access the cache memory, CPU does not have to use the motherboard‘s system bus fordata transfer. (The data transfer speed slows to the motherboard‘s

capability, when data is passed through system bus. CPU can process data at a much faster rate by avoiding the system bus.)
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Figure 1.10 Illustration of cache memory

· Cache memory is built into the processor, and may also be located next to it on a separate chip between the CPU and RAM. Cache built into the CPU is faster than separate cache, running at the speed of the microprocessor itself. However, separate cache is roughly twice as fast as RAM.
· The CPU has a built-in Level 1 (L1) cache and Level2 (L2) cache, as shown in Figure 1.10. In addition to the built-in L1 and L2 cache, some CPUs have a separate cache chip on the motherboard. This cache on the motherboard is called Level 3 (L3) cache. Nowadays, high-end processor comes with built-in L3 cache, like in Intel core i7. The L1, L2 and L3 cache store the most recently run instructions, the next ones and the possible ones, respectively. Typically, CPUs have cache size varying from 256KB (L1), 6 MB (L2), to 12MB (L3) cache.
· Cache memory is very expensive, so it is smaller in size. Generally, computers havecache memory of sizes 256 KB to 2 MB.
Primary Memory
· Primary memory is the main memory of computer. It is used to store data and instructions during the processing of data. Primary memory is semiconductor memory.
· Primary memory is of two kinds—Random Access Memory (RAM) and Read OnlyMemory (ROM).
· RAM is volatile. It stores data when the computer is on. The information stored in RAM gets erased when the computer is turned off. RAM provides temporary storage for data and instructions.
· ROM is non-volatile memory, but is a read only memory. The storage in ROM is permanent in nature, and is used for storing standard processing programs that permanently reside in the computer. ROM comes programmed by the manufacturer.
· RAM stores data and instructions during the execution of instructions. The data and instructions that require processing are brought into the RAM from the storage devices like hard disk. CPU accesses the data and the instructions from RAM, as it can access it at a fast speed than the storage devices connected to the input and output unit (Figure 1.11).
· The input data that is entered using the input unit is stored in RAM, to be made

available during the processing of data. Similarly, the output data generated after processing is stored in RAM before being sent to the output device. Any intermediate results generated during the processing of program are stored in RAM.
· RAM provides a limited storage capacity, due to its high cost.
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Figure 1.11 Interaction of CPU with memory
Secondary Memory
· The secondary memory stores data and instructions permanently. The information can be stored in secondary memory for a long time (years), and is generally permanent in nature unless erased by the user. It is a non-volatile memory.
· It provides back-up storage for data and instructions. Hard disk drive, floppy drive andoptical disk drives are some examples of storage devices.
· The data and instructions that are currently not being used by CPU, but may be requiredlater for processing, are stored in secondary memory.
· Secondary memory has a high storage capacity than the primary memory.
· Secondary memory is also cheaper than the primary memory.
· It takes longer time to access the data and instructions stored in secondary memorythanin primary memory.
Magnetic tape drives, disk drives and optical disk drives are the different types of storagedevices.

· is performed.
· Storing CPU writes back the results of execution, to the computer‘s memory.
Memory Chips
The RAM consists of chips on a small circuit board (Figure 1.12). Two types of memory chips— Single In-line Memory Module (SIMM) and Dual In-line Memory Module (DIMM) are used in desktop computers. The CPU can retrieve information from DIMM chip at 64 bits compared to 32 bits or 16 bits transfer with SIMM chips. DIMM chips are used in Pentium 4 onwards to increase the access speed.
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Figure 1.12 RAM memory chip
Storage Devices
The disk drives are present inside the machine. The common disk drives in a machine are hard disk drive, floppy drive (Figure 1.13 (i & ii)) and CD drive or DVD drive. High- storage devices like hard disk, floppy disk and CDs (Figure 1.13 (iii) & (iv)) are inserted into the hard disk drive, floppy drive and CD drive, respectively. These storage devices can store large amounts of data, permanently.
Processor
The processor or the CPU is the main component of the computer. Select a processor based on factors like its speed, performance, reliability and motherboard support. Pentium Pro, Pentium 2and Pentium 4 are some of the processors.
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Figure 1.13 Storage devices (i) Hard disk drive, (ii) DVD drive, (iii) Floppy disk, (iv) CD

SUMMARY
· Computer is an electronic device which accepts data as input, performs processing on the data, and gives the desired output. A computer may be analog or digital computer.
· Speed, accuracy, diligence, storage capability and versatility are the main
characteristicsof computer.
· The computing devices have evolved from simple mechanical machines, like ABACUS, Napier‘s bones, Slide Rule, Pascal‘s Adding and Subtraction Machine, Leibniz‘s Multiplication and Dividing Machine, Jacquard Punched Card System, Babbage‘s Analytical Engine and Hollerith‘s Tabulating Machine, to the first

electronic computer.
· Charles Babbage is called the father of computer.
· Computer is an electronic device based on the input-process-output concept. Input/Output Unit, CPU and Memory unit are the three main components of computer.
· Input/Output Unit consists of the Input unit which accepts data from the user and the Output unit that provides the processed data. CPU processes the input data, and, controls, coordinates and supervises the operations of the computer. CPU consists of ALU, CU and Registers. The memory unit stores programs, data and output, temporarily, during the processing. Additionally, storage unit or secondary memory is used for the storing of programs, data and output permanently.
· CPU or microprocessor is called the brain of the computer. It processes the data and the instructions. It also supervises the operations of other parts of the computer.
· Registers, Arithmetic Logic Unit and Control Unit are the parts of CPU.
· Cache memory, primary memory and secondary memory constitute the
memory unit.Primary memory consists of RAM and ROM.
· Registers are low-storage capacity, high-speed storage areas within the CPU. The data, instructions, addresses and intermediate results of processing are stored in the registers bythe CPU.
· Cache memory is a very high-speed memory placed in between RAM and CPU, to increase the processing speed. Cache memory is available in three levels L1, L2 and L3.
· RAM provides temporary storage, has a limited storage capacity and is volatile memory. The access speed of RAM is faster than access speed of the storage devices like hard disk. The data and the instructions stored in the hard disk are brought into the RAM so that the CPU can access the data and the instructions and process it.
· CU organizes the processing of data and instructions. It acts as a supervisor and controlsand coordinates the activity of other units of computer.
· ALU performs arithmetic operations and logic operations on the data.
· An instruction is an elementary operation that the processor can accomplish. The instructions in the instruction set are the language that a processor understands. The instruction set is embedded in the processor which determines the machine language forthe processor.
QUESTIONS

1. The brain of any computer system is CPU
2. Which part interprets program instructions and initiate control operations. Control Unit
3. ALU	performs arithmetic operations and logic operations on the data
4. Define a computer
Computer is an electronic device which accepts data as input, performs processing on the data, and gives the desired output. A computer may be analog or digital computer.

5. What is a calculating machine?

ABACUS was the first mechanical calculating device for counting of large numbers. The word ABACUS means calculating board. It consists of bars in horizontal positions on which sets of beads are inserted.

6. Who is called the Father of Computer?

Charles Babbage is called the father of computer.

7. The different parts of the CPU are ALU CU  and Memory	.

8.  RAM	and ROM	are the main memory.


9. Binary digit or bit is the basic unit of memory.


10. Define a bit and byte.
Binary digit or bit is the basic unit of memory. A bit is a single
binary digit, i.e., 0 or 1. A bit is the smallest unit of representation of data in a computer. However, the data is handled by the computer as a combination of bits. A group of 8 bits form a byte. One byte is the smallest unit of data that is handled by the computer

11. 1Byte = 8 bits
12. 1 Kilobyte (KB) = 1024	bytes
13. 1 Megabyte (MB) = 1024	KB
14. 1 Gigabyte (GB) = 230 = 1024 MB = 1024 *1024 KB
15. Terabyte (TB) = 1024GB = 1024*1024*1024 KB
16. Which is the fastest memory? Cache
17. What is cache memory?
Cache memory is a very high-speed memory placed in between RAM and CPU, to increase the processing speed. Cache memory is available in three levels L1, L2 and L3.

18. The Cache	memory is placed between the RAM and the CPU.
19. There are 3 levels of cache memory.

20. List the components of computer hardware.
The computer system hardware comprises of three main components —
1. Input/Output (I/O) Unit,
2. Central Processing Unit (CPU), and
3. Memory Unit.

21. Explain in detail the components of computer hardware.
The computer system hardware comprises of three main components —

Input/Output (I/O) Unit,
Central Processing Unit (CPU), and Memory Unit.
The I/O unit consists of the input unit and the output unit. CPU performs calculations and processing on the input data, to generate the output. The memory unit is used to store the data, the instructions and the output information.
Input/Output Unit The user interacts with the computer via the I/O unit. The Input unit accepts data from the user and the Output unit provides the processed data i.e. the information to the user. The Input unit converts the data that it accepts from the user, into a form that is understandable by the computer. Similarly, the Output unit provides the output in a form that is understandable by the user. The input is provided to the computer using input devices like keyboard, trackball and mouse. Some of the commonly used output devices are monitor and printer.
Central Processing Unit CPU controls, coordinates and supervises the operations of the computer. It is responsible for processing of the input data. CPU consists of Arithmetic Logic Unit (ALU) and Control Unit (CU).
· ALU performs all the arithmetic and logic operations on the input data.
· CU controls the overall operations of the computer i.e. it checks the sequence of execution of instructions, and, controls and coordinates the overall functioning ofthe units of computer.
Additionally, CPU also has a set of registers for temporary storage of data, instructions,addresses and intermediate results of calculation.
Memory Unit Memory unit stores the data, instructions, intermediate results and output, temporarily, during the processing of data. This memory is also called the main memory or primary memory of the computer. The input data that is to be processed is brought into the main memory before processing. The instructions required for processing of data andany intermediate results are also stored in the main memory. The output is stored in memory before being transferred to the output device. CPU can work with the information stored in the main memory. Another kind of storage unit is also referred to as the secondary memory of the computer. The data, the programs and the output are stored permanently in the storage unit of the computer. Magnetic disks, optical disks and magnetic tapes are examples of secondary memory.

22. Draw the block diagram of a computer
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23. Explain briefly the developments in computer technology starting from a simple calculatingmachine to the first computer.
The key developments that took place till the first computer was developed are as follows—
· Calculating Machines ABACUS was the first mechanical calculating device for counting of large numbers. The word ABACUS means calculating board. It consists of bars in horizontal positions on which sets of beads are inserted. The horizontal bars have10 beads each, representing units, tens, hundreds, etc.
· Napier’s Bones was a mechanical device built for the purpose of multiplication in 1617ad. by an English mathematician John Napier.
· Slide Rule was developed by an English mathematician Edmund Gunter in the 16th century. Using the slide rule, one could perform operations like addition, subtraction, multiplication and division. It was used extensively till late 1970s.
· Pascal’s Adding and Subtraction Machine was developed by Blaise Pascal. It could addand subtract. The machine consisted of wheels, gears and cylinders.
· Leibniz’s Multiplication and Dividing Machine was a mechanical device that could both multiply and divide. The German philosopher and mathematician Gottfried Leibniz built it around 1673.
· Punch Card System was developed by Jacquard to control the power loom in 1801. He invented the punched card reader that could recognize the presence of hole in the punched card as binary one and the absence of the hole as binary zero.
· Babbage’s Analytical Engine An English man Charles Babbage built a mechanical machine to do complex mathematical calculations, in the year 1823. The machine was called as difference engine. Later, Charles Babbage and Lady
Ada Lovelace developed a general-purpose calculating machine, the analytical engine.
· Hollerith’s Punched Card Tabulating Machine was invented by Herman Hollerith. The machine could read the information from a punched card and

process it electronically.

These developments resulted in thedevelopment of the first computer in the 1940s.


24. Give full form of the following abbreviations
a. CPU
b. I/O
c. ALU
d. CU
A 1.Central Processing Unit
2. Input/Output
3. Arithmetic and Logic Unit 4, Control Unit

25. What is primary memory?

Primary memory is the main memory of computer. It is used to store data and instructions during the processing of data. Primary memory is semiconductor memory.
Primary memory is of two kinds—Random Access Memory (RAM) and Read OnlyMemory (ROM).

26. Two types of memory chips— Single In-line Memory Module (SIMM) and Dual In-line Memory Module (DIMM) are used in desktop computers.
27. List any three storage devices that are attached to the computer.

A 1.Hard disk drive,
2. floppy drive and
3. . optical disk drives

28. Show the memory hierarchy.
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Chapter 2

BASIC INTERNET SKILLS



Why this chapter

Every one of you has heard of the Internet and most of you would have used it. You connect to the Internet, maybe, from your home, school, college, or a cyber café. Once connected, you may browse the WWW, use the e-mail facility or chat with a friend. Internet is considered as an important part of the using of the computer. The purpose of this chapter is to introduce you to thebasics of the Internet and the services provided by the Internet.

INTRODUCTION
Internet is defined as an interconnection of networks. Internet allows computers on different kinds of networks to interact with each other. Any two computers, often having different software and hardware, can exchange information over the Internet, as long as they obey the technical rules of Internet communication. The exchange of information may be among connected computers located anywhere, like military and research institutions, different kinds of organizations, banks, educational institutions (elementary schools, high schools, colleges), publiclibraries, commercial sectors etc.

In 1980s, many Internet applications like electronic mail, newsgroups, file transfer facility and remote login were developed. The Electronic mail facility allowed users to compose, send, and receive messages. Users having common interests could exchange messages using forums like Newsgroups. The Telnet command allowed users to login to a remote computer. The File Transfer Protocol program was used to copy files from one computer to another on the Internet.
In the early 1990s, a new application World Wide Web (WWW) changed the way in which Internet was used. WWW is a system of creating, organizing, and linking documents, and was created by British scientist Tim Berners Lee. A protocol based on hypertext was developed that allowed the documents and content on WWW to be connected via hyperlink.
In 1993, Marc Andreessen at the University of Illinois developed the Mosaic browser. The WWW along with the browser made it possible to set up number of web pages that may consist of text, pictures or sound, and with link to other pages.

Internet and WWW which are interconnection of networks, and interconnection of

documentsand resources, respectively, has wired the whole world together.

CONNECTING TO INTERNET

To be able to connect your computer to the Internet, you require—(1) a TCP/IP enabled computer, (2) web browser software, (3) an account with an ISP, (4) a telephone line, and (5) a modem or Network Interface Card (NIC) to connect the telephone line to the computer (Figure2…1).


[image: ]

Figure 2.1 Connecting to Internet

INTERNET SERVICES

Internet is a huge de-centralized network that connects computers. Every computer connected tothe Internet has a unique address, which helps to identify the computer on the Internet uniquely. Over the years, Internet has grown as the biggest network for communication and provides several services to its users. Each service has its own features and uses. Some of the important services provided by Internet are—World Wide Web, electronic mail, news, chat, and discussiongroups.

World Wide Web (WWW)
WWW (also called as Web) is a large scale, online store of information. It is a system of creating, organizing, and linking of documents. Information is stored on WWW as a collection of  documents that are interconnected with each other via links. The interconnected documents may be located on one or more than one computer, worldwide, thus, the name world wide web. The features of WWW and terms linked to WWW are given below—
· The documents on web are created in hypertext format. Hypertext facilitates linking of documents.
· The language used to create a hypertext format document is HyperText Markup Language (HTML). HTML allows the designer of the document to

include text, pictures, video, images, sound, graphics, movies etc., and also to link contents on the same document or different documents using a hyperlink.
· The hypertext format document is transferred on the Web using HyperText Transfer Protocol
(HTTP).
· A single hypertext document is called a Web page (Figure 2.2).
· A group of related web pages is called a Web site. A web site displays related information on aspecific topic (Figure 2.3).
[image: ]


Figure 2.2 A web page

[image: ]

Figure 2.3 A web site
· The first web page or main page of a website is called Homepage.
· The web pages are stored on the Internet on the Web Server. Web servers are host computers that can store thousands of web pages.
· The process of storing a web page on a web server is called uploading.
· The process of retrieving a web page from a web server onto the user‘s computer is
downloading.
[image: ]

Figure 2.4 Web portal (http://www.google.co.in)

· The web pages stored on web server on the Internet, can be viewed from the user‘s computer using a tool called Web browser.
· Every web page is identified on Internet by its address, also called Uniform Resource Locator (URL).
· A web portal is a web site that presents information from different sources and makes them available in a unified way (Figure 2.4). A web portal enables the user to search for any type of information from a single location, i.e. the home page of the web portal. A web portal generally consists of a search engine, e- mail service, news, advertisements, and an extensive list of links to other sites etc. www.msn.com and www.google.co.in (igoogle) are popular web portals.

Web Browser
· Web Browser (or browser) is a software program that extracts information on user request from the Internet and presents it as a web page to the user. It is also referred to as the user interface of the web. Some of the popular web browsers are—Internet Explorer from Microsoft, Mosaic browser, Google‘s chrome, and Netscape Navigator from Netscape Inc. Some of the browser icons are shown in Figure 2.5.
· Browsers are of two types—graphical browser and text-based browser.
· Graphical browsers provide a graphical user interface where the user can jump from one web page to the other by clicking on the hyperlink (displayed in blue color with underline) on a web page. Internet Explorer, Chrome and Mosaic are examples of graphical browsers. (Figure 2.6)
[image: ]


Figure 2.5 Different browser icon
[image: ]

Figure 2.6 A GUI browser (Internet explorer)

· Text browsers are used on computers that do not support graphics. Lynx is a text browser.
· The process of using browser to view information on the Internet is known as Browsing or Surfing. During browsing, the user can navigate from one web page to another using URLs, hyperlinks, browser navigation tools like forward and back button, bookmarks etc.
Internet Search Engines
One of the most exciting things a user can do on the Internet is to search for information from multiple sources. There are hundreds of millions of web pages available, containing information on a wide variety of topics. There is no single catalog maintained (similar to a library) that lists all the web pages and their information. The user needs to search the Internet to find the information relevant to his/her requirement. Internet Search engines or Search engines are
specific web sites that help the users to find information stored on the Internet. Search engines (Figure 2.7(a)) search the Internet based on some important words (keywords) or combinations of words. Some of the common and well-known search engines are www.google.com, www.lycos.com and www.yahoo.com

Using the Search Engine: The user uses the search engine as follows:
· Enter the address of search engine, for example www.google.com
· Enter the word, or combinations of words, or symbols with words, based on which the Internet is to be searched. Some options for searching are shown in Table 2.1.
[image: ]


Table 2.1 Search engine options



Working of Search Engine: The search engines work as follows:

· Search engines maintain a data repository of words along with the URL‘s at

which these words are found.
· When the user uses the search engine to search for a word or group of words, the search engine checks its data repository and returns a list of URLs that satisfy the search. (Figure 2.7(b))
· To narrow down the scope of search, the search engines also provide different criteria for search. For example, some of the search criteria provided by Google search engine are Images, News, and Scholar to search for images, news, and published papers, respectively.
· Sites like www.msn.com are metasearch engines. Such sites do not maintain their own data repository, but send the search request to other search engines. The search results are collected from different search engines and displayed to the user.

[image: ]

Figure 2.7 (a) Search engine ―Bing‖ by Microsoft (b) Search result by ―Bing‖

Electronic Mail
Electronic mail (E-mail) is an electronic message transmitted over a network from one user to another. E-mail is a text-based mail consisting of lines of text, and can include attachments such as audio messages, pictures and documents. The features of e-mail are as follows:

· E-mail can be sent to one person or more than one person at the same time.
· Communicating via e-mail does not require physical presence of the recipient. The recipient canopen the e-mail at his/her convenience.
· Since messages are transmitted electronically, e-mail is a fast way to communicate with the people in your office or to people located in a distant country, as compared to postal system.
· E-mail messages can be sent at any time of the day.
· A copy of e-mail message that the sender has sent is available on the senders computer for later reference.
· In addition to sending messages, e-mail is an ideal method for sending documents already on the computer, as attachments. E-mail has features of the regular postal service. The sender of e-mail gets the e-mail address of the recipient, composes the message and sends it. The recipient of e-mail can read the mail, forward it or reply back. The recipient can also store the e-mail or delete it.
E-mail Address
To use e-mail, a user must have an e-mail address. The e-mail address contains all information required to send or receive a message from anywhere in the world. An e- mail address consists of two parts separated by @ symbol (spelled as at)—the first part is user_name and the second part is host computer name. The e-mail address may look like

abcdgoel@gmail.com

where, abcdgoel is the user_name,
gmail.com is the host computer name (domain name) i.e. the mailbox where finally the mail willbe delivered. gmail is the mail server where the mailbox ―abcdgoel‖ exists.
E-mail Message Format
The e-mail message consists of two parts-header and body. The header contains information about the message, such as—
· From—Sender‘s e-mail address.
· To—Recipient‘s e-mail address.
· Date—When the e-mail was sent.
· Subject—The topic of the message.
· Cc—Addresses where carbon copies of the same e-mail will be sent. The recipients of e-mail can see all e-mail addresses to which the copies have been sent.
· Bcc—Addresses where Blind carbon copies (Bcc) of the same e-mail will be sent. The recipients of e-mail do not know that the same e-mail has been sent to other e-mail addresses.
· The size of e-mail.
The body contains the text of the message and any attachments to be sent. Figure 2.8 shows the ―compose mail‖ on gmail.com to create a new e-mail message.

[image: ]

Figure 2.8 The ―compose mail‖ screen on gmail
E-mail Services
There are two kinds of e-mail services—Application-based e-mail, and Web-based e-mail.
· Application-based e-mail is installed onto the user‘s computer. The mail is stored on the user‘s computer. For using an application based e-mail, the user uses a program such as Microsoft Outlook, Outlook Express etc. The user must have an e-mail account on the Internet mail server with a domain name (e.g. vsnl.com), which is provided by the ISP whose services the user is using to connect to the Internet. The user also has an e-mail address (create e-mail address by adding your username to e-mail server‘s domain name. E.g. aagoel@vsnl.com), which identifies the user uniquely on the e-mail server.
· Web-based e-mail or Webmail appears in a web browser‘s window. A web-based e-mail can be accessed by the user from any Internet-connected computer anywhere in the world. Web-based e-mail is not stored on the user‘s computer. Many free web-based e-mail services are available. Hotmail, yahoo, and gmail provide free e-mail accounts. An example of web-based e-mail address is ashima1234@gmail.com.

Attaching documents with E-mail

An email attachment is a file that one person sends to another with an accompanying email. Its purpose is usually to enhance the value or benefit that the email offers the reader by providing additional content that you can't express in the body of the email. The attachment can have different formats and sizes, with the most typical attachments being large text files, various types of documents, spreadsheets, scanned files, forms, pictures and videos.
Consider these five steps when composing and sending an email containing an attachment:
1. Determine what files you wish to send



Before writing the email, you should know exactly what file you are about to send and where it is located on your device's hard drive or memory drive. Knowing what file or files you are about to send is important because you need to mention them in the email's text, and knowing their location can help you quickly locate and attach them before sending the email.

2. Write the email's subject line
The next step is composing the email's subject line. As many potential recipients tend to disregard emails with attachments unless they know what the attached files are, the email's subject should reflect the fact that it contains one or more attached files and provide information regarding what they are.
3. Compose the email's body
If the attachments are the only reason you need to send a message, the email's body can simply be a brief description of the attached files. If the attached files are only a part of what the email aims to transmit, they need to be mentioned somewhere in the body, ideally with a short sentence that specifies what they are. Sending an email with attachments and no text is not recommended, as the recipient or their email provider may confuse them with spam.
4. Attach the files
After composing the email, the final step before sending it is attaching the necessary file or files. However, this step can take place at any time during the composing and sending process. Many senders prefer to attach the files before writing the email because it eliminates the risk of forgetting to attach them altogether.
5. Review and send the email
Once the email's subject and body are written and the files are attached, you can do a quick proofread and send the email to the recipient.











Gmail

Gmail is a free email service provided by Google. In many ways, Gmail is like any other email service: You can send and receive emails, block spam, create an address book, and perform other basic email tasks. But it also has some more unique features that help make it one of the most popular online email services.

[image: ]
Creating a Google account is needed to access Gmail because it is just one of the many services offered by Google to registered users. Signing up for a Google account is free and easy, and naming your new Gmail address will be a part of the sign-up process. This means whenever you're signed in to Gmail, you are automatically signed in to your Google account. You'll be able to easily access other Google services like Google Docs, Calendar, and YouTube.

Creating a Google account

In order to use Google Drive, you will need a Google account. Google accounts are free, and signing up for one is fairly simple. In order to create a Google account, you'll need to enter some information, including your name, birth date, and location. Creating a Google account will automatically create a Gmail email address and a Google+ profile.

If you have a Gmail address, you already have a Google account, so you won't need to create an account—you can simply sign in to Drive using your Gmail information.

To create a Google account:
1. Go to www.google.com. Locate and select the Sign in button in the top-right corner of the page.
[image: Sign in button. ]

2. Click Create an account.

3. The sign-up form will appear. Follow the directions and enter the required information.

[image: Sign up form.]


4. Next enter your phone number. Google will send a verification code to your phone that you will use to complete the sign up process.
5. Enter the verification code sent to your phone and click Verify.
6. The personal information page will appear. Follow the directions and enter your information, including your birth date and gender.
7. Review Google's Terms of Service and Privacy Policy, then click I agree.

8. Your account will be created.
Just like with any online service, it's important to choose a strong password—in other words, one that's difficult for someone to guess.
When you're working with Gmail, you'll primarily be using the main Gmail interface. This  window  contains  your inbox,  and  it  allows  you  to  navigate  to your contacts, mail settings, and more. Also, if you use other Google services like YouTube or Calendar, you'll be able to access them from the top of the Gmail window.

Google Drive

Google Drive is a free service from Google that allows you to store files online and access them anywhere using the cloud. Google Drive also gives you access to free web-based applications for creating documents, spreadsheets, presentations, and more.

Google Drive is one of the most popular cloud storage services available today. If you've never used a  cloud-based  storage  service  like  Google  Drive  before,  take  a  moment  to  consider the advantages of keeping your files online. Because files can be accessed from any computer with an Internet connection, Drive eliminates the need to email or save a file to a USB drive. And because Drive allows you to share files, working with others becomes much easier.

Creating files on Google Drive

Google  Drive  doesn't  just  store  your  files;  it  also  allows  you  to create, share, and manage documents with its own productivity apps. If you've ever used a suite like Microsoft Office, some things about Google Drive's apps might seem familiar. For instance, the types of files you can work with are similar to files that can be created with various Microsoft Office programs.

Below are the types of files you can create and share on Google Drive:

· [image: google docs logo] Documents: For composing letters, flyers, essays, and other text-based files (similar to Microsoft Word documents)
· [image: google sheets logo] Spreadsheets: For storing and organizing information (similar to Microsoft Excel workbooks)
· [image: google slides logo] Presentations: For	creating	slideshows	(similar	to	Microsoft	PowerPoint presentations)
· [image: google forms logo] Forms: For collecting and organizing data
· [image: google drawings logo] Drawings: For creating simple vector graphics or diagrams
Once  you've  set  up  your  Google  account,  you  can  access Google  Drive by  going to http://drive.google.com in your web browser.

You can also navigate to Google Drive from any Google page (such as Gmail or Google search) by selecting the grid icon near the top-right corner, then clicking Drive.

[image: ]



Your Google Drive may be empty right now, but as you begin to upload and create files you'll need to know how to view, manage, and organize them in the interface.

GOOGLE CALENDAR



Get started with Google Calendar

You can use Google Calendar to keep track of all your events.
Get Google Calendar
1. On your computer, visit Google Calendar.
2. If you already have a Google Account, sign in. If you don't have one yet, click Create an account.
3. Once you sign in, you'll be taken to Google Calendar.
4. To change any of your settings, go to the top right corner and click Settings [image: Settings] .
Browsers that work with Calendar
Note: JavaScript and cookies need to be turned on for the browser you're using.

Google Calendar works with current and major previous versions of these browsers:
· Google Chrome
· Microsoft Edge
· Firefox
· Safari Uses
· Automatically get events from Gmail on your calendar
· Share your calendar with others
· Get notifications for upcoming events



Create a new calendar

You can create calendars to keep track of different types of events. For example, you could create a calendar called "Soccer" that tracks upcoming practices and games.
Set up a new calendar
You can only create new calendars from a browser and not from the Google Calendar app. Once the calendar is created, you can find it on your browser and in the app.
1. On your computer, open Google Calendar.
2. On the left, next to "Other calendars," click Add other calendars [image: Plus]	[image: and then] Create new calendar.
3. Add a name and description for your calendar.
4. Click Create calendar.
5. If you want to share your calendar, click on it in the left bar, then select Share with specific people.
Tip: After you create and share a calendar, you can schedule events for that calendar.
.
Find the calendars you've created
1. On your computer, open Google Calendar.
2. On the left side of the page, under "My calendars," there's a list of calendars you created.
3. To show or hide that calendar's events, click the calendar's name.
4. To remove a calendar from your list, next to the calendar's name, click Options [image: More]	[image: and then] Hide from list.
Edit your calendar's name
1. Open Google Calendar .
2. On the left side of the page, under "My calendars," find your calendar.

3. Next to your calendar, click Options [image: More]	[image: and then] Settings and sharing.
4. In the box at the top, choose a new name.
Change your calendar‘s color
1. Open Google Calendar.
2. On the left side of the page, under "My calendars," find your calendar.
3. Next to your calendar, click Options [image: More]  .
4. Pick the color for your calendar or click Add custom color [image: Plus]

GOOGLE SITES

Build internal project hubs, team sites, public-facing websites, and more—all without designer, programmer, or IT help. With Google Sites, building websites is easy. Just drag content where you need it.
When you create a new site, it‘s automatically added to Drive, like your other files stored in Drive. You can edit a Google Site together with someone else in real time, and see each other‘s changes live. Publish the site for everyone to see, or restrict sharing permissions and make the site accessible only to people you want to share it with, like vendors or suppliers.
Google Sites websites are responsive, which means they‘re optimized for tablets and smartphones, too.
Create your site
1 Choose an option:
· From	the Sites	homepage,	at	the	top,	click Create [image: Plus] ,	or	to	choose	a	template, click Template gallery and select a template.
· From Google Drive, click [image: Plus] New	More	Google Sites.
Note: All Sites are stored in Drive.
2 Name your site
When you create a new site, it's added to Drive, just like other Drive files. Sites automatically saves every change you make, but your site isn‘t public until you publish it.
Name different parts of your site:
	Site document name—Enter a unique name to keep track of your site. The site document name is only visible to you.

	Site name—The site name appears in the header and in the web or mobile window title bar after you publish the site. You need to have 2 or more pages in your website for your site name to appear.

	Page title—Each page in your site has a title, which appears at the top of the page. The page title also appears in the navigation menu.



[image: Document, site, and page names mapped, top to center]
3 Select a layout
On the right, click Layouts and choose a different layout for your sections.
4 Select a background image, header type, and theme
Choose a look for your site. Each theme comes with a preset background, color scheme, and font selection. You can adjust fonts, colors, and the background later, and you can always change the theme after the site is created. If you need to make any changes, click Undo  , or Redo  .

	Change the background image:
1. Go to Sites and open your site.
2. Point to the background image and click Change image	.
3. Choose an option:
· To upload an image from your computer, click Upload.
· To choose an image from the gallery or another location, click Select image.
4. (Optional) To go back to the original background image, click Reset	.

	Change the header type:

1. Point to the background image and click Header type [image: Header] .
2. Choose an option:
· Cover
· Large banner
· Banner
· Title only

	Change the theme and font style:
1. In the top-right corner, click Themes.
2. Select a theme option and choose a color.
3. Click Font style and select a style.



[image: Options to change image, header type, theme, and font style mapped]

5 Add, reorder, and nest pages
Add pages for more content. Keep related information together by nesting pages. Nested pages appear as a subtopic of another page.

	Add pages:

1. In the top-right corner, click Pages [image: and then] point to Create	.
2. Choose an option:
· To add a new page, click Add page	. Name the page and click Done.
· To add a URL, click Add link [image: Link] .

	Reorder or nest pages:
1. Click Pages.
2. Drag a page up or down in the list to reorder it.
3. Drag a page on top of another page to nest it.
4. (Optional) To un-nest a page, drag it to the bottom of the list.
Note: You can only nest a page five levels deep.

	Choose page options:

Under Pages, select a page and next to it, click More [image: More]  and choose an option:
· Set it as the homepage.
· Duplicate the page.
· Rename the page.
· Create a subpage.
· Hide a page or subpage. You can‘t hide the page that‘s set as your homepage.
· Delete the page from the site. You can‘t remove the page that‘s set as your homepage.



[image: Menu options 1, 2, and 3 mapped ]

6 Set up site navigation
If you've more than one page, visitors to your site use the navigation menu to jump to different pages. By default, the navigation menu is at the top of your site. In the top-right corner, click your homepage to see the menu.
You can move the navigation menu to the left side if you want, but you need to have one or more pages on your site to change where it appears.
Select a navigation mode:

1. Point	to	the	site	name	and	click	Navigation	settings	Top	navigation or Side navigation.
2. (Optional) To move the pages in the navigation menu, see  5 Add, reorder, and nest pages.





GOOGLE SHEETS

Google Sheets allows you to organize, edit, and analyze different types of information using spreadsheets.

Google Sheets is a web-based spreadsheet application that allows you to store and organize different types of information, much like Microsoft Excel. While Google Sheets does not offer all of Excel's advanced features, it's easy to create and edit spreadsheets ranging from the simple to the complex.

While you might think spreadsheets are only used by certain people to process complicated numbers and data, they can actually be used for a variety of everyday tasks. Whether you're starting a

budget, planning a garden, or creating an invoice or just about anything else you can think of, spreadsheets are a great way to organize information.

To create a new Google spreadsheet:
1. While viewing your Google Drive, click New and select Google Sheets from the drop- down menu.
[image: Creating a new spreadsheet]
2. The spreadsheet will appear in a new browser tab.

[image: The new spreadsheet]
3. To name your spreadsheet, locate and select Untitled spreadsheet at the top of the page. Type a name for your spreadsheet, then press Enter on your keyboard.
[image: Renaming a new spreadsheet]
4. Your spreadsheet will be renamed.
[image: The renamed spreadsheet]

5. Whenever you need to view or edit your spreadsheet, you can access it again from your Google Drive, where it will be saved automatically.
[image: The newly created file in your Google Drive]

[image: The auto-save feature]You may notice that there is no save button. This is because Google Drive uses autosave, which automatically and immediately saves your files as you edit them.


GOOGLE MEET

How to Join a Meeting

When you can't meet in person, video chatting is a good alternative. Google Meet is a video calling service which allows you to connect face-to-face. Joining a Google Meet call is easy to do, and all you'll need is a link or code.
Entering by Email Invitation

First, log into your Google account.
Next you'll need to navigate to your inbox and open the Google Meet email invitation. From the email invitation, click the link to the Google Meet.
Some pop-ups may occur if you haven't used Google Meet before. Click Allow to approve the use of your camera, microphone, and notifications.
Before entering the meeting, you can select the sound and video settings you want to use. You can choose to join the meeting with your microphone and camera on or off by clicking their icons. You can always change these options inside the video call, too.

If you're using Chrome as your browser, you can also click the visual effects icon in the lower right corner. This will allow you to blur your background, choose a unique one, or use a style filter.
[image: https://media.gcflearnfree.org/content/601bfd264136932698f4bda9_02_04_2021/visual%20effects.jpeg]

· Once you have selected your settings, click Join now.
[image: https://media.gcflearnfree.org/content/601bfd264136932698f4bda9_02_04_2021/join%20now.png]

Video Call Basics

· Once you've joined the call, you'll see your video tile as well as the tiles of the people you're chatting with on your desktop screen.
[image: https://media.gcflearnfree.org/content/601bfd264136932698f4bda9_02_04_2021/google_meet_video_tiles-overlay.jpeg]
· To see the bottom toolbar, hover your mouse over the Google Meet window. You can turn your microphone and camera on or off at any time just by clicking their icons.
[image: https://media.gcflearnfree.org/content/601bfd264136932698f4bda9_02_04_2021/google_meet_video_tiles-overlay.png]
· On the bottom toolbar, click the three dots icon. A pop-up menu appears showing other features. We'll talk more about Settings later in this lesson.

[image: https://media.gcflearnfree.org/content/601bfd264136932698f4bda9_02_04_2021/google_meet_settings-overlay.png]



Typing a Message in the Chat
· Navigate to the right-hand corner of the bottom toolbar. You can see written messages by clicking the chat icon.
[image: https://media.gcflearnfree.org/content/601bfd264136932698f4bda9_02_04_2021/chat_overlay.png]

· Type your message in the field. Then click the arrow button to send it to everyone on the video call. You can also read and respond to messages from other participants, too.

[image: typing a message and sending it by clicking the arrow button]
· To close out of the chat box, click the X.
[image: closing the Chat pane]



Adjusting Settings
· On the bottom toolbar, click the three dots icon followed by Settings.
[image: https://media.gcflearnfree.org/content/601bfd264136932698f4bda9_02_04_2021/google_meet_settings-overlay.jpg]
· In Settings,  make  sure  you  have  the  correct  equipment  selected for your Audio and Video.
· In Audio, you can Test your speakers to make sure they're working properly. Double- check Settings if you find yourself unable to hear who you are talking to, or if they say that they can‘t hear or see you.

[image: testing speakers]
· To close out of Settings, click the X.

Ending the Video Call

Hover your mouse over the Google Meet window to make the bottom toolbar appear. When you're ready to end the video call, click the red Leave call icon.
[image: https://media.gcflearnfree.org/content/601bfd264136932698f4bda9_02_04_2021/leave%20call.png]

SUMMARY
· Internet is a network of interconnected networks.
· Internet services include the WWW, e-mail, telnet, news, ftp, IRC etc.
· WWW is a system of creating, organizing and linking of documents. It is large scale collection of documents located worldwide. Hence the name World Wide Web.
· Web browser is a tool used by user to view web documents on the Internet. Using web browser to view information on the Internet is known as browsing or surfing.
· Internet search engines are web sites used for searching specific documents on the web.
· Web development languages like HTML, DHTML and XML are used to design and develop the web pages. Scripting languages like Javascript, Java applets and VBscript are used for client side programming. Perl, PHP, server side VBscript, JSP, ASP, and Ruby on Rails are some server side programming languages.

· E-mail is an electronic message transmitted over a network from one user to another. The e- mail message consists of the e-mail header and the e-mail body. E-mail header contains information about the message. E-mail body contains message text and attachment to be sent.

· Gmail is a free email service provided by Google. You can send and receive emails, block spam, create an address book, and perform other basic email tasks.

· Google Drive is a free service from Google that allows you to store files online and access them	anywhere using the cloud. Google Drive also gives you access to free		web-based	applications for creating documents, spreadsheets, presentations, and more.

· Google Calendar is a service developed by Google to keep track of all your events.

· Google Sites is used to build internal project hubs, team sites, public-facing websites, and more—all without designer, programmer, or IT help.
· Google Sheets is a web-based spreadsheet application that allows you to store and organize different types of information, much like Microsoft Excel
· Google Meet is a video calling service which allows you to connect face-to-face.





QUESTIONS


1. Define: (1) Internet, (2) WWW.
Internet is defined as an interconnection of networks. Internet allows computers on different kinds of networks to interact with each other.
WWW is a system of creating, organizing, and linking documents, and was created by British scientist Tim Berners Lee.

2. Name the scientist who created WWW.
WWW was created by British scientist Tim Berners Lee.
3. The Mosaic browser was developed by Marc Andreessen .
4. What is Google Sheets?

Google Sheets is a web-based spreadsheet application that allows you to store and organize different types of information, much like Microsoft Excel

5. What is Google meet?
Google Meet is a video calling service which allows you to connect face-to-face.

6. What is the use of web browser?

Web Browser (or browser)is used to extract information on user request from the Internet and presents it as a web page to the user.

7. What is a web portal?
A web portal is a web site that presents information from different sources and makes them available in a unified way. A web portal enables the user to search for any type of information from a single location
8. Define—web browser.
Web Browser (or browser) is a software program that extracts information on user request from the Internet and presents it as a web page to the user. It is also referred to as the user interface of the web.

9. Name two web browsers. Internet Explorer from Microsoft Google‘s chrome
10. Why is there a need of Internet search engine?
Internet Search engines are specific web sites that help the users to find information stored on the Internet. As there are hundreds of millions of web pages available, containing information on a wide variety of topics and no single catalog maintained (similar to a library) that lists all the web pages and their information, Search engines search the Internet based on some important words (keywords) or combinations of words. Some of the common and well-known search engines are www.google.com, www.lycos.com and www.yahoo.com
1. Give examples of two Internet search engines.
www.google.com, and www.yahoo.com
2. List four features of e-mail?
The features of e-mail are as follows:

· E-mail can be sent to one person or more than one person at the same time.
· Communicating via e-mail does not require physical presence of the recipient. The recipient canopen the e-mail at his/her convenience.
· E-mail messages can be sent at any time of the day.
· A copy of e-mail message that the sender has sent is available on the senders computer for later reference.
· In addition to sending messages, e-mail is an ideal method for sending documents already on the computer, as attachments.
· The recipient can also store the e-mail or delete it.


3. Explain the syntax of e-mail address with example.
An e-mail address consists of two parts separated by @ symbol (spelled as at)—the first part	is user_name and the second part is host computer name. The e-mail

address may look like

abcdgoel@gmail.com
where, abcdgoel is the user_name,gmail.com is the host computer name (domain name) i.e. the mailbox where finally the mail will be delivered. gmail is the mail server where the mailbox
―abcdgoel‖ exists.

4. What is the difference between Cc and Bcc in an e-mail header?
Cc—Addresses where carbon copies of the same e-mail will be sent. The recipients of e-mail cansee all e-mail addresses to which the copies have been sent.
Bcc—Addresses where Blind carbon copies (Bcc) of the same e-mail will be sent. The recipients of e-mail do not know that the same e-mail has been sent to other e-mail addresses.


5. Differentiate between application based e-mail and web based e-mail?
· Application-based e-mail is installed onto the user‘s computer. The mail is stored on the user‘s computer. For using an application based e-mail, the user uses a program such as Microsoft Outlook, Outlook Express etc. The user must have an e-mail account on the Internet mail server with a domain name (e.g. vsnl.com), which is provided by the ISP whose services the user is using to connect to the Internet. The user also has an e-mail address (create e-mail address by adding your username to e-mail server‘s domain name. E.g. aagoel@vsnl.com), which identifies the user uniquely on the e-mail server.
· Web-based e-mail or Webmail appears in a web browser‘s window. A web-based e-mail can be accessed by the user from any Internet-connected computer anywhere in the world. Web-based e-mail is not stored on the user‘s computer. Many free web-based e-mail services are available. Hotmail, yahoo, and gmail provide free e-mail accounts. An example of web-based e-mail address is ashima1234@gmail.com.


6. What information is stored in the e-mail header?
The header contains information about the message, such as—
· From—Sender‘s e-mail address.
· To—Recipient‘s e-mail address.
· Date—When the e-mail was sent.
· Subject—The topic of the message.
· Cc—Addresses where carbon copies of the same e-mail will be sent. The recipients of e-mail can see all e-mail addresses to which the copies have been sent.
· Bcc—Addresses where Blind carbon copies (Bcc) of the same e-mail will be sent. The recipients of e-mail do not know that the same e-mail has been sent to other e-mail addresses.

· The size of e-mail.


7. What is Gmail ?
Gmail is	a	free	email	service	provided	by	Google.	You	can send and receive emails, block spam, create an address book, and perform other basic email tasks.
8. What is Google calendar and its uses?
Google Calendar is a service developed by Google to keep track of all your events.
	Uses
· Automatically get events from Gmail on your calendar
· Share your calendar with others
· Get notifications for upcoming events

9. What is a Google site and how to create it?
Google Sites is used to build internal project hubs, team sites, public-facing websites, and more—all without designer, programmer, or IT help. When you create a new site, it‘s automatically added to Drive, like your other files stored in Drive. You can edit a Google Site together with someone else in real time, and see each other‘s changes live. Publish the site for everyone to see, or restrict sharing permissions and make the site accessible only to people you want to share it with, like vendors or suppliers.
Create your site
1 Choose an option:
· From	the Sites	homepage,	at	the	top,	click Create [image: Plus] ,	or	to	choose	a	template, click Template gallery and select a template.
· From Google Drive, click [image: Plus] New	More	Google Sites.
2 	Name your site Name different parts of your site i.e Site document name, Site name and page title
3 Select a layout
On the right, click Layouts and choose a different layout for your sections.
4 Select a background image, header type, and theme
Choose a look for your site. Each theme comes with a preset background, color scheme, and font selection. You can adjust fonts, colors, and the background later, and you can always change the theme after the site is created. If you need to make any changes, click Undo  , or Redo  .

5 Add, reorder, and nest pages
Add pages for more content. Keep related information together by nesting pages. Nested pages appear as a subtopic of another page.


6 Set up site navigation
If you've more than one page, visitors to your site use the navigation menu to jump to different pages. By default, the navigation menu is at the top of your site. In the top-right corner, click your homepage to see the menu.
You can move the navigation menu to the left side if you want, but you need to have one or more pages on your site to change where it appears.
Select a navigation mode:

3. Point	to	the	site	name	and	click	Navigation	settings	Top	navigation or Side navigation.
4. (Optional) To move the pages in the navigation menu, see  5 Add, reorder, and nest pages.
10. List and explain types of web browsers

Browsers are of two types—graphical browser and text-based browser. Graphical browsers provide a graphical user interface where the user can jump from one web page to the other by clicking on the hyperlink (displayed in blue color with underline) on a web page. Internet Explorer, Chrome and Mosaic are examples of graphical browsers.
Text browsers are used on computers that do not support graphics. Lynx is a text browser.

Chapter 3:
BASIC LOGIC BUILDING



Contents

· Introduction to Programming
· Steps involved in problem solving—Problem analysis, program design, program development, program documentation and maintenance
· Algorithm- Steps involved in algorithm development
· Control structures—Sequential, selection (branch or conditional), iterative (loop)
· Flowchart—Flowchart symbols, preparing a flowchart
Introduction to Programming

A program is a set of instructions written for performing a specific task. However, writing a goodprogram is not a straightforward task. For writing a program, we have to follow the program development life cycle which includes choosing a programming paradigm, and selecting a computer programming language in which to write the program. With practice, you can easily acquire the skill of program writing. The purpose of this chapter is to introduce you to the basic logic building.

Computer is an electronic device that accepts data, processes it, and generates the relevant output. It can perform both simple and complex tasks with very high speed and accuracy. However, a computer cannot perform any task—simple or complex, of its own. Computers needto be instructed about ―how‖ the task is to be performed. The set of instructions that instruct the computer about the way the task is to be performed is called a program. A program is required for processing all kind of tasks—simple tasks like addition of two numbers, and complex tasks like gaming etc.

In this chapter, we will discuss the steps that are followed while writing a computer program. A brief description of different programming constructs is also presented. We will also learn logic building using flowchart and algorithm.

PROGRAM DEVELOPMENT LIFE CYCLE – Steps involved in problem solving

As stated earlier, a program is needed to instruct the computer about the way a task is to beperformed. The instructions in a program have three essential parts:
1. Instructions to accept the input data that needs to be processed,
2. Instructions that will act upon the input data and process it, and
3. Instructions to provide the output to user
The instructions in a program are defined in a specific sequence. Writing a computer program is not a straightforward task. A person who writes the program (computer programmer) has to follow the Program Development Life Cycle.

Let‘s now discuss the steps that are followed by the programmer for writing a program:

· Problem Analysis—The programmer first understands the problem to be solved. The programmer determines the various ways in which the problem can be solved, and decides upon a single solution which will be followed to solve the problem.
· Program Design—The selected solution is represented in a form, so that it can be coded. This requires three steps—
· An algorithm is written, which is an English-like explanation of the solution.
· A flowchart is drawn, which is a diagrammatic representation of the solution. The solution is represented diagrammatically, for easy understanding and clarity.

· Program Development
· The computer programming languages are of different kinds—low-level languages, and high- level languages like C, C++ and Java. The pseudo code is coded using a suitable programming language.
· The program is compiled for any syntax errors. Syntax errors arise due to the incorrect use of programming language or due to the grammatical errors with respect to the programming language used. During compilation, the syntax errors, if any, are removed.
· The successfully compiled program is now ready for execution.
· The executed program generates the output result, which may be correct or incorrect. The program is tested with various inputs, to see that it generates the desired results. If incorrect results are displayed, then the program has semantic error (logical error). The semantic errors are removed from the program to get the correct results.
· The successfully tested program is ready for use and is installed on the user‘s machine.
· Program Documentation and Maintenance—The program is properly documented, so that later on, anyone can use it and understand its working. Any changes made to the program, after installation, forms part of the maintenance of program. The program may require updating, fixing of errors etc. during the maintenance phase.

Table 3.1 summarises the steps of the program development cycle.

Program Analysis	• Understand the problem
· Have multiple solutions
· Select a solution
Program Design	• Write Algorithm
· Write Flowchart
Program Development	• Choose a programming language
· Write the program by converting the pseudo code, and then using the programming language.

· Compile the program and remove syntax errors, if any
· Execute the program.
· Test the program. Check the output results with different inputs. If the output is incorrect, modify the program to get correct results.
· Install the tested program on the user‘s computer.

Program Documentation	• Document the program, for later use.
And maintenance	• Maintain the program for updating, removing errors, changing requirements etc.
Table 3.1 Program development life cycle

ALGORITHM
Algorithm is an ordered sequence of finite, well defined, unambiguous instructions for completing a task. Algorithm is an English-like representation of the logic which is used to solve the problem. It is a step- by-step procedure for solving a task or a problem. The steps must be ordered, unambiguous and finite in number.

For accomplishing a particular task, different algorithms can be written. The different algorithms differ in their requirements of time and space. The programmer selects the best-suited algorithm for the given task to be solved.

Let‘s now look at two simple algorithms to find the greatest among three numbers, as follows:

Algorithm to find the greatest among three numbers—ALGORITHM 1. Step 1: Start

Step 2: Read the three numbers A, B, C

Step 3: Compare A and B. If A is greater perform step 4 else perform step 5.

Step 4: Compare A and C. If A is greater, output ―A is greatest‖ else output ―C is greatest‖. Perform step 6.

Step 5: Compare B and C. If B is greater, output ―B is greatest‖ else output ―C is greatest‖. Step 6: Stop


ALGORITHM 2.

Step 7: Start

Step 8: Read the three numbers A, B, C

Step 9: Compare A and B. If A is greater, store A in MAX, else store B in MAX.

Step 10: Compare MAX and C. If MAX is greater, output ―MAX is greatest‖ else output
―C isgreatest‖.

Step 11: Stop
Both the algorithms accomplish the same goal, but in different ways. The programmer selects thealgorithm based on the advantages and disadvantages of each algorithm. For example, the first algorithm has more number of comparisons, whereas in the second algorithm an additional variable MAX is required.



CONTROL STRUCTURES

The logic of a program may not always be a linear sequence of statements to be executed in that order. The logic of the program may require execution of a statement based on a decision. It may repetitively execute a set of statements unless some condition is met. Control structures specify the statements to be executed and the order of execution of statements.

Flowcharts use control structures for representation. There are three kinds of control structures:

· Sequential—instructions are executed in linear order
· Selection (branch or conditional)—it asks a true/false question and then selects the next instruction based on the answer
· Iterative (loop)—it repeats the execution of a block of instructions.

FLOWCHART
A flowchart is a diagrammatic representation of the logic for solving a task. A flowchart is drawn using boxes of different shapes with lines connecting them to show the flow of control. The purpose of drawing a flowchart is to make the logic of the program clearer in a visual form. There is a famous saying S―A photograph is equivalent to thousand wordsS‖. The same can be said of flowchart. The logic of the program is communicated in a much better way using a flowchart. Since flowchart is a diagrammatic representation, it forms a common medium of communication.
Flowchart Symbols
A flowchart is drawn using different kinds of symbols. A symbol used in a flowchart is for a specific purpose. Figure 3.1 shows the different symbols of the flowchart along with their names. The flowchart symbols are available in most word processors including MS-WORD, facilitating the programmer to draw a flowchart on the computer using the word processor.

A single line description of the flowchart symbols is given in Table 3.2.

Preparing a Flowchart
A flowchart may be simple or complex. The most common symbols that are used to draw a flowchart are—Process, Decision, Data, Terminator, Connector and Flow lines. While drawing aflowchart, some rules need to be followed—(1) A flowchart should have a start and end, (2) The direction of flow in a flowchart must be from top to bottom and left to right, and (3) The relevant symbols must be used while drawing a flowchart. While preparing the flowchart, the sequence, selection or iterative structures may be used wherever required. Figure 8.2 shows the sequence, selection and iteration structures.
[image: ]

Figure 3.1 Flowchart symbols (available for use in MS-WORD) Process—operation or action step	Decision—decision or a branch Alternate Process—alternate to normal process	Data—I/O to or from a process Document—a document	Manual Input—Data entry from a form
Multi document—more than one document	Manual	Operation—operation	to	be done manually Preparation—set-up process	Connector—join flow lines
Punched Tape—I/O from punched tape	Off	page	connector—continue	on

another page Collate—organize in a format	Summing	Junction—Logical	AND Merge—
merge in a predefined order	OR—Logical OR
Sort—sort in some order	Sequential Access storage—stored on magnetic tape Display—display output	Stored Data—general data storage
Predefined process—process previously specified Magnetic Disk—I/O from magnetic disk Internal Storage—stored in memory Direct access storage— storing on hard disk Termination—start or stop point Flow  lines—indicates direction of flow Delay—wait	Extract—split process
Card—I/O from a punched card


Table 3.2 Description of flowchart symbols

Figure 3.2 Control structures in flowchart

We see that in a sequence, the steps are executed in linear order one after the other. In aselection operation, the step to be executed next is based on a decision taken. If the condition is true (yes) a different path is followed than if the condition evaluates to false (no). In case of iterative operation, a condition is checked. Based upon the result of this conditional check, true or false, different paths are followed. Either the next step in the sequence is executed or the control goes back to one of the already executed steps to make a loop.

Here, we will illustrate the method to draw flowchart, by discussing three different examples. To draw the flowcharts, relevant boxes are used and are connected via flow lines. The flowchart forthe examples is shown in Figure 8.3.

[image: ]

Figure 3.3 Examples of flowchart

· The first flowchart computes the product of any two numbers and givesthe result. The flowchart is a simple sequence of steps to be performed in a sequential order.
· The second flowchart compares three numbers and finds the maximum of the three numbers. This flowchart uses selection. In this flowchart, decision is taken based upon a condition, which decides the next path to be followed, i.e. If A is greater than B then the true (Yes) path is followed else the false (No) path is followed. Another decision is again made while comparing MAX with C.
· The third flowchart finds the sum of first 100 integers. Here, iteration (loop) is performed so that some steps are executed repetitively until they fulfill some condition to exit from the repetition. In the decision box, the value of I is compared with 100. If it is false (No), a loop is created which breaks when the condition becomes true (Yes).

Flowcharts have their own benefits; however, they have some limitations too. A complex and long flowchart may run into multiple pages, which becomes difficult to understand and follow. Moreover, updating a flowchart with the changing requirements is a challenging job.

Difference between Algorithm and Flowchart: An algorithm is a sequence of instructions used to solve a particular problem. Flowchart is tools to document and represent the algorithm. In other words, an algorithm can be represented using a flowchart. Flowchart is a graphical representation of the algorithm. Flowchart is a pictorial representation of the algorithm. Flowchart uses structured constructs of the programming language for representation. The user does not require the knowledge of a programming language to write or understand a flowchart.

SUMMARY
· Program is a set of instructions that instruct the computer about the way the task is to be performed.
· Program development life cycle consists of—analyze problem to select a solution, write algorithm, draw flowchart and write pseudo code for the selected solution, write program code in a programming language, remove syntax and semantic errors, and install successfully tested program. Also, document the program to make program maintenance easy.
· Algorithm is an ordered sequence of finite, well-defined, unambiguous instructions for completing a task.
· Control structures specify the statements that are to be executed and the order of the statements that have to be executed. Sequential, selection, and iteration are three kinds of control structures.
· Flowchart is a diagrammatic representation of the logic for solving a task. Flowchart is a tool to document and represent the algorithm. Flowchart is drawn using the flowchart symbols.
QUESTIONS

1. Define a program.
A program is a set of instructions written for performing a specific task.

2. Explain the program development life cycle in detail. The steps of the program development cycle are:

· Problem Analysis—The programmer first understands the problem to be solved. The programmer determines the various ways in which the problem can be solved, and decides upon a single solution which will be followed to solve the problem.
· Program Design—The selected solution is represented in a form, so that it can be coded. This requires three steps—
An algorithm is written, which is an English-like explanation of the solution. A flowchart is drawn, which is a diagrammatic representation of the solution.
· Program Development
The pseudo code is coded using a suitable programming language.
The program is compiled for any syntax errors. Syntax errors arise due to the incorrect use of programming language or due to the grammatical errors with respect to the programming language used. During compilation, the syntax errors, if any, are removed.
The successfully compiled program is now ready for execution.
The executed program generates the output result, which may be correct or incorrect. If incorrect results are displayed, then the program has semantic error (logical error)which are removed get the correct results.
The successfully tested program is ready for use and is installed on the user‘s machine.
· Program Documentation and Maintenance—The program is properly documented, so that later on, anyone can use it and understand its working. Any changes like updating, fixing of errors made to the program, after installation, forms part of the maintenance of program.

3. Define algorithm.
Algorithm is an ordered sequence of finite, well-defined, unambiguous instructions for completing a task.

4. What are control structures?
Control structures specify the statements that are to be executed and the order of the statements that have to be executed. Sequential, selection, and iteration are three kinds of control structures.

5. Name the three kinds of control structures.
1. Sequence,
2. Selection, and
3. Iteration.
6. Define flowchart.
Flowchart is a diagrammatic representation of the logic for solving a task.
7. Give differences between Flowchart and Algorithm
Difference between Algorithm and Flowchart: An algorithm is a sequence of instructions used to solve a particular problem. Flowchart is tools to document and represent the algorithm. In other words, an algorithm can be represented using a flowchart. Flowchart is a graphical representation of the algorithm. Flowchart is a pictorial representation of the algorithm. Flowchart uses structured constructs of the programming language for representation. The user does not require the knowledge of a programming language to write or understand a flowchart.

8. Draw the control structures (Sequence, Selection and Iteration) for the flowchart.
[image: ]










Programming Exercise

9. Write the algorithm and draw a flowchart, for the following:

1. To find the sum of square root of any three numbers.
2. To find the sum of first 100 integers.
3. To find the sum of all even numbers till 100.
4. To find the sum of all odd numbers till 100.
5. To find the sum of any five integers.
6. To find the factorial of a number n. Hint: n! = n(n−1)(n−2)….3.2.1
7. To find the first n numbers in a Fibonacci series. Hint: f(0) = 0, f(1) = 1, f(n) = f(n−1) + f(n−2)
8. To find the sum of digits of a number. (For example, for number 345 find 3+4+5)
9. To check whether a number is prime or not.
10. To convert the temperature from Fahrenheit to Celsius. Hint: C= (5/9)*(F-32)

Chapter 4 OpenOffice










Introducing OpenOffice Writer

What is Writer?	
Writer is the word processor component of OpenOffice.org (OOo). In addition to the usual features of a word processor (spelling check, thesaurus, hyphenation, autocorrect, find and replace, automatic generation of tables of contents and indexes, mail merge, and others),Writer provides these important features:
· Templates and styles
· Page-layout methods, including frames, columns, and tables
· Embedding or linking of graphics, spreadsheets, and otherobjects
· Built-in drawing tools
· Master documents—to group a collection of documents into a single document
· Change tracking during revisions
· Database integration, including a bibliography database
· Export to PDF, including bookmarks
· And many more
Styles are central to using Writer. Using styles, you can easily format your document consistently and change the format with minimal effort. A style is a named set of formatting options. Writer defines several types of styles, for different types of elements: characters, paragraphs, pages, frames, and lists. Often, you are using styles whether you realize it or not. The use of styles is described in more detail in Chapter 6 (Introduction to Styles) and Chapter 7 (Working with Styles).
The other features of Writer listed above are also covered in detail inother chapters of this guide.

Starting Writer	
If you are reading this document in OpenOffice.org, you already know how to start Writer. However, if this is a printed version or a PDF version, you may not know how to start Writer. So let‘s look at three ways to do that:
· From the system menu
· From an existing document
· From the command line

Typesetting Text and Basic Formatting

Selecting text
Before you can do anything with text, you need to select it. Selecting text in Writer is similar to selecting anything in other applications.
In addition to selecting blocks of text, you can select items that are not consecutive, and columns (vertical blocks) of text.

Selecting items that are not consecutive
To select nonconsecutive items (as shown in Figure 75) using themouse:
1) Select the first piece of text.
2) Hold down the Control (Ctrl) key and use the mouse to select thenext piece of text.
3) Repeat as often as needed.


Now you can work with the selected text (copy it, delete it, change thestyle, or whatever).

To select nonconsecutive items using the keyboard:
1) Select the first piece of text. (For more information about keyboard selection of text, see the topic ―Navigating and Selecting with the Keyboard‖ in the OpenOffice.org Help (F1).)
2) Press Shift+F8. This puts Writer in ―ADD‖ mode. The word ADDappears on the Status Bar.
3) Use the arrow keys to move to the start of the next piece of text to be selected. Hold down the Shift key and select the next pieceof text.
4) Repeat as often as needed.
Now you can work with the selected text.
[image: ]
Figure 53: Selecting items that are not next to each other
Press Esc to exit from this mode.

Selecting a vertical block of text

You can select a vertical block or ―column‖ of text that is separated by spaces or tabs (as you might see in text pasted from e-mails, program listings, or other sources), using OOo‘s block selection mode. To change to block selection mode, use Edit > Selection Mode > Block Area, or click several times in the status bar on STD until it changes toBLK.
Now highlight the selection, using mouse or keyboard, as shown in Figure.

Figure : Selecting a vertical block of text
Cutting, copying, and pasting text	
Cutting and copying text in Writer is similar to cutting and copying text in other applications. You can copy or move text within a document, or between documents, by dragging or by using menu selections, icons, orkeyboard shortcuts. You can also copy text from other sources such as Web pages and paste it into a Writer document.
To move (cut and paste) selected text using the mouse, drag it to thenew location and release it. To copy selected text, hold down the Control key while dragging. The text retains the formatting it had before dragging.

After selecting text, you can use the mouse or the keyboard for theseoperations. [image: ]	Cut: Use Edit > Cut or the keyboard shortcut Control+X or the
Cut icon on the toolbar.
[image: ]	Copy: Use Edit > Copy or the keyboard shortcut Control+C or the
Copy icon.
[image: ]	Paste: Use Edit > Paste or the keyboard shortcut Control+V orthe Paste
icon.
The result of a paste operation depends on the source of the text to be pasted. If you simply click on the Paste icon, any formatting the text has (such as bold or italics) is retained. Text pasted from Web sites and other sources may also be placed into frames or tables. If you do not like the results, click the Undo icon or press Control+Z.




To make the pasted text take on the formatting of the surrounding textwhere it is to be pasted, choose:

· Edit > Paste Special
· or click the triangle to the right of the Paste icon
· or click the Paste icon without releasing the left mouse button Then select Unformatted text from the resulting menu.

The range of choices on the Paste Special menu varies depending upon the origin and formatting of the text (or other object) to be pasted. See Figure for an example with text on the clipboard.
[image: ]

[bookmark: _bookmark0]Figure : Paste Special menu

This example includes the formatting option DDE link. DDE is an acronym for Dynamic Data Exchange, a mechanism whereby selected data in document A can be pasted into document B as a linked, ‗live‘ copy of the original. It would be used, for example, in a report written in Writer containing time-varying data, such as sales results sourced from a Calc spreadsheet. The DDE link ensures that, as the source spreadsheet is updated so is the report, thus reducing the scope for error and reducing the work involved in keeping the Writer documentup to date.

Moving paragraphs quickly	
With the cursor anywhere in the paragraph:
1) Press and hold the Control+Alt keys.
2) While holding the Control+Alt keys down, press the up-arrow or
down-arrow key.
The paragraph will move to a new location either before the previous paragraph or after the next paragraph in your document. To move more than one paragraph at a time, select at least part of all paragraphs (including the end of the first paragraph you want to move and the start of the last) before pressing the Control+Alt+arrow keys.




Tip

If your paragraphs suddenly jumped from one place to another, the most likely reason is that you have accidentally pressed one of these key combinations.




Finding and replacing text	
When looking for certain words in a 3000-word essay, it is inefficient togo through every word manually. Writer has a Find and Replace feature that automates the process of searching for text inside a document.
In addition to finding and replacing words and phrases, you can:
· Use wildcards and regular expressions to fine-tune a search.
· Find and replace specific formatting.
· Find and replace paragraph styles.
[bookmark: _bookmark1]To display the Find & Replace dialog box (Error: Reference source not found), use the keyboard shortcut Control+F or select Edit > Find & Replace.
[image: ]

[bookmark: _bookmark2]Figure : Expanded Find & Replace dialog box
1) Type the text you want to find in the Search for box.

2) To replace the text with different text, type the new text in the
Replace with box.
3) You can select various options, such as matching the case, matching whole words only, or doing a search for similar words. (See below for some other choices.)
4) When you have set up your search, click Find. To replace text, click
Replace instead.

Tip

If	you click Find All,





[image: ]

Writer selects all instances of the search text in the document. Similarly, if you click Replace All button, Writer replaces all matches.



Use Replace All with caution; otherwise, you may end up with some hilarious (and highly embarrassing) mistakes. A mistake with Replace All might require a manual, word-by-word search to fix, if not discovered in time to undo.




Use wildcards (regular expressions)
Wildcards (also known as regular expressions) are combinations of characters that instruct OOo how to search for something. Regular expressions are very powerful but not very intuitive. They can save time and effort by combining multiple finds into one.
Table 2 shows a few of the regular expressions used by OOo.


The online help describes many more regular expressions and their uses.








Note

One of the most common mistakes when using regular expressions is to try to search for a character that is defined asa wildcard, such as brackets or dots. If you need to search for such a character, type a backslash (\) before it. This instructs OOo to treat the character following the backslash as a normal character. For example, to find the text $5.00 ($ and . are wildcard characters), you would conduct a search using \
$5\.00.





To use wildcards and regular expressions when searching andreplacing:
1) On the Find & Replace dialog box, click More Options to see more choices. On this expanded dialog box (Figure 56), select the Regular expressions option.

2) Type the search text, including the wildcards, in the Search for box and the replacement text (if any) in the Replace with box. Notall regular expressions work as replacement characters; the line break (\n) is one that does work.
3) Click Find, Find All, Replace, or Replace All (not recommended).
[bookmark: _bookmark3]Table 2. Examples of search wildcards (regular expressions)

	To find
	Use	this expression
	Examples and comments

	Any single character
	.
	b.d finds bad, bud, bid, and bed.

	Characters at the beginning of a paragraph
	^chars
	^term

	Characters	at	the end of a paragraph
	chars$
	term.$

	One of the specified characters
	[xyz]
	b[iu]n finds bin and bun.

	Any	single character in this range
	[x-y]
	[r-t]eed finds reed, seed, and teed; ranges must be in alphabetically ascending order.

	Any single
	[^x]
	p[^a]st finds post and pest, but not

	character except
	
	past.

	the characters
	
	

	inside the brackets
	
	

	The beginning of a word
	\<start
	\<log finds logbook and logistics, but not
catalog.

	The end of a word
	end\>
	log\> finds catalog, but not logistics.

	A paragraph marker	$	Does not work as a replacement character. Use \n instead.

	An empty paragraph
	^$
	

	A tab character
	\t
	

	A line break
	\n
	Finds a line break that was inserted with Shift+Enter. When used as a replacement character, it inserts a paragraph marker.



Find and replace specific formatting
A very powerful use of Find & Replace takes advantage of the format option. For example, you might want to replace underlined words withitalics.
On the Find & Replace dialog box (with More Options displayed, as inFigure 56):
1) To search for text with specific formatting, enter the text in the Search for box. To search for specific formatting only, delete anytext in the Search for box.
2) Click Format to display the Text Format (Search) dialog box. The tabs on this dialog box are similar to those on the Paragraph format and Paragraph Style dialog boxes. Choose the formats you want to search for and then click OK. The names of selected formats appear under the Search for box. For example, you mightsearch for all text in 14-point bold Helvetica.
3) To replace text, enter the replacement text in the Replace with
box.
To search for specific text with specific formatting (for example, the word hello in bold), specify the formatting, put the text in theSearch for box and leave the Replace with box blank.
To remove specific character formatting, click Format, select theFont tab, then select the opposite format (for example, No Bold). The No Format button on the Find & Replace dialog box clears all previously selected formats.
4) Click Find, Find All, Replace, or Replace All.





Tip

Unless you plan to search for other text using those same attributes, click No Format to remove the attributes after completing your search. If you forget to do this, you may wonder why your next search fails to find words you know arein the document.


Find and replace paragraph styles
If you combine material from several sources, you may discover that lots of unwanted paragraph styles have suddenly shown up in your document. To quickly change all the paragraphs of one (unwanted) style to another (preferred) style:
1) On the expanded Find & Replace dialog box (Figure 56), select
Search for Styles. (If you have attributes specified, this option is

labeled Including Styles.) The Search for and Replace with boxes now contain a list of styles.
2) Select the styles you want to search for and replace.
3) Click Find, Find All, Replace, or Replace All.
Inserting special characters
A ―special‖ character is one not found on a standard English keyboard. For example, © ¾ æ ç ñ ö ø ¢ are all special characters. To insert a special character:
1) Place the cursor in your document where you want the character to appear.
2) Click Insert > Special Character to open the Special Characters dialog box (Figure ).
3) Select the characters (from any font or mixture of fonts) you wish to insert, in order; then click OK. The selected characters are shown in the lower left of the dialog box. As you select each character, it is shown on the lower right, along with the numericalcode for that character.


Notice	that	the	characters	selected	appear	in	the	bottom-left corner of the dialog box.





Note

Different fonts include different special characters. If you do not find a particular special character you want, try changingthe Font selection.



[image: ]

[bookmark: _bookmark4]Figure : The Special Characters dialog box, where you can insert special characters.

Inserting non-breaking spaces and hyphens
Non-breaking spaces
To prevent two words from being separated at the end of a line, press
Control+spacebar after the first word.
Non-breaking hyphen
You can use a non-breaking hyphen in cases where you do not want thehyphen to appear at the end of a line, for example in a number such as 123-4567. To insert a non-breaking hyphen, press Shift+Control+minus sign.

Inserting dashes
To enter en and em dashes, you can use the Replace dashes option under Tools > AutoCorrect > Options (Figure 66). This option replaces two hyphens, under certain conditions, with the corresponding dash.
In the following table, the A and B represent text consisting of letters A to z or digits 0 to 9.

	Text that you type:
	Result

	A - B (A, space, minus, space, B)
	A – B (A, space, en-dash, space, B)

	A -- B (A, space, minus, minus, space, B)
	A – B (A, space, en-dash, space, B)

	A--B (A, minus, minus, B)
	A—B (A, em-dash, B)

	A-B (A, minus, B)
	A-B (unchanged)

	A -B (A, space, minus, B)
	A -B (unchanged)

	A --B (A, space, minus, minus, B)
	A –B (A, space, en-dash, B)


Another means of inserting en or em dashes is through the Insert > Special Characters menu. Select the U+2013 or U+2014 character,respectively.
A third method uses keyboard shortcuts. These shortcuts vary depending on your operating system.



Tip

You can also record macros to insert en and em dashes and assign those macros to unused key combinations, for example Ctrl+Shift+N and Ctrl+Shift+M. For more information, see Chapter 17 (Customizing Writer).




Windows
Hold down one of the Alt keys and type on the numeric keypad: 0150 for an en dash or 0151 for an em dash. The dash appears when you release the Alt key.


On a keyboard with no numeric keypad, use a Fn (Function) key combination to type the numbers. (The Fn key is usually to
Tip	the right of the left-hand Ctrl key on the keyboard.)
For example, on a US keyboard layout, the combination for an en
dash should be Alt+Fn+mjim and for an em dash it should be
Alt+Fn+mjij.




Formatting	paragraphs

You can apply many formats to paragraphs using the buttons on the Formatting toolbar. Figure shows the Formatting toolbar as a floating toolbar, customized to show only the buttons for paragraphformatting.






Tip

It is highly recommended that you use paragraph styles ratherthan manually formatting paragraphs, especially for long or standardized	documents.





[image: ]


1 Open Styles and Formatting Window

5 Align Right	10 Numbering On/Off
6 Justified	11 Bullets On/Off


	2 Apply Style
	7
	Line Spacing: 1
	12
	Decrease Indent

	3 Align Left
	8
	Line Spacing: 1.5
	13
	Increase Indent

	4 Centered
	9
	Line Spacing: 2
	14
	Paragraph format dialog


[bookmark: _bookmark5]Figure: Formatting toolbar, showing icons for paragraph formatting
Figure shows examples of the text alignment options.

[image: ]
[bookmark: _bookmark6]Figure : Text alignment options
When using justified text, the last line is by default aligned to the left; however, if so desired, you can also align the last line to the center of the paragraph area or justify it so that spaces are inserted between thewords in order to fill the whole line. In the case where the last line consists of a single word, you can also have this word stretched to cover the whole line. Figure shows an example of the effect obtained when setting each of these options.

[image: ]
[bookmark: _bookmark7]Figure : Four choices for the last line of a justified paragraph
These options are controlled in the Alignment page of the Format > Paragraph
dialog box (see Figure ).

[image: ]
[bookmark: _bookmark8]Figure : Options for the last line of a justified paragraph
Setting tab stops and indents
The default tab stops affect two things: tabs within paragraphs (as shown in Figure ) and the indentation of entire paragraphs by using the Increase Indent button on the Formatting toolbar.
Using the default tab stops to space out material on a page is not recommended, for two reasons:
· If you use the default tab interval and then send the document tosomeone who has chosen a different default tab interval, tabbed material will change to use the other person‘s settings.
· Any changes you make to the default tab stops affect existing default tab stops (in any document you open afterwards) as well as tab stops you insert after making the change.
Both cases may cause a major formatting problem, as illustrated inFigure .


[bookmark: _bookmark9]Figure : Default tab settings might be different
To avoid these unwanted changes, do not use the default tabs. Instead, define your own tab stops in paragraph styles or individual paragraphs as described in
―Defining your own tab stops and indents‖ on page 80.


Depending on what you are trying to accomplish a borderless table is often a better choice than using tabs.


To set the measurement unit and the spacing of default tab stops, use Tools > Options > OpenOffice.org Writer > General. On this page, make any required changes in the Settings section (Figure ) and click OK to save.
[image: ]

[bookmark: _bookmark10]Figure : Selecting a measurement unit and default tab stop spacing.
You can also set or change the measurement unit of the ruler itself by right- clicking on the ruler to open a list of units, as shown in Figure . Click on one of them to change the ruler to that unit. This change does not affect the measurement unit chosen in the Options.
[image: ]

[bookmark: _bookmark11]Figure : Ruler showing default tab stops
The horizontal ruler shows both the default tab stops and any that you have defined.

[bookmark: _bookmark12]Defining your own tab stops and indents
To set your own tab stops for one or more selected paragraphs, use theTabs page of the Paragraph dialog box. To reach this page, you can either:
· Double-click anywhere between the left and right indent icons on the ruler itself to open the Tabs page of the Paragraph dialog box, or
· Right-click on the paragraph, choose Paragraph from the pop-up menu, and choose the Tabs page.
Similarly, you can change the tabs defined in the paragraph style. Right-click on the paragraph, choose Edit Paragraph Style from thepop-up menu, and choose the Tabs page.

To change the indentation of one or more selected paragraphs, use theIndents & Spacing page of the Paragraph dialog box. To reach this page, you can either:
· Double-click on a part of the ruler that is not between the left and right indent icons, or
· Right-click on the paragraph, choose Paragraph from the pop-up menu, and choose the Indents & Spacing page.
Similarly, you can change the indentation defined in the paragraph style. Right- click on the paragraph, choose Edit Paragraph Style from the pop-up menu, and choose the Indents & Spacing page.

Formatting characters

You can apply many formats to characters using the buttons on the Formatting toolbar. Figure shows the Formatting toolbar as a floating toolbar, customized to show only the buttons for characterformatting.




Tip

It is highly recommended that you use character styles rather than manually formatting characters. For information on stylesand how to use them, see Chapters 6 and 7.



[image: ]



1 	Open Styles and Formatting Window
6 
Italic	12 Font Color
7 Underline	13 Highlighting

2 Apply Style	8 Superscript	14 Background Color
3 Font Name	9 Subscript	15 Open Character Format

4 Font Size	10	Increase Font
5 Bold	11 Reduce Font

Dialog

[bookmark: _bookmark13]Figure : Formatting toolbar, showing icons for character formatting





Tip

To remove manual formatting, select the text and click Format
· Default Formatting or right-click and select Default Formatting from the pop-up menu.




Autoformatting	
Writer can be set to automatically format parts of a document according to the choices made on the Options page of the AutoCorrect dialog box (Tools > AutoCorrect > Options). See Figure .
[image: ]

[bookmark: _bookmark14]Figure	:	Autoformat	choices	on	the	Options	page	of the AutoCorrect dialog box
The Help describes each of these choices and how to activate the autoformats. Some common unwanted or unexpected formatting changes include:
· Horizontal lines. If you type three or more hyphens (---), underscores ([image: ]) or equal signs (===) on a line and then press Enter, the paragraph is replaced by a horizontal line as wide asthe page minus any indentation of the preceding paragraph of which the line is the lower border.
· Bulleted and numbered lists. A bulleted list is created when you type a hyphen (-), asterisk (*), or plus sign (+), followed by a space or tab at the beginning of a paragraph. A numbered list is created when you type a number followed by a period (.), followedby a space or tab at the beginning of a paragraph. Automatic numbering is only applied to paragraphs formatted with the Default, Text body or Text body indent paragraph styles.


If you notice unexpected formatting changes occurring in your document, this is the first place to look for the cause.

To turn autoformatting on or off, go to Format > AutoFormat (Figure) and select or deselect the items on the submenu.
[image: ]

[bookmark: _bookmark15]Figure : Turning autoformatting on or off
· While Typing automatically formats the document while youtype.
· If While	Typing is deselected, you can select Apply to automatically format the file.
· Apply and Edit Changes automatically formats the file and thenopens a dialog box where you can accept or reject the changes.

Creating numbered or bulleted lists	
There are several ways to create numbered or bulleted lists:
· Use autoformatting, as described above.
· Use list styles.
· Use the Numbering and Bullets icons on the paragraph formatting toolbar (see Figure ). This last method is describedhere.
To produce a numbered or bulleted list, select the paragraphs in the list and then click on the appropriate icon on the toolbar.


It is a matter of personal preference whether you type your information first, then apply Numbering/Bullets or apply these as you type.Note



Using the Bullets and Numbering toolbar
You can create a nested list (where one or more list items has a sublist under it, as in an outline) by using the buttons on the Bullets and Numbering toolbar (Figure ). You can move items up or down the list, create subpoints, and even change the style of bullets.
[image: ]

1 Bullets On/Off	7 Move Down (One Level) 12	Move	Down	in	Sub- points

2 Numbering On/Off

with Sub-points

3 Numbering Off	8 Insert Unnumbered Entry13 Restart Numbering
4 Up One Level	9 Move Up	14 Bullets and Numbering
5 Down One Level	10 Move Down

6 Move Up (One Level) with Sub- points

11 Move Up in Sub-points

[bookmark: _bookmark16]Figure : Bullets and Numbering toolbar





Tip

It is possible to move a list entry up, together with all of its sub- entries. Do this by clicking the Promote One Level With Subpoints button.


If you create a nested list using the predefined styles, all the levels of the list (up to 10) apply the same numbering (or bullet), however in many circumstances you will want to use a combination of numbering formats and bullets when creating nested lists. Such lists with a mixture of numbering formats and bullets can be easily configured as described in the following example.




Tip

When creating nested lists one option is to enter all the list paragraphs first and apply the levels afterwards.
You can use keyboard shortcuts to move paragraphs up or down the outline levels. Place the cursor at the beginning of the numbered paragraph and press:
Tab  Down a level
Shift+Tab Up a level
To insert a tab stop at the beginning of a numbered paragraph (that is, after the number but before the text), press Control+Tab.




Example: configuring a nested list
We will use a numbering style to produce the following effect:
I.  Level-1 list item
A. Level-2 list item
i. Level-3 list item
a) Level-4 list item
This example uses one of the supplied styles, Numbering 1, however ifyou intend to reuse this type of nested list you can also create a new style.
1) Create the first item and apply the Numbering 1 style from the Styles and Formatting window.
2) Select Format > Bullets and Numbering to open the dialog that controls the appearance of the list.
3) Go to the Outline page (Figure ), where you will find that one style matches our requirements. Click once on that style.
4) To modify the layout of the list, use the Options tab (Figures 18 and 19). Notice that the preview on the right shows the outline selected. In the Level box on the left, select 1, then 2, 3, and 4 and see how the information in the Numbering and After boxes changes.
Use the Options page to set different punctuation; for example, aperiod (full stop) after ―a‖ on level 4 instead of a parenthesis.
To make the indentation at each level greater or less than the default, change it on the Position page. Select the level, then make any changes in the indentation, spacing, or numbering alignment.
5) Repeat for each level as required, then click OK.

[image: ]
[bookmark: _bookmark17]Figure: Choosing a predefined outline-numbering style
[image: ]
Figure : Checking the outline numbering for level-1 list items
[image: ]
Figure : Numbering style for level-2 list items



Tip

With outline numbering you can define different bullet styles for the different levels of a bullet list. Use the Bullets tab of the Bullets and Numbering dialog box (not shown) to select the basic style. Return to the Options tab to customize the bullet for each indent level. Here you can set bullets to any character. See the Graphics tab for more bullets.




Using footnotes and endnotes	
Footnotes appear at the bottom of the page on which they are referenced. Endnotes are collected at the end of a document.
To work effectively with footnotes and endnotes, you need to:
· Insert footnotes.
· Define the format of footnotes.
· Define the location of footnotes on the page.

Inserting footnotes/endnotes
To insert a footnote or an endnote, put the cursor where you want the footnote/endnote marker to appear. Then select Insert > Footnote from the menu bar or click the Insert Footnote Directly or Insert Endnote Directly icon on the Insert toolbar (see Figure ).
[image: ]
[bookmark: _bookmark18]Figure : Using the Insert Footnote Directly icon on the toolbar
A footnote (or endnote) marker is inserted in the text, and the cursor isrelocated to the footnote area at the bottom of the page (or to the endnote area at the end of the document). Type the footnote or endnote content in this area.
If you use Insert > Footnote, the Insert Footnote dialog box (Figure) is displayed. Here you can choose whether to use the automatic numbering sequence specified in the footnote settings and whether to insert the item as a footnote or an endnote.

[image: ]
[bookmark: _bookmark19]Figure: Inserting a footnote directly
If you use the Insert Footnote Directly or Insert Endnote Directly icon, the footnote or endnote automatically takes on the attributes previously defined in the Footnote Settings dialog box (Figure 74).
You can edit an existing footnote or endnote the same way you edit anyother text.
To delete a footnote or endnote, delete the footnote marker. The contents of the footnote or endnote are deleted automatically, and thenumbering of other footnotes or endnotes is adjusted automatically.

Defining the format of footnotes/endnotes
To format the footnotes themselves, click Tools > Footnotes. On the Footnote Settings dialog box (Figure ), choose settings as required. The Endnotes page has similar choices.
[image: ]
[bookmark: _bookmark20]Figure	:	Defining	footnote	formatting

Checking spelling	
Writer provides a spelling checker, which can be used in two ways.
[image: ]AutoSpellcheck checks each word as it is typed and displays a wavy red
line under any misspelled words. Once the word is corrected, the red wavy line disappears.
[image: ]To perform a separate spelling check on the document (or a textselection) click the Spelling and Grammar button. This checks
the document or selection and opens the Spelling dialog box(Figure ) if any misspelled words are found.
[image: ]
[bookmark: _bookmark21]Figure: The Spelling dialog box
Here are some more features of the spelling checker:
· You can right-click on a word with a wavy underline, to open a powerful context menu. If you select from the suggested words on the menu, the selection will replace the misspelled word in your text. Other menu options are discussed below.
· You can change the dictionary language (for example, Spanish, French, or German) on the Spelling dialog box.
· You can add a word to a dictionary. Click Add in the Spelling dialog box and pick the dictionary to add it to.

· The Options dialog box of the Spelling tool has a number of different options such as whether to check uppercase words and words with numbers. Here you can also manage custom dictionaries, that is, add or delete dictionaries and add or deletewords in a dictionary.

Using language tools	
OOo provides some tools that make your work easier if you mix multiple languages within the same document or write documents invarious languages.
You can set the language for the whole document, individual paragraphs, or even individual words and characters. In versions earlier than OOo 3.0 it was necessary to use styles in order to insert within a document paragraphs or individual groups of characters that use a different language, while now this can be conveniently done fromthe main menu.


Using character and paragraph styles is still the preferred method, as styles allow a greater level of control and make
Tip	changing language much faster.


The main advantage of changing the language is that you can then use the correct dictionaries to check spelling and apply the localized versions of Autocorrect replacement tables, thesaurus, and hyphenation rules.
The language tools can be found in Tools > Languages on the main menu, as shown in Figure .
[image: ]

[bookmark: _bookmark22]Figure : The Language menu

The following options are available:
· For selection: select this option to apply a specified language to the selected text (the selection can comprise only a few characters or several paragraphs).
· For paragraph: select this option to apply the specified language to the paragraph where the cursor is located.
· For all text: select this option to apply the specified language to all the document.
An alternative way to the menu above that allows you to change the language of a whole document is the use of Tools > Options > Language Settings > Languages. In the Default languages for documents section of the options dialog (Figure ) you can choose adifferent language for all the text.




[image: ]Caution

Unlike the menu tool that applies to the individual document, a change in the default language from the Options dialog is a general change of settings of OOo and will therefore apply to all the documents created in the future. If you want to change the language for the current document only, be sure to select the For the current document only option.




Spelling checking is available only for those languages in the list which have the symbol [image: ] next to them. If you do not see the symbol next to your preferred language, you can install the additional dictionary using Tools > Languages > More dictionaries online.
[image: ]

[bookmark: _bookmark23]Figure : Options available in the Languages settings
The language used for checking spelling is also shown in the statusbar, next to the page style in use.
You can also configure the language for a paragraph or a group of characters as None. This option is particularly useful in the case where you insert in the document text that you do not want to spellcheck, such as web addresses or programming language snippets.

Using the thesaurus
The thesaurus offers alternative words and phrases. Select the word or phrase you want to find alternatives for and select Tools > Language
· Thesaurus or press Control+F7. Click on a meaning to show alternative words and phrases for that meaning of the word. For example, when given the word
―house‖,	the	thesaurus	offers	several	meanings,	including	―dwelling‖,
―legislature‖, and ―sign of the zodiac‖. If you click on ―dwelling‖, you will see
―dwelling‖, ―home‖, ―domicile‖, ―abode‖, and other alternatives, as shown in Figure .


If the current language does not have a thesaurus installed, this feature is disabled.
[image: ]

[bookmark: _bookmark24]Figure : The thesaurus offers alternatives to words
Hyphenating words
To turn automatic hyphenation of words on or off:
1) Press F11 to open the Styles and Formatting window (Figure ).
[image: ]
[bookmark: _bookmark25]Figure : Modifying a style

2) On the Paragraph Styles page of the Styles and Formatting window, right-click on Default and select Modify.
3) On the Paragraph Style dialog box, select the Text Flow tab(Figure
).
4) Under Hyphenation, select or deselect the Automatically option.
5) Click OK to save.
[image: ]
[bookmark: _bookmark26]Figure : Turning on automatic hyphenation





Note

Turning on hyphenation for the Default paragraph style affects all other paragraph styles that are based on Default. You can individually change other styles so that hyphenation is not active; for example, you might not want headings to be hyphenated. Any styles that are not based on Default are not affected.



You can also set hyphenation choices through Tools > Options > Language Settings > Writing Aids. In Options, near the bottom ofthe dialog box, scroll down to find the hyphenation settings (see Figure).
[image: ]

Figure : Setting hyphenation options
To change the minimal number of characters for hyphenation, the minimum number of characters before a line break, or the minimum number of characters after a line break, select the item, and then clickEdit.

Hyphenate without inquiry specifies that you will never be asked to manually hyphenate words that the hyphenation dictionary does not recognize. If this box is not selected, when a word is not recognized, adialog box will open where you can manually enter hyphens.
Hyphenate special regions specifies that hyphenation will also becarried out in footnotes, headers, and footers.





Note

Hyphenation options set on the Writing Aids dialog box are effective only if hyphenation is turned on through paragraph styles.
Choices on the Writing Aids dialog box for ―characters before line break‖ and ―characters after line break‖ override settings in paragraph styles for ―characters at line end‖ and ―characters at line begin‖.


To enter a conditional hyphen inside a word, press Control+minus sign. The word is hyphenated at this position when it is at the end of the line, even if automatic hyphenation for this paragraph is switchedoff.

Using AutoCorrect

Writer‘s AutoCorrect function has a long list of common misspellings and typing errors, which it corrects automatically. For example, ―hte‖will be changed to ―the‖. Select Tools > AutoCorrect to open the AutoCorrect dialog box. There you can define what strings of text arecorrected and how. In most cases, the defaults are fine.


AutoCorrect is automatically turned on. To turn it off, uncheck
Format > AutoFormat > While Typing.

· To stop Writer replacing a specific spelling, use Tools > AutoCorrect > Replace, highlight the word pair and click Delete.
· To add a new spelling to correct, type it into the Replace and With
boxes and click New.
· See the different pages of the dialog box for the wide variety of other options available to fine-tune AutoCorrect.





Tip

AutoCorrect can be used as a quick way to insert special characters. For example, (c) will be autocorrected to ©. Youcan add your own special characters.




Using word completion	
If Word Completion is enabled, Writer tries to guess which word you are typing and offers to complete this word for you. To accept the suggestion, press Enter. Otherwise, continue typing.




Tip

Many people prefer not to use Word Completion. If you do not want to use it, select Tools > AutoCorrect > Word Completion and deselect Enable word completion.



You can customize word completion from the Tools > AutoCorrect > Word Completion page (Figure ).
[image: ]
[bookmark: _bookmark27]Figure : Customizing word completion
· Add (append) a space automatically after an accepted word.
· Show the suggested word as a tip (hovering over the word) rather than completing the text as you type.
· Change	the	maximum	number	of	words	remembered	for	word completion and the length of the smallest words to be remembered.
· Delete specific entries from the word completion list.
· Change the key that accepts a suggested entry—the options are
right arrow, End key, Return (Enter), Space bar, and Tab.


Automatic word completion only occurs after you type a word for the second time in a document.

Using AutoText

AutoText allows you to assign text, tables, graphics, and other items to a key combination. For example, rather than typing ―Senior Management‖, you just have to type ―sm‖ and press F3. Or you can save a formatted Tip (like the one on this page) as AutoText and then insert a copy by typing ―tip‖ and pressing F3.
To assign some text to an AutoText shortcut:
1) Type the text into your document.
2) Select the text.
3) Go to Edit > AutoText (or press Control+F3).
4) Enter a name for your shortcut. Writer will suggest a one-letter shortcut, which you can change.
5) Click the AutoText button on the right of the AutoText dialog box and select New (text only) from the menu.
6) Click Close to return to your document.
To insert AutoText, type the shortcut and press F3.




Tip

If the only option under the AutoText button is Import, either you have not entered a name for your AutoText or there is no text selected in the document.

AutoText is especially powerful when assigned to fields.

Line numbering

Line numbering puts line numbers in the margin. The line numbers are displayed on screen and are printed. Figure shows an example with numbering on every line.
Click Tools > Line Numbering and select the Show numbering
option in the top left corner. Then click OK.

[image: ]
[bookmark: _bookmark28]Figure : Line numbering example
You can choose how many lines are numbered (for example, every line or every tenth line), the numbering type and whether numbers restart on each page. In addition, a text separator (any text you choose) can be set on a different numbering scheme (one every 12 lines, for example).
[image: ]
Figure 84: The Line Numbering dialog box
Undoing and redoing changes	
To undo the most recent change, press Control+Z, click the Undo icon
[image: ] on the Standard toolbar, or select Edit > Undo from the menu bar.The Edit menu shows the latest change that can be undone.
[image: ]

Figure : Edit > Undo last action

Click the small triangle to the right of the Undo icon to get a list of allthe changes that can be undone (Figure ). You can select multiple changes and undo them at the same time.
[image: ]

[bookmark: _bookmark29]Figure : List of actions that can be undone
After changes have been undone, Redo becomes active. To redo a change, select Edit > Redo, or press Control+Y or click on the Redo icon [image: ]. As with Undo, click on the triangle to the right of the arrow toget a list of the changes that can be reapplied.
To modify the number of changes OpenOffice.org remembers, select Tools > Options > OpenOffice.org > Memory and change Undo:Number of steps. Be aware that asking OOo to remember more changes makes it consume more memory.

Linking to another part of a document	
If you type in references to other parts of the document, those references can easily get out of date if you reorganize the order of topics, add or remove material, or reword a heading, OOo provides three ways to ensure that your references are up to date, by inserting links to other parts of the same document or to a different document.
· Hyperlinks
· Cross-references
· Bookmarks
The first two methods have the same result if you Control+click the link when the document is open in OOo: you are taken directly to the cross-referenced item. However, they also have two major differences:
· The text in a hyperlink does not automatically update if you change the text of the linked item (although you can change it manually), but changed text does automatically update in a cross-reference.
· When using a hyperlink, you do not have a choice of the content of the link (for example text or page number), but when using a cross-reference, you do have several choices, including bookmarks.

Using hyperlinks
To insert a cross-reference as a hyperlink in your document, use theNavigator:
1) Open	the	documents	containing	the	items	you	want	to	cross- reference.
2) Open	the	Navigator	(by	clicking	its	icon,	choosing	Edit	> Navigator, or pressing F5.
3) Click the arrow next to the Drag Mode icon [image: ] and select
Insert as Hyperlink.
4) In the list at the	bottom	of the Navigator,	select the document containing the item that you want to cross-reference.
5) In the Navigator list, select the item that you want to insert as a hyperlink.

6) Drag the item to where you want to insert the hyperlink in the document. The name of the item is inserted in the document as anactive hyperlink.

Using cross-references
To ensure that references update if you reword a heading, caption, orother linked item, use automatic cross-references. See ―Using automatic cross-references‖ in Chapter 14 (Working with Fields) for details.

Using bookmarks
Bookmarks are listed in the Navigator and can be accessed directly from there with a single mouse click. In HTML documents, bookmarks are converted to anchors that you can jump to by hyperlink. For more about bookmarks, see ―Using bookmarks‖ in Chapter 14 (Working withFields).

Working with hyperlinks	
When you type text (such as a website address or URL) that can be used as a hyperlink, and then type a space, OOo formats the URL automatically, creating the hyperlink and applying to the text a color and underlining. If this does not happen, you can enable this featureusing Tools > AutoCorrect > Options and selecting the URL Recognition option.







Tip

If you do not want OOo to convert a specific URL to a hyperlink, select Edit > Undo Insert from the menu bar or press Control+Z immediately after the formatting has been applied.
To change the color of hyperlinks, go to Tools > Options > OpenOffice.org > Appearance, scroll to Unvisited links and/or Visited links, select those options, pick the new colors and click OK. Caution: this will change the color for all hyperlinks in all components of OpenOffice.org—this may not be what you want.
In Writer and Calc, you can also change the Internet link
character style or define and apply new styles to selected links.




Inserting hyperlinks
You can also insert and modify links using the Hyperlink dialog (Figure 91). To display the dialog, click the Hyperlink icon [image: ] on the

Standard toolbar or select Insert > Hyperlink from the menu bar. To turn existing text into a link, highlight it before opening the Hyperlinkdialog.
[image: ]
[bookmark: _bookmark30]Figure 91. Hyperlink dialog showing details for Internet links
On the left hand side, select one of the four types of hyperlink:
· Internet: a web address, normally starting with http://
· Mail & News: for example an email address.
· Document: the hyperlink points to another document or toanother place in the presentation.
· New document: the hyperlink creates a new document.
The top right part of the dialog changes according to the choice made for the hyperlink type. A full description of all the choices, and their interactions, is beyond the scope of this chapter. Here is a summary ofthe most common choices used in presentations.
For an Internet type hyperlink, choose the type of hyperlink (choose between Web, FTP or Telnet), and enter the required web address (URL).
For a Mail and News type hyperlink, specify whether it is a mail or news link, the receiver address and for email, also the subject.
For a Document type hyperlink, specify the document path (the Open File button opens a file browser); leave this blank if you want to link toa target in the same presentation. Optionally specify the target in the document (for example a specific slide). Click on the Target icon to open the Navigator where you can select the target, or if you know thename of the target, you can type it into the box.

For a New Document type hyperlink, specify whether to edit the newly created document immediately or just create it (Edit later) and the type of document to create (text, spreadsheet, etc.). For a presentation, Edit now is the more likely choice. The Select path button opens a directory picker.
The Further settings section in the bottom right part of the dialog iscommon to all the hyperlink types, although some choices are more relevant to some types of links.
· Set the value of Frame to determine how the hyperlink will open. This applies to documents that open in a Web browser.
· Form specifies if the link is to be presented as text or as a button.
· Text specifies the text that will be visible to the user.
· Name is applicable to HTML documents. It specifies text that willbe added as a NAME attribute in the HTML code behind the hyperlink.
· Event button: this button will be activated to allow OOo to react to events for which the user has written some code (macro). This function is not covered in this book.

Editing hyperlinks
To edit a hyperlink, you can either click anywhere in the link text, or position the cursor in the link text using the arrow keys, and then openthe Hyperlink dialog by clicking the Hyperlink icon on the Standard toolbar or selecting Edit > Hyperlink from the menu bar.
To activate a hyperlink, that is, to open the URL in your default browser, it is necessary to hold down the Control key while clicking on the link. A tooltip is displayed reminding you to press the Control key when the mouse pointer hovers over the hyperlink text.




Tip

If you need to edit several hyperlinks, you can leave the Hyperlink dialog open until you have edited all of them. Be sure to click Apply after each one. When you are finished, click Close.




Tables and Table Properties
Creating a table	
Before you insert a table into a document, it helps to have an idea of the visual result you want to obtain as well as an estimate of the number of rows and columns required. Every parameter can be changed at a later stage; however, thinking ahead can save a large amount of time as changes to fully formatted tables often require a significant effort.

[bookmark: _bookmark31]Inserting a new table
To insert a new table, position the cursor where you want the table to appear, then use any of the following methods to open the Insert Table dialog box (shown in Figure 270):
· From the main menu, select Table > Insert > Table.
· Press Control+F12.
· From the Standard toolbar, click the Table icon [image: ]

[image: ]
[bookmark: _bookmark32]Figure 270: Inserting a new table using the Insert Tabledialog box
Here you can specify the properties for the new table.
Under Name, you can enter a different name than the OOo-generated default for the table. This might come in handy when using the Navigator to quickly jump to a table.
Under Size, specify the initial number of columns and rows for the new table. You can change the size of the table later, if necessary.
Under Options, set up the initial table characteristics. Selecting theoptions in this section of the dialog produces the following results:
· Heading — Defines the first row(s) in the table as headings. The default Table Heading paragraph style is applied to the heading rows and thus makes the text centered, bold, and italic. You can edit the OOo-predefined Table Heading paragraph style in the Styles and Formatting window to change these default settings. When splitting a table into two tables, the Heading row(s) are copied in the second table.
· Repeat heading — Repeats the heading row(s) of the table at thetop of subsequent pages if the table spans more than one page. The first ... rows
—Specifies the number of rows to be repeated. Default is 1.
· Don’t split table — Prevents the table from spanning more than one page. This can be useful if the table starts near the end of a page, and would look better if it were completely located on the following page. If the table becomes longer than would fit on one page, you will need to either deselect this option or manually splitthe table.

· Border — Surrounds each cell of the table with a border. This border can be modified or deleted later.
The AutoFormat button opens a dialog from where it is possible to select one of the many predefined table layouts. See ―Automatic formatting of tables‖ on page 321 for more information.
After making your choices, click OK. Writer creates a table as wide as the text area (from the left page margin to the right page margin), with all columns the same width and all rows the same height. You can then adjust the columns and rows later to suit your needs.





Tip

To directly insert a table with the default properties, click on the little arrow next to the Table icon on the Standard toolbar. A graphic appears where you can choose the table‘s size (rows and columns). To create the table, click on the cell that you want to be on the last row of the last column. Holding down the mouse button over the Table icon will also display the graphic.


Creating nested tables
You can create tables within tables, nested to a depth only limited by imagination and practicality. Figure 271 demonstrates a simple, two- level example.
To achieve this, simply click in a cell of an existing table and use any of the methods mentioned in ―Inserting a new table‖ above.
[image: ]

[bookmark: _bookmark33]Figure 271: Nested table example. The shaded table is nested in a cell of the largertable.
Using AutoCorrect to create a table
You can also create a table by typing a series of hyphens (-) or tabs separated by plus signs. Use the plus signs to indicate column dividers, while hyphens and tabs are used to indicate the width of a column.
For example, this character sequence:
+	+	+	+

creates a table like this:

	
	
	






Note

This function can be disabled or enabled in Tools > AutoCorrect. On the Options tab, deselect or select Create table.







[image: ]Caution

When using tabs instead of a table to line up your data, always make sure that you know how wide they are set and remember that default tabs may be different when the document is displayed on a different computer or even when copying the same data in a new document.




Create a table from formatted text
It is possible to create a table starting from plain text by means of the
[image: ]Table > Convert > Text to Table menu. In order for this command to work effectively, the starting text needs to have clear demarcation between what will become the columns of the table. Paragraph marks indicate the end of a row.










Figure 272: Dialog box to configure the text to table conversion

[bookmark: _bookmark34]To convert text to a table, start by selecting the text you want to convert and select Table > Convert >
Text to Table to open the dialog shown in Figure 272.
In the top part of the dialog, select the symbol that separates the columns. This would normally be a tab, but it could be a semicolon or comma if you are importing a CSV file. The other options in this dialogare the same as those in the dialog used to insert a table shown in Figure 270.
Example
In this example we will convert the following text into a table.
Row 1 Column 1; Row 1 Column 2; Row 1 Column 3
Row 2 Column 1; Row 2 Column 2; Row 2 Column 3

In this case, the separator between elements is a semicolon. By selecting the text and applying the conversion, we obtain the followingresult.

	Row 1 Column 1
	Row 1 Column 2
	Row 1 Column 3

	Row 2 Column 1
	Row 2 Column 2
	Row 2 Column 3


Note that, unlike when creating a table with other mechanisms, the conversion from text to table preserves the paragraph style applied tothe original text.
You can also use the Convert menu to perform the opposite operation;that is, to transform a table into plain text. This may be useful when you want to export the table contents into a different program.
To transform a table into text, place the cursor anywhere in the table, select Table
· Convert > Table to Text in the main menu, pick the preferred row separator, and click OK to finish.

Formatting the table layout	
Formatting a table is, generally speaking, a two-step process: formatting of the table layout (the subject of this section) and formatting of the table text (the subject of the next section).
Formatting the layout normally involves one or more of the following operations: adjusting the size of the table and its position on the page,adding or removing rows or columns, merging and splitting individualcells, changing borders and background.

Default parameters
If you create a table using the Insert Table dialog box or the Table icon on the Standard toolbar and activate the Heading option, the following defaults are set:
· The cells in the heading row (or rows) use the Table Heading paragraph style. In the default template, the text is centered andset with a bold and italic font.
· The remaining cells use the Table Contents paragraph style, which, in the default template, is identical to the Default paragraph style.
· The default table occupies all the space from margin to margin (text area).
· The default table has thin black borders around each cell (grid).

Resizing and positioning the table
Using the default settings, any newly created table will occupy the entire width of the text area; this is sometimes what you want while inother occasions you may prefer a smaller table. To quickly resize a table, move first the mouse to either the left or right edge. When the cursor changes shape into a double arrow, drag the border to the new position. This operation will, however, only change the size of the first or last cell and will not change the alignment of the table on the page.
If you need more precise control over the size and position of the table on the page, you need to use the Table Format dialog box. Open this dialog box by selecting Table > Table Properties or by right-clickinganywhere in the table and selecting Table from the pop-up menu.
Select the first page of the dialog box (Table) so that it appears likeFigure .
[image: ]

Figure: The table page of the table formatting dialog
On this page you can set the alignment of the table, choosing amongthe following options:
· Automatic: the default setting for a table.
· Left: aligns the table with the left margin.
· Right: aligns the table with the right margin.
· From Left: lets you specify under Spacing exactly how far from the left margin the table is placed.
· Center: aligns the table in the middle between the left and rightmargins. If the table width is greater than the margin, the table will extend outside of the margins.
· Manual: lets you specify the distances from both left and rightmargins under Spacing.

Selecting an alignment option other than Automatic activates the Width field in the Properties section, where you can enter the desired size of the table. Select Relative to see the width as percentage of thetext area.
In the Spacing section, use the Above and the Below boxes to modify the separation between the text and the table. When the size of the table is less than the size of the text area, OOo will insert some values in the Left and Right boxes. You can only change both values if you select Manual alignment and you can change the Left box value only when you select the From Left alignment. Note that the sum of the table width, and the values in the Left and Right boxes, needs to equalthe width of the text area.
Resizing rows and columns
You can adjust the height of rows and the width of columns in a table in several ways.
· Move the mouse next to the edge of the cell and when a double- headed arrow appears, click and hold the left mouse button, drag the border to the desired position, and release the mouse button.
· On the horizontal ruler, column dividers are marked by a pair ofthin gray lines; the vertical ruler indicates row dividers in the same way. You can resize a row or column by holding the mouse button down on the appropriate divider and dragging it to the desired location.
· Use the keyboard as described below.
Selecting Table > Autofit from the main menu also offers someresizing options:
· The Optimal Column Width or Optimal Row Height options make the columns or rows as narrow as possible while still fittingtheir contents.
· Columns and rows can be distributed evenly to quickly bring themback to all being the same width or height.
For greater control over the width of each column, use the Columns
page of the Table Format dialog box (see Figure ).

[image: ]
Figure: Table Format dialog box: Columns page

Right-click on the table and select Table from the pop-up menu or select Table > Table Properties from the menu bar. On the Table Format dialog box, select the Columns tab.
· Adapt table width: If a table already stretches to the page margins, it cannot stretch any wider and the Adapt table widthoption is not available. If the table is narrower, increasing the width of a column will increase the width of the whole table.
If the table width already extends pasts the margins with the Adapt table width option checked, attempting to change a columnwidth will automatically decrease that column‘s size so that the table will now shrink to the page margins while keeping any othercolumn sizes intact.
· Adjust columns proportionally results in all columns changing their widths by the same percentage when one is changed. For example, if you reduce by half the size of a column, all the othercolumns sizes will be halved.
· Remaining space shows how much further the table can expand before hitting the limit of the margins. This value cannot be edited and will not be negative in the event that the table width is already larger than the space between the left and right margins.
· Under Column width, each individual column can be adjusted. If you have more than six columns, use the arrows at the right and left to view them all.
Rather than start from the Table Format dialog box, it is often more efficient to make rough adjustments to a new table using the mouse, and then fine tune the layout using the Columns page in conjunction with the Table page of the Table Format dialog box.

It is also possible to resize a table using only the keyboard. This is on occasions easier than using the mouse.
1) Place the cursor on the cell whose size you want to change.
2) Press and hold the Alt key while using the arrow keys to changethe size.
To adjust the resizing parameters and behavior for keyboard handling,select Tools
· Options > OpenOffice.org Writer > Table.
Use the Row and Column values in the Move cells section to determine the amount of change produced by a single keystroke while resizing. In the Behavior of rows/columns section you can choose one of the following three strategies when resizing:
· Fixed: select this if you want the resizing to only affect the adjacent cell, and not the entire table. The width of the table does not change when resizing its cells.
· Fixed, proportional: when resizing a cell with this option selected,all the other cells are also resized proportionally, Also in this case the width of the table remains constant.
· Variable: this is the default value. Resizing a cell affects the table size. For example, when you widen a cell, the width of the table increases.

Inserting rows and columns
To insert any number of rows or columns:
1) Place the cursor in the row or column where you want to add new rows or columns and right-click.
2) On the pop-up menu, select Row > Insert or Column > Insert. This will display a dialog box where you can select the number of rows or columns to add, and whether they appear before or after the selected one.
3) Set Amount to the number of rows or columns to insert, and
Position to Before or After.
4) Click OK to close the dialog box.





Note

Clicking on the Insert Row icon on the Table toolbar inserts one row below the selected one. Clicking on the Insert Column icon on the Table toolbar inserts a column after (to the right of) the selected one.
Regardless of how they are inserted, new rows or columns have the same formatting as the row or column where the cursor was when the insert command was issued.




You can also quickly insert a row or a column using only the keyboard:
1) Place the cursor in the row or column next to the row or columnyou want to insert.
2) Use the Alt+Insert keystroke combination to activate keyboardhandling.
3) Use the arrow keys as desired to add a row or column:
Left to insert a new column to the left of the cell where the cursor is located.
Right to insert a new column to the right of the cell where thecursor is.
Down to insert a new row below the cell where the cursor is.
Up to insert a new row above the cell where the cursor is.
The above keyboard technique can also be used to delete rows or columns by substituting the Alt+Insert keystroke combination in Step2 with Alt+Delete.
[bookmark: _bookmark35]Merging and splitting cells
To merge a group of cells into one cell:
1) Select the cells to merge.
2) Right-click and select Cell > Merge on the pop-up menu, or select
Table > Merge Cells from the menu bar.
To split a cell into multiple cells:
1) Position the cursor inside the cell.
2) Right-click and select Cell > Split on the pop-up menu, or select
Table > Split Cells from the menu bar.
3) Select how to split the cell. A cell can be split either horizontally (create more rows) or vertically (create more columns), and you can specify the total number of cells to create.
It is generally a good rule to execute merging and splitting of cells at the end of the layout formatting. This is because some operations suchas deleting a column or a row may produce a result difficult to predict when applied to a table with merged or split cells.

Specifying table borders
On the Table Format dialog box, select the Borders tab (Figure 275).
Here you can set borders for a whole table or groups of cells within a table. In addition, a shadow can be set for the whole table.

Borders have three components: where they go, what they look like, and how much space is left around them.
· Line arrangement specifies where the borders go. If a group of cells is selected, the border will be applied only to those cells. You can specify individually the style of the border for the outside edges of the selected cells as well as for the the cell divisions. OOo provides 5 default arrangements but you can just as easily click on the line you want to customize in the User-defined area to get exactly what you want. When multiple cells are selected the user defined area allow you to select the edges of the selection as well as the cell dividers. Clicking at the intersection of the lines you can modify multiple borders simultaneously (in Figure below the right edge and horizontal cells separators are modified with a single operation.)


When the selected group of cells have different styles of border the User-defined area shows this border as a gray line. You can
Note	override this with a new border style (first click), leave the borders as they are (second click) or delete all the borders (thirdclick).
[image: ]


Figure: Table Format dialog box: Borders page
· Line specifies what the border looks like: the style and color. There are a number of different styles and colors to choose from. The Line Style and Color will apply to those borders highlighted

by a pair of black arrows in the User-defined map on the left hand side of the dialog box.
· Spacing to contents specifies how much space to leave between the border and the cell contents. Spaces can be specified to the left, right, above, and below. Check Synchronize to have the same spacing for all four sides. This spacing is like a padding andit is not factored in when calculating the text measurements.
· Shadow style properties always apply to the whole table. A shadow has three components: where it is, how far from the table it is cast, and what color it is.
· If Merge adjacent line styles is checked, two cells sharing a common border will have their borders merged, rather than beingside by side.





Tip

To reset everything if you are having problems with borders, right-click in the table and select Table or select Table > Table Properties from the menu bar. On the Borders tab, select the Set No Borders icon under Line arrangement: Default (the boxon the left).




Selecting background colors and graphics
A table background can greatly improve the readability of the data, visually highlight important parts of the table (such as the heading or a specific cell), or just make the table more appealing. You can choose between two types of background when formatting the table: solid color or graphic. The background can be applied to the whole table, to a single cell, or to a row. The background selected for a cell will be in front of the row background which in turn will hide the table background.
The row background option is quite handy when you want to create alternate color rows or assign a different background to the heading ofthe table. The tables in this guide adopt this technique.
To set the background for a cell, row, or table:
1) Place the cursor anywhere inside the cell, row or table you want to work with. If you want to apply a background to a group of cells, select the group.
2) Right-click and select Table from the pop-up menu, or select
Table > Table Properties from the main menu.
3) In the Table Format dialog box, select the Background tab (Figure 276).

4) In the For section, chose whether to apply the settings to cell, row, or table.
· If you choose Cell, changes apply only to the selected cells, orthe cell where the cursor currently resides. Even when selecting a group of cells, the background settings are appliedto each cell individually.
· If you choose Row, changes affect the entire row where thecursor resides.
· If you choose Table, changes will set the background for the entire table, regardless of the cursor position or selected cells.
[image: ]

[bookmark: _bookmark36]Figure	276:	Table	Format	dialog:	inserting	a	graphic table background
5) In the As section, choose whether the background is a color or agraphic.
To apply a color, select the color and click OK. Remember thatyou can add custom colors by choosing Tools > Options > Colors.
To apply a graphic:
a) First select the graphic from your computer's file system with the
Browse button. (Writer supports a large number of graphics formats.)

b) You can use the Link option to link the graphic file. If it is linked, changes to the graphic (for example, if you edit it in a different software package) are reflected in your document. However, you also need to keep the linked graphic file with the document file. If, for example, you email the document without the graphic file, the graphic will no longer be visible.
c) Under Type, select the type of placement for the graphic.
· If you choose Position, you can select in the position map where the graphic will be displayed in the selected area.
· If you choose Area, the graphic is stretched to fill the whole area.
· If	Tile,	the	graphic	is	tiled	(repeated	horizontally	and vertically) to fill the area.
d) If the Preview option is checked, the graphic displays in thepane on the right.
e) To apply the graphic, click OK.
Figure 277 shows an example of a table set with a background image, and the first row background colored. As you can see, the row background covers the table background.
[image: ]

[bookmark: _bookmark37]Figure 277: Example of table with different rowand table backgrounds
Displaying or hiding table boundaries
A table boundary is a set of pale (usually gray) lines around the cells when viewed on-screen in OOo. These boundaries are not printed; their only function is to help you see where the table cells are.
To display the table the same way on the screen as on the printed page, with no boundary lines, right-click on the table and select Table Boundaries from the pop-up menu. Repeat this to have the boundariesappear again.


Turning boundaries off does not hide the borders that the table may have.





Tip

You can also turn table boundaries on and off through Tools > Options > OpenOffice.org > Appearance. On that page, youcan display or hide boundaries around text, pages headers and footers, figures, and other parts of a document.


Formatting the table text

Once the table layout is satisfactory, you can move on to formatting thetext in the individual cells. You can apply manual formatting as with any other paragraph in the text, but it is highly recommended, for the sake of consistency and ease of maintenance, that you define your ownparagraph and character styles.
Besides the paragraph and character styles, there are other aspects to consider when placing text in a table cell; such as text flow, alignment and orientation.
You can format each cell independently of other cells, or you can simultaneously format a group of cells by selecting them before applying the desired formatting.

Specifying text flow
On the Text Flow page of the Table Format dialog box (Figure 278), youcan:
· Insert a page or column break either before or after the table. Use the Text Flow: Break option, combined with the Page or Column and the Before or After buttons.
If you insert a page break before the table (that is, start the tableon a new page), you can also change the page style that will go with it by checking the With Page Style box and selecting a new page style. As with any page break, you can also reset the page numbers using the Page number box.
· Keep a table on one page by deselecting the Allow table to split across pages and columns option. If this item is deselected, the next item is not active.
· Keep each row on one page by deselecting the Allow row to break across pages and columns option.

· Use the Keep with next paragraph option to keep the table and an immediately following paragraph together if you insert a page break.
· Use the Repeat heading option, and its associated numbers box, to select the number of table heading rows that will be repeated on each page. A complicated table may need two or three headingrows to be easily read and understood.
· Use the Text direction list to select the direction for the text in thecells. The most common setting is Left to right for Western languages.


The phrase Use superordinate object settings means ―use theformatting settings from the paragraph before the table‖.
[image: ]

[bookmark: _bookmark38]Figure 278: Table Format dialog box: Text Flow page
· Select the vertical alignment of the text in the table or the selected cells; the choices are to align with the top of the cell, the center of the cell, or the bottom of the cell. This alignment is in addition to the Left-Right alignment options available on the Table page of the Table Format dialog box.



Note


A table heading row can not span two pages, but any other row can. A one-row table (often used for page layout purposes), if set up with the default of including a heading, will not break across pages. The cure is to make sure the table is defined without a heading row.


Vertical alignment
By default, text entered into a table is aligned to the top-left of the cell. You can change the default for the entire table, as described above, or for individually selected cells.
To vertically align the text in specific cells:
· Place the cursor in the cell you wish to change, or click and dragto select multiple cells.
· Right-click in the selected area and select Cell > Center, Top, or
Bottom in the pop-up menu to vertically align the text as desired.

Number formats
The number format can be set for a whole table or group of cells. For example, cells can be set to display in a particular currency, to four decimal places, or in a particular date format.
Number recognition specifies that numbers in a text table are recognized and formatted as numbers. If number recognition is selected, numbers are automatically bottom-right aligned. Number recognition option can be enabled under Tools > Options > OpenOffice.org Writer > Table.
Select the cells to format, then right-click and select Number Format from the pop-up menu. The Number Format dialog box opens for you to set options for various categories of numerical data.
· In the Category list, select the category you want, such ascurrency, date, or text.
· In the Format list, choose a format for the category you justselected.
· For some categories, such as date, you may wish to change the language using the Language list while for other numerical categories the Options section of the dialog box allows you to customize the appearance.



Tip

You will notice that OOo displays the formatting code for the category and format selected in Format Code section at the bottom of the dialog box. For example, if you select a date format such as 31 Dec 1999 the corresponding code is D MMM YYYY. Advanced users can easily customize this formatting code as well as create new user-defined codes.




Rotating text in a table cell
You can rotate text in a table cell by 90 or 270 degrees. Text rotation is useful when you have long headings for narrow columns.
· Select the text to be rotated and then click Format > Character.
· On the Position page, in the Rotation / scaling section, choose the rotation angle and click OK.
Figure 279 shows a sample table with rotated headings.
[image: ]
[bookmark: _bookmark39]Figure 279: A table with rotated headings





Note

Text rotation within table cells can also be achieved with the use of paragraph styles, discussed in greater detail in Chapter 7 (Working with Styles).



Data entry and manipulation in tables Moving between cells
Within a table, you can use the mouse, the cursor keys, or the Tab key to move between cells.

The cursor keys move to the next cell only if there is no text in the way. For example, pressing the right cursor key will move the cursor to the right within the text in the current cell, then to the next cell.
The Tab key moves directly to the next cell and, if the cursor is in the last cell in the table, creates a new row. Pressing Shift+Tab moves thecursor back a cell.


To enter a Tab character as part of the text of the cell, press the
Control and Tab keys at the same time.


Sorting data in a table
Just as in a spreadsheet, Writer allows data in a table to be sorted. Up to three levels of sorting can be specified (for example, sort first by age numerically, then alphabetically by name within each age).
To sort data in a table:
· Select the table (or part of the table) to be sorted.
· From the menu bar, select Table > Sort. In the Sort dialog box:
· Decide whether you want to sort in the direction of rows orcolumns. The default sorting direction is by rows, which results in sorting the data in a column.
· Select up to three keys to sort on, in the correct order.
· For each key, select which column or row to sort on, whetherthe sort is Numeric or Alphanumeric and whether it is Ascending or Descending.
· Click OK to perform the sort.




Note

You have to select all cells that might be affected by the sorting. For example, if you select only the cells of one column, the sort affects that column only, while the others remain unchanged. In such a case, you risk mixing the data of the rows.


[bookmark: _bookmark40]Using spreadsheet functions in a table
In a table in a Writer document, you can use some of the mathematicalfunctions that are normally implemented by OpenOffice.org Calc. For many simple functions, Writer tables can be used as basic spreadsheets.
Just as in a spreadsheet, each table cell is identified by a letter (for the column) and a number (for the row). For example, cell C4 is the cell in

the third column from the left and fourth row from the top. When thecursor is in a cell, this cell reference is displayed on the status bar.





Tip

Basic spreadsheet functions in tables are much the same as in OpenOffice.org Calc. The main difference is that cell references are formatted differently. Cell A2 (first column, second row) is referred to in Calc as A2 (or $A$2 for an absolute reference). In Writer tables, it is referred to as <A2>.



For example, suppose you had two numbers in cells <B1> and <C2>and wanted to display the sum of the two in cell <A1>, as shown in Figure 280.
[image: ]

[bookmark: _bookmark41]Figure 280: Using spreadsheet functions in a table
Do the following:
1) Click in cell <A1> and press the = key. The Formula bar appears automatically, near the top of the screen. In the leftmost side of the bar, you can see the coordinates of the selected cell.
2) Click in cell <B1>. The identifiers of this cell are automaticallydisplayed in the Formula bar and inserted into cell <A1>.
3) Press the + key.
4) Click on cell <C2>. You can see the final formula = <B1>+<C2>
displayed both in the selected cell and in the Object bar.
5) Press the Enter key or click the green tick (checkmark) on the Formula Bar.



Tip


To display the list of the mathematical functions that you can use in a table:
1) Display the Formula toolbar by pressing F2 or by selecting a blank cell and pressing the = key.
2) Click and hold the Formula f(x) icon.

In our example, this gives the result 9 in the top left cell. For contiguous cells, you can simply select the cells in the row, column, or the rectangle of rows and columns. Thus, for example, to add a columnof numbers, do this:
1) Type an equals sign = in an empty cell.
2) Select the cells to be added together—in this case the cells fromA2 to A5. The formula should be something like =<A2:A5>.
3) Press the Enter key or click the green tick (checkmark) on the Formula Bar.
4) The answer appears in the cell you have selected.
When using a function, you can enter the cells manually or by selectingthem. Thus, to add up the four numbers that we added above (A2, A3, A4, A5), do this:
1) Type an equals sign = in an empty cell.
2) Type sum or select it from the function list f(x).
3) Select	the	cells	to	be	added	together.	The	formula	should	be something like =sum<A2:A5>.
4) Press the Enter key or click the green tick (checkmark) on the Formula Bar.
5) The answer appears in the cell you have selected.


[image: ][image: ]	Unlike Calc, when inserting or deleting rows or columns of the table, formulas are not updated automatically. If you plan to use complex formulas you should consider embedding a Calc spreadsheet in your Writer document.




Automatic formatting of tables
AutoFormat is a functionality whereby you can apply an elaborate formatting to your table with just a few clicks. AutoFormat is somewhat similar to paragraph styles and will enable you to obtain

consistent looking tables across your document. You can also create your own table formats and save them as another AutoFormat option.
To apply an AutoFormat, place the cursor anywhere in the table and select Table
· AutoFormat. This opens the dialog box shown in Figure 281.
Select from the list on the left the Format most suitable for your table and click OK to apply it. Clicking the More button opens another section of the dialog box where you can rename the selected table format scheme as well as decide which parts of the predefined formatting you want to apply to your table. You can selectively apply the number format, the font, the alignment, the border, or the pattern.
[image: ]
[bookmark: _bookmark42]Figure 281: The table AutoFormat dialog
To create your own AutoFormat, proceed as follows:
1) Create a table and manually format it as you wish, including borders, spacing of text from the top and bottom borders, fonts to be used in the table heading and data cells, and background colors.
2) Position the cursor anywhere in the table and then click Table > AutoFormat.
3) On the AutoFormat dialog box (Figure 281), click Add and give the table format a name in the Add AutoFormat dialog box and click OK.
4) The newly named AutoFormat now appears as an available format. Click OK to close the AutoFormat dialog box.


This technique does not include table and column widths in the table format. To insert a table with predefined full formatting, save it as AutoText. See ―Using AutoText‖ in Chapter 3 (Working with Text) for instructions.Tip



Creating a heading row in an existing table
To create a heading row in an existing table that does not have one, you need to apply an AutoFormat that does have a heading defined. (Here is where having some personalized table formats could come in very handy.) Place the cursor anywhere in the table and then click Table > AutoFormat. Choose a format. Click OK. Use the More button and deselect the formatting options you do not want to apply toyour table.
Merging and splitting tables
One table can be split into two tables, and two tables can be merged into a single table. Tables are split only horizontally (the rows above the split point are put into one table, and the rows below into another).
To split a table:
1) Place the cursor in a cell which will be in the top row of the second table after the split (the table splits immediately above thecursor).
2) Right-click and select Split Table in the pop-up menu. You canalso use
Table > Split Table from the menu bar.
3) A Split Table dialog box pops up. You can select No heading or an alternative formatting for the heading—the top row(s) of thenew table.
4) The table is then	split into two tables separated by	a blank paragraph.
To merge two tables:
1) Delete the blank paragraph between the tables. You must use the
Delete key (not the Backspace key) to do this.
2) Select a cell in the second table.
3) Right-click and select Merge Tables in the pop-up menu. You can also use
Table > Merge Table from the menu bar.




Tip

To see clearly where the paragraphs are and to delete them easily, select View > Nonprinting Characters (Ctrl+F10) or click the ¶ button in the Standard toolbar.




Deleting a table
To delete a table:
1) Click anywhere in the table.
2) Select Table > Delete > Table from the main menu.Or:
1) Select from the end of the paragraph before the table to the start of the paragraph after the table.
2) Press the Delete or the Backspace key.




Note

The second method also merges the paragraph after the table with the paragraph before the table, which may not be what youwant.


Copying a table
To copy a table from one part of the document and paste it into anotherpart:
1) Click anywhere in the table.
2) From the main menu select Table > Select > Table.
3) Press Control+C or click the Copy icon on the Standard toolbar.
4) Move the cursor to the target position and click on it to fix theinsertion point.
5) Press Control+V or click the Paste icon in the Standard toolbar.
Moving a table
To move a table from one part of a document to another part:
1) Click anywhere in the table.
2) From the main menu, select Table > Select > Table.
3) Press Control+X or click the Cut icon in the Standard toolbar.
4) Move the cursor to the target position and click on it to fix theinsertion point.
5) Press Control+V or click the Paste icon in the Standard toolbar.
6) Return to the original table, click somewhere in it and then select
Table > Delete > Table from the main menu.

Inserting a paragraph before or after a table
To insert a paragraph before or after a table, position the cursor in thefirst or last cell and press Alt+Enter.

Using tables as a page layout tool
Tables may be used as a page layout tool to position text in a documentinstead of using tabs or spaces. For example, the Tip below is formatted as a table.
For more information and tips about using tables in page layout, see Chapter 4 (Formatting Pages).





Tip

When inserting a table used for layout, you may wish to deselect the Heading and Border options (see Inserting a new table on page 298).
To remove the borders from an existing table, right-click on the table, select Table from the pop-up menu, select the Borders tab (see Figure 275 on page 308), and select the icon for no borders.




The Table menu and toolbar	
All of the table commands described in this chapter are convenientlylocated in the main menu under the Table item and on the Table toolbar, shown in Figure 282.
Table 7 describes the effects of using these icons. When you create a table or select an existing table, the Table toolbar may be displayed automatically, or you can manually display it by clicking View > Toolbars > Table. The toolbar can float over the main Writer window (as shown in Figure 282), or it can be docked along any edge of the main window.

[image: ]

	1 Table
	9
	Top
	17
	Select Column

	2 Line Style
	10
	Center (vertical)
	18
	Select Row

	3	Line	Color (border)
	11
	Bottom
	19
	AutoFormat

	4 Borders
	12
	Insert Row
	20
	Table Properties

	5 Background Color
	13
	Insert Column
	21
	Sort

	6 Merge Cells
	14
	Delete Row
	22
	Sum

	7 Split Cells
	15
	Delete Column
	
	

	8 Optimize
	16
	Select Table
	
	


[bookmark: _bookmark43]Figure 282: Table toolbar
[bookmark: _bookmark44]Table 7: Functions of the icons on the Table toolbar

	Name
	Description

	Table
	Opens the Insert Table dialog box where you can set up and insert a table into the document, name the table for use with the Navigator, and set some other options. If you press the small black triangle pointing down next to the icon, you can use the mouse to drag to select the number of rows and columns to include in the table.

	Line Style
	Opens the Border Style window where you can modify the border line style.

	Line	Color (border)
	Opens the Border Color window where you can modify the border color.

	Borders
	Opens the Borders window where you can select which sides of the table or of the selected cells will have a border.

	Background Color
	Opens the Background toolbar where you can select the background color of the table or of the selected cells.

	Merge Cells
	Combines the selected cells into a single cell. Refer to Merging and splitting cells on page 307 for an example of using this button.



	Name
	Description

	Split Cells
	Opens the Split Cell dialog box where you can define how to split a cell. Refer to Merging and splitting cells on page 307 for an example of using this button.

	Optimize
	Opens the a drop down menu with four options you can use to let OOo optimize the distribution of the columns or rows or optimize the row height or column width.

	Top
	Press this button to align the contents of the selected cellsto the top of the cell.

	Center (vertical)
	Press this button to align the contents of the selected cellsto the vertical center of the cell.

	Bottom
	Press this button to align the contents of the selected cellsto the bottom of the cell.

	Insert Row
	Inserts a row below the selected row.

	Insert Column
	Inserts a column after the selected column.

	Delete Row
	Deletes the selected row(s) from the table.

	Delete Column
	Deletes the selected column(s) from the table.

	Select Table
	Selects the entire table.

	Select Column
	Selects the column in which the cursor is positioned.

	Select Row
	Selects the row in which the cursor is positioned.

	AutoFormat
	Opens the AutoFormat dialog box where you can select among several predefined formatting sets. Each set is characterized by its own fonts, shading, and borders styles. You can also select AutoFormat from the Insert Table dialog box.

	Table Properties
	Opens the Table Format dialog box where you can control all the properties of the table—for example: name, alignment, spacing, column width, borders, and background.

	Sort
	Opens the Sort dialog box where you can specify the sort criteria for the selected cells.

	Sum
	Activates the sum function. Refer to ―Using spreadsheet functions in a table‖ on page 316 for an example of usingthis function.



Graphics in Writer
When you create a text document using OpenOffice.org (OOo) Writer, you may need to include some graphic illustrations. Graphics are added to textual documents for a wide variety of reasons: from supporting the description provided in the text—such as that used in this Guide—to providing an immediate visual impact of the contents, such as what is often found in a newspaper.
Graphics in Writer are of three basic types:
· Image files, including photos, drawings, scanned images, andothers
· Diagrams created using OOo‘s drawing tools
· Charts created using OOo‘s Chart facility
This chapter covers the first two types of graphic illustrations.
More detailed descriptions on working with drawing tools can be foundin the Draw Guide and Impress Guide. Instructions on how to create charts are given in the Calc Guide.

[bookmark: _bookmark45]Adding images to a document
Images (also called ‗pictures‘ in this guide) can be taken from a variety of sources. They may be downloaded from the Internet, scanned, or created with a graphics program; or they may be photos taken with a digital camera.

Inserting an image from a file
In the case where the image is already available in a file stored on thecomputer, it can be immediately inserted in the Writer document. OOocan import various vector (line drawing) and raster (bitmap) file formats. The most common are GIF, JPEG or JPG, PNG, and BMP. See ―Graphic file types supported‖ on page 295 for a full list of supported graphic file types.
To insert an image from a file, proceed as follows:
1) Determine the destination for the image. Place the cursor at ornear the appropriate location in the document.


Do not worry too much about the exact placement of the image
Note	at this stage as this can be easily changed later as described in section ―Positioning graphics within the text‖ on page 279.


2) On the main menu, select Insert > Picture > From File. This displays the dialog box shown in Figure 249.
3) Navigate to the file to be inserted, select it, and click Open.
[image: ]
[bookmark: _bookmark46]Figure 249: Insert picture dialog box




Note

At the bottom of the Insert picture dialog box are two check boxes. If Preview is checked, the selected graphic file is previewed in a pane, as shown in Figure 249, so you can verify that you have the correct file. The Link option is discussed below.




Linking an image file
If the Link option in the Insert picture dialog box is selected, Writer creates a link to the file containing the image, instead of saving a copy of the image in the document. The result is that the image is displayed in the document, but when the document is saved, it will contain only areference to the image file—not the image itself. The document and the image remain as two separate files, and they are merged together only when you open the document again.
Linking an image has two advantages and one disadvantage:
· Advantage – Linking can reduce the size of the document when it is saved, because the image file itself is not included. The file size is usually not a problem on a modern computer with a reasonable amount of memory, unless the document includes many large graphics files. Writer can handle quite large files.
· Advantage – You can modify the image file separately without changing the document because the link to the file remains valid,and the modified image will appear when you next open the document. This can be a big advantage if you (or someone else, perhaps, a graphic artist) is updating images.

· Disadvantage – If you send the document to someone else, or move it to a different computer, you must also send the image files, or the receiver will not be able to see the linked images. Youneed to keep track of the location of the images and make sure the recipient knows where to put them on another machine, so the Writer document can find them. For example, you might keep images in a subfolder named Images (under the folder containingthe Writer document); the recipient of the Writer file needs to put the images in a subfolder with the same name (under the folder containing the Writer document).




Note

When inserting the same image several times in the document, it might appear beneficial to create links; however, this is not necessary as OOo embeds in the document only one copy of the image file.


Embedding linked images
If you originally linked the images, you can easily embed one or more of them later if you wish. To do so:
1) Open the Writer document in OOo.
2) Choose Edit > Links from the menu bar.
The Edit Links dialog box (Figure 250) shows all the linked files. In the Source file list, select the files you want to change from linked to embedded.
3) Click the Break Link button.
4) Save the Writer document.
[image: ]

[bookmark: _bookmark47]Figure 250: The Edit Links dialog box


Going the other way, from embedded to linked, is not so easy— you must delete and reinsert each image, one at a time, selecting the Link option when you do so.Note



Inserting images from other sources
You can insert images from sources other than a file:
· Graphics program
· Scanner
· OOo Gallery
Graphics program
You can use many different graphics programs to edit a graphic file. From these programs, you can select, copy, and paste an image or part of a graphic into an OOo document. Figure 251 shows an example of this procedure, which can be recreated with these steps:
1) In the graphic program window, select an area of the image to becopied.
2) Move the cursor over the selected area and press Control+C tocopy.

[bookmark: _bookmark48]Figure 251. Using a graphics program
3) Switch to the OOo Writer window.
4) Click to place the cursor where the graphic is to be inserted.
5) Press Control+V to paste the image.

Scanner
If a scanner is connected to your computer, OOo can call the scanning application and insert the scanned item into the Writer document page as an image. To start this procedure, place the cursor where the graphic is to be inserted and select Insert > Picture > Scan > SelectSource.
Although this practice is quick and easy, it is unlikely to result in a high-quality image of the correct size. You may get better results byscanning material into a graphics program and cleaning it up there before inserting the resulting image into Writer.
OpenOffice.org Gallery
The Gallery contains objects (graphics and sounds) that you can insert into your documents. The Gallery is available in all components of OOo. For an introduction to the Gallery, see Chapter 11 (Graphics, the Gallery, and Fontwork) in the Getting Started guide.
To select a graphic from the Gallery and drag it into the document:
1) Click on the Gallery icon [image: ] (located in the right side of the Standard toolbar) or choose Tools > Gallery.
2) Select the theme containing the image you want to insert.
3) Click on the image with the left mouse button, then drag and dropthe image into the document. You can also right-click on the object and select Insert
· Copy.
Figure 252 shows an example of an image dragged from the Gallery.
[image: ]
[bookmark: _bookmark49]Figure 252. Inserting an image from the Gallery

Modifying an image	
When you insert a new image, you may need to modify it to make it more suitable for fitting into the document. The placement of the picture relative to the text is discussed in ―Positioning graphics within the text‖ on page 279. This section describes the use of the Picture toolbar, resizing, and cropping, as well as a workaround to rotate a picture.





Note

Although OOo provides many tools for working with images, for best results it is generally better to use an image manipulation program such as GIMP2, to modify images (for example, to crop, resize, rotate, and change color values) and then insert the result into OOo.




Using the picture toolbar
When you insert a suitable graphic image or select one already present in the document, the Picture toolbar appears. This toolbar can be either floating or docked. Figure 253 shows what the Picture toolbar looks like when it is floating. Two other toolbars can be opened from this one: the Graphic Filter toolbar, which can be torn off and placed elsewhere on the window, and the Color toolbar, which opens as a separate floating toolbar.
From these toolbars, you can apply small corrections to the graphic or obtain special effects.
Filters
Table 5provides a short description of the available filters, however the best way to understand them is to see them in action. Feel free to experiment with the different filters and filters settings, remembering that you can undo all the changes by pressing Ctrl+Z or Alt+Backspace or by selecting Edit > Undo.

1	2	4	5	6	7	1 From File
2 Filter3	8
9
10
11
12
19
18
17
20
21
22
13	14	15	16
23
24
25

3 Graphics mode
4 Color
5 Transparency
6 Flip Horizontally
7 Flip Vertically
8 Graphics Properties
9 Invert
10 Smooth
11 Solarization
12 Aging
13 Charcoal Sketch
14 Relief
15 Mosaic
16 Posterize
17 Pop Art

Note: Graphics mode (3) can be Default, Grayscale, Black/White, or Watermark.



[bookmark: _bookmark50]Figure 253. Picture toolbar plus tear-off Graphic Filter toolbar and floating Color toolbar
18 
Sharpen
19 Remove Noise
20 Red
21 Green
22 Blue
23 Brightness
24 Contrast
25 Gamma


Figure 254 shows examples of some of the changes available on the Picture toolbar.


	Original Image
	Flipped 50%Vertically
	Flipped Horizontally
	Light

	
[image: ]
	
[image: ]
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	Contrast 50%
	Red 50%
	Green 50%
	Blue 50%

	
[image: ]
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[bookmark: _bookmark51]Figure 254. Some graphic effects available from the Picture toolbar

[bookmark: _bookmark52]Table 5: Graphic filters and their effects

	Icon	Name	Effect

	
[image: ]
	Invert
	Inverts the color values of a color image or the brightness values of a grayscale image.

	

	Smooth
	Softens the contrast of an image.

	

	Sharpen
	Increases the contrast of an image.

	
[image: ]
	Remove noise
	Removes single pixels from an image.

	

	Solarization
	Mimics the effects of too much light in a picture. A further dialog box opens to adjust the parameters.

	
[image: ]
	Aging
	Simulates the effects of time on a picture. Can be applied several times. A further dialog box opens to adjust the aging level.

	
[image: ]
	Posterize
	Makes a picture appear like a painting by reducing the number of colors used.

	
[image: ]
	Pop Art
	Modifies the picture dramatically.

	
[image: ]
	Charcoal
	Displays the image as a charcoal sketch.

	
[image: ]
	Relief
	A dialog box is displayed to adjust the light source that will create the shadow and, hence, the relief effect.

	
[image: ]
	Mosaic
	Joins groups of pixels into a single area of onecolor.


Color
Use this dialog box to modify the individual RGB color components of the image (red, green, blue) as well as the brightness, contrast, and gamma of the image. If the result is not satisfactory, you can press Control+Z to restore the default values.
Setting the object transparency
Modify the percentage value in the Transparency box [image: ] on the Picture toolbar to make the image more transparent. This is particularly useful when creating a watermark or when wrapping the image in the background.

Using the formatting toolbar and picture dialog
When an image is selected, you can customize some aspects of its appearance using the tools available on the Formatting toolbar (shown in Figure 259) as well as in the dialog that is shown by right-clicking on the image and selecting Picture (see Figure 255). You can, for example, create a border around the image, selecting style and color; or you can (in the Borders page of the Picture dialog) add a shadow tothe image.
Cropping images
When you are only interested in a section of the image for the purpose of your document, you may wish to crop (cut off) parts of it. To start cropping the image, right-click on it and select Picture from the pop- up menu. In the Picture dialog box, select the Crop page (Figure 255).
[image: ]
[bookmark: _bookmark53]Figure 255: The options available when cropping a picture
[bookmark: _bookmark54]In the Crop dialog box, you can control the following parameters:
· Keep scale / Keep image size options: when Keep scale is selected (default), cropping the image does not change the scale of the picture. When Keep image size is selected, cropping produces enlargement (for positive cropping values), shrinking

(for negative cropping values), or distortion of the image so thatthe image size remains constant.
· Left, Right, Top, and Bottom: the function of these boxes changes according to the choice made between Keep scale and Keep image size. In both cases, when a value is entered in one of these boxes, the image is cropped by that amount. For example, a value of 3cm in the Left box will cut 3 cm from the left side of thepicture.
When Keep scale is selected, the size of the image also changes, so in this example the width will be reduced by 3 cm. If Keep image size is selected instead, the remaining part of the image is enlarged (positive values for cropping) or shrunk (negative values for cropping) so that the width and height of the image remains unchanged.
Note that the Width and Height fields change as you enter the values when in this mode. Use the thumbnail next to these fields to determine the correct amount by which to crop.

Resizing an image
It is possible, and quite likely, that the inserted image will not fit perfectly into the document because it is too big or too small. In these cases you will need to resize the image.
1) Click the picture, if necessary, to show the green resizing handles.
2) Position the pointer over one of the green resizing handles. The pointer changes shape giving a graphical representation of the direction of the resizing.
3) Click and drag to resize the picture.
4) Release the mouse button when satisfied with the new size.
The corner handles resize both the width and the height of the graphic object simultaneously, while the other four handles only resize one dimension at a time.




Tip

To retain the original proportions of the graphic, Shift+click one of the corner handles, then drag. Be sure to release the mouse button before releasing the Shift key.



Be aware that re-sizing a bit-mapped (raster) image will adversely affect the resolution, causing some degree of blurring. It is better to externally size your picture correctly before insertion into your presentation, if possible.

Figure 256 shows three examples of an image inserted into a document and resized.

[bookmark: _bookmark55]Figure 256. Three examples of resized images, plus the original image
For more accurate resizing, use either the Crop page of the Picture dialog box (Figure 255) or, for images, the Type page of the Picture dialog box. On the Crop page you can either adjust the following settings or use the settings in the Crop section as described on page272.
· Scale Width and Height: specify in percentages the scaling of the picture. The size of the image changes accordingly. For a scaled resizing, both values should be identical.
· Image	size: specify the size of the image in your preferred unit of measurement. The image enlarges or shrinks accordingly.
· Original size button: when clicked, restores the image to itsoriginal size.
In the Type page of the Picture dialog box, select the Relative optionto toggle between percentage and actual dimension. For a scaled

resizing, select the Keep ratio option. As for the Crop page, clicking on the
Original Size button restores the original image size.

Rotating a picture
Writer does not provide a tool for rotating a picture; however, there is a very simple workaround:
1) Open a new Draw or Impress document.
2) Insert the image you want to rotate. You can use any of the mechanisms described in ―Adding images to a document‖ on page 264, although there are some slight variations in the position of the menu entries and icons.
3) Select the image, then in the drawing toolbar (shown by default at the bottom of the window in Impress and Draw), select the Rotate icon [image: ].
4) Rotate the image as desired. Use the red handles at the corners of the picture and move the mouse in the direction you wish to rotate. By default the picture rotates around its center (indicated by a black crosshair), but you can change the pivot point by moving the black crosshair to the desired rotation center.


To restrict the rotation angle to multiples of 15 degrees keep the
Shift key pressed while rotating the image.

5) Select the rotated picture by pressing Ctrl+A, then copy theimage to the clipboard with Ctrl+C.
6) Finish by going back to the location of the Writer document where the image is to be inserted and pressing Ctrl+V.

Other settings
The Picture dialog box (Figure 255) consists of eight pages. The Crop page was described on page 272, while the use of the Type and the Wrap pages is explained in ―Positioning graphics within the text‖ on page 279. The other pages serve the following purposes:
· Options: use this page to give the picture a descriptive name (as you want it to appear in the Navigator), display alternative text when the mouse hovers over the picture, and protect some of the picture settings from accidental changes. You can also prevent the picture from being printed by deselecting the corresponding option.

· Borders: use this page to create borders around the picture. The Borders dialog box is the same as the one used for defining table or paragraph borders. You can also add a shadow to the image if so desired.
· Background: use this page to change the background color of the picture. This setting produces the desired results only for images with a transparent color.
· Hyperlink: use this page to associate a hyperlink to the picture. you can also create an image map so that only certain areas of the picture respond to a mouse click by opening the associated URI (Uniform Resource Identifier) in the default browser. More information on image maps can be found in the Impress Guide.
· Picture: use this page to flip the picture as well as to display the original location of the file in case the image is linked rather than embedded.
· Macro: allows you to associate a macro to the picture. You can choose among the predefined macros or write your own.

Deleting a picture
To delete a picture:
1) Click on the picture, if necessary, to show the green resizinghandles.
2) Press Delete.
Using Writer’s drawing tools	
You can use Writer‘s drawing tools to create graphics, such as simple diagrams using rectangles, circles, lines, text, and other predefined shapes. You can also group several drawing objects to make sure theymaintain their relative position and proportion.
You can place the drawing objects directly on a page in your document, or you can insert them into a frame.
You can also use the drawing tools to annotate photographs, screen captures, or other illustrations produced by other programs, but this is not recommended because:
· You cannot include images in a group with drawing objects, sothey may get out of alignment in your document.
If you convert a Writer document to another format, such as HTML, the drawing objects and the graphics will not remainassociated; they are saved separately





















Open Office Calc(Spreadsheet)

Introduction
OpenOffice is an open source Office Suite package originally designed by Sun Microsystems. OpenOffice is much like Microsoft Office but free to use. The software can be freely downloaded and used.
OpenOffice Calc is much like using Microsoft Excel.




What is a Spreadsheet?
A spreadsheet is the computer equivalent of a paper ledger sheet. It consists of agrid made from columns and rows. It is an environment that can make number manipulation easy and somewhat painless.

The math that goes on behind the scenes on the paper ledger can be overwhelming. If you change the loan amount, you will have to start the math all over again (from scratch). The nice thing about using a computer and spreadsheet is that you can experiment with numbers without having to redo all the calculations. Let the COMPUTER do the calculations for you! Once you have the formulas set up, you can change the variables that are called from the formulaand watch the answers change. Spreadsheets are instantly updated if one of the entries is changed. NO erasers! NO new formulas! NO calculators!

Spreadsheets are made up of columns, rows, and cells (intersection of a column and row. A cell can contain data including text (strings or labels), numeric data, and formulas (mathematical equations).










Starting OpenOffice Calc
Procedure

1. Click Start, Programs, OpenOffice.org 1.0.3, OpenOffice Calc.
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[image: ]
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OpenOffice Calc (Spreadsheet) Basics
The picture below shows the Calc screen.
Status Bar
Worksheets (Sheet tabs)
Cell
Active Cell
Row
Instrumen tToolbar
Column
Calculation toolbar
Object Toolbar
Menu Bar
Function Toolbar
Title Bar
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The Menu toolbar contains the main menus of the Calc module. The Function toolbar provides user access to function icons such as Open, Save, Copy, Cut, Paste and other common tasks in Open Office. The Object toolbar consists of aset of tools that are specific to calculation and cell formatting (number format, text alignment, borders). Finally, the Calculation toolbar is intended for the entry of formulae necessary for your calculations, and also shows you the position of the cursor within the spreadsheet.

[image: ]On the left of the screen, you will notice the Instrument toolbar (show here on the right). This toolbar provides the tools that you will need to wor with your spreadsheet. The basic functions of the toolbar are explained in thin k s

`How-to'. At the bottom of the screen, you will notice the Status Bar. This bar provides essential information such as the sheet that you're currently working on, the page style, and in normal mode, the sum of the cell in whichthe cursor is situated.

You will also notice that the folder you have just opened contains three worksheets by default, indicated by the presence of three small tabs above the Status Bar and bearing the names: Sheet1, Sheet2, Sheet3.

The spreadsheet is represented as a grid comprising cells, with each cell bearing a unique reference. A cell is referenced by its column (vertical reference), given here as a letter (e.g. A...Z etc.), and its line (horizontal reference), given here as a number (e.g. 1...65000 etc.). These references appear as grey column and line headers on the spreadsheet. Thus, the first cell in the first line (the one at the uppermost left hand corner) bears the reference A1.










Creating a New Document
Procedures

1. Type CTRL+N on your keyboard (hold down the CTRL key and type N).
2. Select File, New, Spreadsheet from the Menu Bar OR
3. Click on the New Document Icon [image: ] on the Function Bar and selectSpreadsheet.
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Entering Data
Procedures

To enter text, values or a formula:
1. Click on the cell you wish to enter information.
2. Type the information.
3. Press the ENTER key on the keyboard or press one of the arrow keys.
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Selecting (Highlighting) Cell(s)

To Select One Cell
Procedure

1. Click in the cell. (The active cell is already selected.)


To Select a Range of Cells (e.g. A1:G5)
Procedures

1. On the first cell of the range (e.g. A1), click and hold the left mouse buttonwhile dragging the mouse to the last cell of the range (e/g. G5).
2. All cells will turn black except the first cell will remain white.

To Select a Column or Row
Procedure

1. Click on the column or row heading in gray.



Deleting Cell(s)
Procedures

1. Select the cell(s) you wish to delete.
2. Press the DELETE key on the keyboard. The following window will appear.
[image: ]
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3. Check the boxes of what you wish to delete (e.g. checking Formats willdelete things like bold, italics, font color, borders).
4. Click the OK button.



Opening and Saving a File
The opening, saving, and printing of files are the most common actions in a wordprocessor, and therefore, they have to be very easy and accessible.
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Opening a File
Procedures

1. Select the File menu, Open from the Menu Bar, OR
2. Click the Open File icon [image: ] on the toolbar.
3. An Open File Dialog box will appear as shown below. From the drop down list (shown by the arrow) indicated below, choose the directory thatcontains the file you wish to open.
4. When a list of files appears, double click on the filename to open the file.

Saving a File
Procedures

1. Choose File, Save from the Menu Bar, OR
2. Click the Save icon [image: ] on the Function Bar.
3. If you are saving for the first time, a Save File Dialog Window will bedisplayed.
4. Type a filename and choose a location to save the file.
5. If you wish to save your file as a Microsoft Excel file format, change theSave as type to Microsoft Excel 97/2000/XP.
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[image: ]
6. Click the Save button.



Cut, Copy, Paste
You can perform four main actions on a selected text: copying, cutting, deleting,and formatting.

Cut and Paste
This allows the user to move selected text so that it can be placed somewhere else in the document or in another document.
Procedures

1. Select cell(s) that contain the information you wish to cut (move).
2. Click the Cut [image: ] button on the toolbar or CTRL + X on the keyboard.
3. Click in the cell where you want to paste the information.
4. Click the Paste [image: ] button on the toolbar or CTRL+ V on the keyboard.
Copy and Paste
This allows the user to create a duplicate (copy) of the selected text to be placed somewhere else in the document or in another document.
Procedures
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1. Select cell(s) you wish to cut (move).
2. Click the Copy [image: ] button on the toolbar or CTRL + C on the keyboard.
3. Place the cursor where to place the cut cell(s).

4. Click the Paste [image: ] button on the toolbar or CTRL+ V on the keyboard.



Formatting Text
The formatting action in Open Office is slightly different from other Office applications such as Microsoft Office. There are two ways to format text in Open Office Writer.
Procedure

1. Use the buttons provided from the Toolbar or Format Menu.

Changing the Font/Font Size
Font is the style of writing and font size is the size of the text with a 12-point sizebeing 1/6 of an inch.
Procedures

1. Select the cell(s) you wish to change.
2. On the toolbar, click the [image: ] first drop-down arrow to change the font and the second drop down arrow to change the font size.
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Bold, Italics, Underline
Procedures

1. Select the cell(s) you wish to format.
2. Click on the attribute icon you wish to apply such as [image: ]on the Toolbar. These buttons transform the selected text (in sequence from leftto right) into Bold, Italics, and Underlined.
3. With the cell(s) still selected, click the button again to turn the feature off.
Note: More formatting options can be accessed by selecting Format menu,Cells.


Cell Alignment
Procedures

1. Select the cell you wish to change.
2. Click on one of the alignment icons [image: ] on the function toolbarto modify the text alignment (left, center, right, or justified).

Font Color
Procedures

1. Select the cell (s) you wish to change.
2. Click the font color button [image: ] on the toolbar and pick the color of yourchoice.

Background (highlighting) Color
Procedures

1. Select the cell (s) you wish to change.
2. Click the background color button [image: ] on the toolbar and pick the color ofyour choice.
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Undo/Redo Buttons
If you perform an action that does not give you the desired result, you can use the Undo button [image: ]to reverse the last action. Likewise, the Redo button [image: ] canbe used to Redo an action that has been undone.



Spelling/Grammar Check
There is only a spell check available in Open Office. Words spelled incorrectlywill be underlined in red if the spell check toggle button is turned on.
Procedures
1. To turn the spell check on/off as you are typing, click the [image: ] button on thetoolbar.
2. If you wish to spell check the entire document in order to makecorrections, click the [image: ] button on the toolbar.



Headers/Footers
A header/footer is a piece of information you would like to have appear at the top(header) or bottom (footer) of every page such as page numbers.
Adding Headers/Footers
A header is space at the top of the page reserved for such things as page numbers. A footer is space reserved at the bottom of the page.
Procedures

1. From the menu toolbar, choose Format, Page.
2. Click on the tab Footer.
3. In the window that appears, click on the checkbox that says Footer on.
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4. The button More allows you to add a border or background to the footer.
5. Click the Edit button.

The following window will appear.



6. Click in the area you want to place information (each area corresponds tothe area of your page).
7. Use the buttons to add information (e.g. page numbers). For example, click on the icon Page [image: ], you will see the page number written into theselected window or type your own information.
8. Click OK to return to the Page Style window.
9. Click OK to close this window.


Deleting a header/footer
Procedures

1. Click Format menu, Click Page…
2. Click Header or Footer tab.
3. Deselect Header or Footer checkbox.
4. Click Yes to delete the text in the header or footer.



Adding Pictures
Follow these steps if you wish to add pictures that are saved in a file.
Procedures
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1. Place your cursor where you want to place a picture.
2. Click Insert menu, Click Graphics, Click From File (as shown below)
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[image: ]
3. Pick the location where the file has been saved.
4. Double click filename to insert into document.
Note: Use the following toolbar to modify picture attributes.
[image: ]






Creating Formulas/Calculations

As mentioned above, the boxes that you see formed by the grid are called cells. You can enter text, numbers or formulae in these cells. Of course, the whole purpose of a spreadsheet application is to be able to carry out calculations within these cells. A calculation can be simply adding two numbers or taking the average of ten numbers.

Note: A right mouse button click in the box where Sum is written will give you access to a context-sensitive menu that proposes other choices, such as mean, maximum, minimum...
Formula Basics
· Just like in Microsoft Excel, formulas are started with an EQUAL (=)
sign.(e.g. =b3+b4)
· Use cell references (e.g. b3) instead of actual values (e.g. 56) whereverpossible.
· Use FUNCTIONS (e.g. SUM, AVERAGE) to save time when creating formulas.
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e.g.	=SUM(A1:A9)	Instead of =A1+A2+A3+A4+A5+A6+A7+A8+A9



By typing the colon [ : ] between the cell references, you have told the software that you want to add up the values in the range of cells from A1 to A9. The range is indicated on the screen by a red border. By typing ―=sum()‖, you are telling the software the type of mathematical operation that you want to carry out on the referenced cells that are between parentheses.

You can also select the ranges to be added together using the mouse. After having typed "= sum()" into the target cell, click on the first cell and whilst holding the mouse button down, drag the mouse to the last cell of the range, and then let go of the mouse button, and you will see the end of the formula inserted in automatically into the Formula bar.

Note : If the number that is displayed is too big to be displayed completely in the cell, it will be replaced by a series of musical flat symbols (###). In order to adjust the size of the cell, all you have to do is click on the right-hand column separator

of any given column and drag the separator rightwards (to broaden) or leftwards(to narrow). The same function can be reached through the command Format - Column - Optimal width.
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Cell References
It is important to grasp the basics of references when you want to carry outcalculations on cells containing formulae.

A relative reference is a range whose references are adjusted when the formula is moved:
e.g. If you copy the formula "=sum(A1:A9)" to column B, it will become"=sum(B1:B9)"

An absolute reference is used when a calculation has to refer to a precise or absolute cell of the spreadsheet. This is written using dollar signs ($) around the cell reference. For example, typing $A$1 will make column A and row 1 absolute or fixed.

e.g. If you copy the formula ―=$B$3 * B8‖ from cell C8 to cell C9, the formula would read ―=$B$3 * B9. Notice the first part of the formula (=$B$3) did not changed when copied. A good example of when you might use an absolute cell reference is when you are calculating the tax on an item. The tax (7%) will not change.  Each  item  will  be  multiplied  by  the  same  tax  amount
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Formatting Cell(s)

Text Alignment
Use these buttons [image: ] found on the toolbar to change the alignment of cell contents.


Merging Cells
Sometimes you might want to center a title between many columns.
Procedures

1. Select all the cells in which the title is to be centered between.
2. In the menu toolbar, select Format, Merge Cells, Define.
3. The cells are now merged into one large cell.	Click the Center
button [image: ] on the toolbar to center text within this cell.
4. Click the OK button.

Other Formatting Hints
The ‗Cell Attributes‘ window (click Format, Cells) below includes other tabs for cell formatting (e.g. Fonts, Font Effects, Alignment, etc). The function toolbaralso contains some of these formatting functions.
[image: ]

Example: Adding Borders
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A border such as a thick dark border can be added to emphasize a range of cells.

Procedures

1. Select the cells for which you want to add a border.
2. Choose the Format menu, Cells and click on the tab called `Borders'.
3. Choose the style and thickness of the border [image: ] you wish to use.




Renaming Sheets
Your spreadsheet contains three sheets, Sheet 1, 2, 3. Each sheet can be renamed.
Procedures

1. Right-click on the Sheet name (e.g. Sheet 1).
2. Click Rename.
3. Enter a name for your sheet and click the OK button; the sheet will thendisplay the new name in the tab.
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Page Settings
Page settings allows you to change settings related to a page as a whole such as changing the page orientation (e.g. portrait - 8.5‖ x 11‖ or landscape- 11‖ x 8.5‖), adding headers/footers, and margins.


Changing Page Orientation
Procedures

1. From the menu toolbar, choose Format, Page.
2. Click on the tab Page.
3. At the section Orientation, click on the radio button Landscape.
4. Confirm with OK.

To verify the change in page orientation, click the File menu, Preview.Other Page Setting Options
· In the Margins section of the Page tab, you set the margin sizes. If youset them beyond the printing area, a message will warn you.
· In the Layout settings section of the Page tab, Page Layout lets youselect how to align the content of the cells inside the sheet.
· In the Sheet Tab under Scale, the Reduce/enlarge printout option allows you to decrease or increase the size of the printed page.
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· [image: ]In the Sheet Tab under Scale, the Fit printout on number of pages option allows you to determine the exact number of pages on which the spreadsheet will be printed. The size of the sheets will be adjusted to fit that number of pages.




Using the AutoFormat feature
This feature formats a range of cells with color, borders, font, font size, etc.automatically rather than you having to do it one step at a time.
Procedures

1. Select the range of cells you wish to format.
2. Select the Format menu, AutoFormat, or click the AutoFormat button [image: ] on the toolbar to the left of your screen.
3. The following window will appear.
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[image: ]


4. Click the format you want from the left side. You can create your own format (see the Add. ..button to the right) and delete it when you do not
want it anymore. By clicking on the More button, some additional formatting options appear. If you modify them, the result will be presentedin the preview image displayed in the AutoFormat window.

5. Click	OK.
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Creating Charts
A chart (e.g. bar chart, pie chart) is a visual representation of data contained in aspreadsheet.
Procedures

1. Select the cells you wish to include in the chart.
2. Click the Insert menu, Chart…
3. Step 1: Choose whether you want your chart in the same sheet as yourdata or a new sheet.
4. Click Next.
5. Step 2: Choose a chart type from the list.
6. Click Next.
7. Step 3: Choose a chart sub-type (variant) from the list.Choose data series in rows or columns.
8. Click Next.
9. Step 4: Add a title to your chart.
10. Click the Create button.



Printing a File
It is a good habit to check how the document will look when printed, beforeprinting. It can be done by using the Page Preview feature.
Procedures

1. Select File, Page Preview from the menu bar to switch to the
PagePreview Mode.
2. Click Page Preview [image: ] button in Page Preview to close Page Preview and return to the main document.

You may want to print part of your spreadsheet, the entire workbook (allworksheets) or even only one sheet.





Printing a Selected Area of your Worksheet
30

Procedures

1. Select the cell(s) you wish to print.
2. Select the File menu, Print.
3. In the dialog box that appears, click on the box Selection in `Print range'.
4. Click OK.

Printing a Single Worksheet
Procedures

1. Click the File menu, Print.
2. In the dialog box that appears, under Print Range click on the radio button Pages and enter the page number that you wish to print. If you wishto print more than one page at a time such page 2 and 3, you would enter 2,3.
3. Click OK.


Printing Multiple Worksheets
Procedures

1. Select the worksheets you wish to print by clicking the first sheet tab at the bottom of the page, press and hold the CTRL key on the keyboard and select the remaining sheets you wish to print.
2. Click on the icon Quick printing in the function toolbar.
3. To undo selected sheets, press and hold the CTRL key and click once more on the sheet tab.

Source: Gautier, Sophie (January 16, 2002). OpenOffice.org Documentation Project. Available at http://whiteboard.openoffice.org/doc/index.html
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Getting Started with Impress
Presentations in OpenOffice.org
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What is Impress?

Impress is OpenOffice.org‘s slide show (presentations) program. You can create slides that contain many different elements, including text, bulleted and numbered lists, tables, charts, clip art, and a wide range of graphic objects. Impress also includes a spelling checker, a thesaurus, prepackaged text styles, and attractive background styles.
This chapter includes instructions, screenshots, and hints to guide you through the Impress environment while designing the easier presentations. Although more difficult designs are mentioned throughout this chapter, explanations for creating them are in the Impress Guide. If you have a working knowledge of how to create slide shows, we recommend you use the Impress Guide for your source of information.
To use Impress for more than very simple slide shows requires some knowledge of the elements which the slides contain. Slides containing text use styles to determine the appearance of that text. Graphic objects are created the same way that drawings are created in Draw..



Starting Impress

You can start Impress in several ways:
· From the OOo Start Center, if no component is open.
· From the system menu or the OOo Quickstarter. Details vary with your operating system; see Chapter 1 (Introducing OpenOffice.org) for more information.
· From any open component of OOo. Click the triangle to the right of the New icon on the main toolbar and select Presentation from the drop-down menu or choose File > New > Presentation from the menu bar.
When you start Impress for the first time, the Presentation Wizard is shown. Here you can choose from the following options:
· Empty presentation, which gives you a blank document
· From template, which is a presentation designed with a template of yourchoice
· Open existing presentation
If you prefer not to use the wizard in future, you can select Do not show this wizardagain.
Click Create to open the main Impress window.

Parts of the main Impress window

The main Impress window (Figure 1) has three parts: the Slides pane, Workspace, and Tasks pane. Additionally, several toolbars can be displayed or hidden during thecreation of a presentation.
[image: ]
[bookmark: _bookmark56]Figure 1: Main window of Impress; oval indicates the Hide/Show markers





Tip

You can remove the Slides pane or Tasks pane from view by clicking the X in the upper right corner. You can also show or hide these panes using View > Slide Pane or View > Tasks Pane.
You can also hide these panes in order to maximize the Workspace area by clicking the Hide/Show marker in the middle of the vertical separator line and restore them by clicking again on the same area.

Slides pane
The Slides pane contains thumbnail pictures of the slides in your presentation, in the order they will be shown (unless you change the slide show order). Clicking a slide in this pane selects it and places it in the Workspace. When a slide is in the Workspace, you can apply to it any changes desired.
Several additional operations can be performed on one or more slides simultaneously in the Slides pane:
· Add new slides to the presentation.
· Mark a slide as hidden so that it will not be shown as part of the presentation.
· Delete a slide from the presentation if it is no longer needed.
· Rename a slide.
· Duplicate a slide (copy and paste) or move it to a different position in the presentation (cut and paste).

It is also possible to perform the following operations, although there are more efficient methods than using the Slides pane:
· Change the slide transition following the selected slide or after each slide in a group of slides.
· Change the sequence of slides in the presentation.
· Change the slide design.
· Change slide layout for a group of slides simultaneously.
























[image: ][image: ]


Tasks pane
The Tasks pane has five sections. To expand the section you wish to use, click on the right-pointing triangle to the left of the caption. Only one section at a time can be expanded.
Master Pages
Here you define the page style for your presentation. Impress contains prepackaged Master Pages (slide masters). One of them—Default—is blank, andthe rest have a background.




Tip

Press F11 to open the Styles and Formatting window, where you can modify the styles used in any slide master to suit your purpose. This can be done at any time.




Layout
The prepackaged layouts are shown here. You can choose the one you want, use it as it is or modify it to your own requirements. At present it is not possible to create custom layouts.
Table Design
The standard table styles are provided in this pane. You can further modify the appearance of a table with the selections to show or hide specific rows and columns, or to apply a banded appearance to the rows and columns.
Custom Animation
A variety of animations for selected elements of a slide are listed. Animation can be added to a slide, and it can also be changed or removed later.
Slide Transition
Many transitions are available, including No Transition. You can select the transition speed (slow, medium, fast), choose between an automatic or manual transition, and choose how long the selected slide will be shown.

Workspace
The Workspace has five tabs: Normal, Outline, Notes, Handout, and Slide Sorter. These five tabs are called View buttons. The Workspace below the View buttons changes depending on the chosen view.
[image: ]

Figure 2: Workspace tabs
[image: ][image: ]


Toolbars
Many toolbars can be used during slide creation; they can be displayed or hidden byclicking View > Toolbars and selecting from the menu.
You can also select the icons that you wish to appear on each toolbar. For more information, refer to Chapter 1 (Introducing OpenOffice.org) in this book.
Many of the toolbars in Impress are similar to the toolbars in Draw. Refer to the
Draw Guide for details on the functions available and how to use them.

Status bar
The Status bar, located at the bottom of the Impress window, contains information that you may find useful when working on a presentation.






































[image: ][image: ]




Note

The sizes are given in the current measurement unit (not to be confused with the ruler units). This unit is defined in Tools > Options
· OpenOffice.org Draw > General, where you can also change the scale of the page. Another way to change the scale is to double-click on the number shown in the status bar.

[image: ]

Figure 3: Left end of the Impress status bar
[image: ]

Figure 4: Right end of Impress status bar









[image: ]Navigator
The Navigator displays all objects contained in a document. It provides another convenient way to move around a document and find items in it. To display the Navigator, click its icon [image: ] on the Standard toolbar, choose View > Navigator on themenu bar, or press Ctrl+Shift+F5.
The Navigator is more useful if you give your slides and objects (pictures, spreadsheets, and so on) meaningful names, instead of leaving them as the default ―Object 1‖ and ―Shape 1‖ shown in
Figure Error: Reference source not found.

Figure 5: Navigator


8 Getting	Started	with
Impress

Workspace views	

Each of the workspace views is designed to ease the completion of certain tasks; it is therefore useful to familiarize yourself with them in order to quickly accomplish those tasks.

Normal view
Normal view is the main view for working with individual slides. Use this view to format and design and to add text, graphics, and animation effects.
To place a slide in the slide design area (Normal view), click the slide thumbnail inthe Slides pane or double-click it in the Navigator.

Outline view
Outline view contains all the slides of the presentation in their numbered sequence. It shows topic titles, bulleted lists, and numbered lists for each slide in outline format.
Only the text contained in the default text boxes in each slide is shown, so if your slide includes other text boxes or drawing objects, the text in these objects is not displayed. Slide names are also not included.
[image: ]

Figure 6: Outline view
Use Outline view for the following purposes.
1) Making changes in the text of a slide:
· Add and delete the text in a slide just as in the Normal view.
· [image: ]Move the paragraphs of text in the selected slide up or down by using the up and down arrow buttons (Move Up or Move Down) on the Text Formatting toolbar.
· Change the outline level for any of the paragraphs in a slide using the left and right arrow buttons (Promote or Demote).
· Both move a paragraph and change its outline level using a combination ofthese four arrow buttons.
2) [image: ][image: ]Comparing the slides with your outline (if you have prepared one in advance). If you notice from your outline that another slide is needed, you can create it directly in the Outline view or you can return to the


Normal view to create it.

Notes view
Use the Notes view to add notes to a slide.
1) Click the Notes tab in the Workspace.
2) Select the slide to which you want to add notes.
· Click the slide in the Slides pane, or
· Double-click the slide‘s name in the Navigator.
3) In the text box below the slide, click on the words Click to add notes
and begin typing.
You can resize the Notes text box using the green resizing handles which appear when you click on the edge of the box. You can also move the box by placing the pointer on the border, then clicking and dragging. To make changes in the text style, press the F11 key to open the Styles and Formatting window.

Figure 7: Notes view

[image: ]











[image: ][image: ]


Handout view
Handout view is for setting up the layout of your slide for a printed handout. Click the Handout tab in the workspace, then choose Layouts in the Tasks pane. You can then choose to print 1, 2, 3, 4, 6, or 9 slides per page.
[image: ]

Figure 8: Handout layouts
Use this view also to customize the information printed on the handout. Refer to Chapter 10 of the Impress Guide for instructions on printing slides, handouts, andnotes.
Select from the main menu Insert > Page Number or Insert > Date and Time andin the dialog box that opens click on the Notes and Handouts tab (see Figure 9). Use this dialog to select the elements you want to appear on each handout page and theircontents.
[image: ]
[bookmark: _bookmark57]Figure  9:  Dialog  to  set  the  page  information  for  handouts  and  notes





[image: ][image: ]


Slide Sorter view
Slide Sorter view contains all of the slide thumbnails. Use this view to work with a group of slides or with only one slide.
[image: ]

Figure 10: Slide Sorter view


Customizing Slide Sorter view
To change the number of slides per row:
1) Check View > Toolbars > Slide View to make the Slide View toolbar visible.
[image: ]

Figure 11: Slide Sorter and Slide View toolbars
2) Adjust the number of slides (up to a maximum of 15).
Moving a slide using Slide Sorter
To move a slide in a presentation in the Slide Sorter:
1) Click the slide. A thick black border is drawn around it.
2) Drag and drop it to the location you want.
· As you move the slide, a black vertical line appears to one side of theslide.
· Drag the slide until this black vertical line is located where you
[image: ][image: ]	want theslide to be moved.	

Selecting and moving groups of slides
To select a group of slides, use one of these methods:
· Use the Control (Ctrl) key: Click on the first slide and, while keeping the Control key pressed, select the other desired slides.
· Use the Shift key: Click on the first slide, and while pressing the Shift key, click on the final slide in the group. This selects all of the other slides in between the first and the last.
· Use the mouse: Click slightly to the left of the first slide to be selected. Hold down the left mouse button and drag the mouse pointer to a spot slightly to the right of the last slide to be included. (You can also do this right to left.) A dashed outline of a rectangle forms as you drag the cursor through the slide thumbnails and a thick border is drawn around each of the selected slides. Make sure the rectangle includes all the slides you want to select.
To move a group of slides:
1) Select the group.
2) Drag and drop the group to their new location. A vertical black line appears toshow you where the group of slides will go.
Working in Slide Sorter view
You can work with slides in the Slide Sorter view just as you can in the Slide pane.
To make changes, right-click a slide and choose any of the following from the pop-upmenu:
· Add a new slide after the selected slide.
· Rename or delete the selected slide.
· Change the slide layout.
· Change the slide transition.
· For one slide, click the slide to select it. Then add the desired transition.
· For more than one slide, select the group of slides and add the desired transition.
· Mark a slide as hidden. Hidden slides will not be shown in the slide show.
· Copy or cut and paste a slide.
Renaming slides
Right-click on a thumbnail in the Slides pane or the Slide Sorter and choose Rename Slide from the pop-up menu. In the Name field, delete the old name of the slide and type the new name. Click OK.




[image: ][image: ]


Creating a new presentation

This section describes how to start a new presentation using the Presentation Wizard. When you start Impress, the Presentation Wizard appears.





Tip

If you do not want the wizard to start every time you launch Impress, select the Do not show this wizard again option. You can enable the wizard again later under Tools
· Options > OpenOffice.org Impress
· General > Wizard, and select the Start with wizard
option.
Leave the Preview option selected, so templates, slide designs, and slide transitions appear in the preview box as you choose them.



[image: ]

[bookmark: _bookmark58]Figure 12. Choosing the type of presentation
1) Select Empty Presentation under Type. It creates a presentation from scratch.
· From template uses a template design already created as the basis for a new presentation. The wizard changes to show a list of available templates. Choose the template you want.

[image: ]


· Open existing presentation continues work on a previously created presentation. The wizard changes to show a list of existing presentations. Choose the presentation you want.
Both of these options are covered in the Impress Guide.
2) Click Next. Figure 13 shows the Presentation Wizard step 2 as it appears if you selected Empty Presentation at step 1. If you selected From template, anexample slide is shown in the Preview box.
[image: ]

[bookmark: _bookmark59]Figure 13. Selecting a slide design
3) Choose a design under Select a slide design. The slide design section gives you two main choices: Presentation Backgrounds and Presentations. Each one has a list of choices for slide designs. If you want to use one of these other than <Original>, click it to select it.
· The types of Presentation Backgrounds are shown in Figure 13. By clicking an item, you will see a preview of the slide design in the Preview window. Impress contains three choices under Presentations: <Original>, Introducing a New Product, and Recommendation of a Strategy.
· <Original> is for a blank presentation slide design.
· Both Introducing a New Product and Recommendation of a Strategy have their own prepackaged slide designs. Each design appears in the Preview window when its name is clicked.




[image: ]Note

Introducing a New Product and Recommendation of a Strategy can also be used to create a presentation by choosing From template in the first step (Figure 12).




4) Select how the presentation will be used under Select an output medium. Most often, presentations are created for computer screen display. Select Screen. You can change the page format at any time.
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The Screen page is optimized for a 4:3 display (28cm x 21cm) so it is not suitable for modern widescreen displays. You can change the slide size at any time switching to Normal view and selecting Format > Page.Note



5) Click Next. The Presentation Wizard step 3 appears.
[image: ]

Figure 14. Selecting a slide design
· Choose the desired slide transition from the Effect drop-down menu.
· Select the desired speed for the transition between the different slides in the presentation from the Speed drop-down menu. Medium is a good choice for now.
6) Click Create. A new presentation is created.
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Formatting a presentation

A new presentation contains only one empty slide. In this section we will start addingnew slides and preparing them for the intended contents.

Inserting slides
This can be done in a variety of ways; take your pick.
· Insert > Slide.
· Right-click on the present slide, and select Slide > New Slide from the pop-upmenu.
· Click the Slide icon in the Presentation toolbar.
[image: ]

Sometimes, rather than starting from a new slide you want to duplicate a slide you have already inserted. To do so select the slide you want to duplicate from the Slides pane and then choose Insert > Duplicate Slide.

Selecting a layout
In the Tasks pane, select the Layout drawer to display the available layouts. The Layouts differ in the number of elements a slide will contain, spanning from the empty slide (Blank Slide) to a slide with 6 contents boxes and a title
[image: ]
(Title, 6 contents).
Figure 15: Available slide layouts
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The Title Slide (which also contains a section for a subtitle) or Title Only are suitable layouts for the first slide, while for most of the slides you will probably use the Title, Contents layout.






Tip

If you do not know the names for the prepackaged layouts position the cursor on an icon in the Layout section and its name will be displayed in a small rectangle.
The small rectangle is called tooltip. If the tooltips are not enabled select Tools > Options > OpenOffice.org > General > Help and mark the Tips checkbox. If the Extended tips checkbox is also marked, you will get more detailed tooltip information, but the tooltip names themselves will not be provided.




Several layouts contain one or more content boxes. Each of these boxes can be configured to contain one of the following elements: Text, Media clip, Picture, Chart or Table.
You can choose the type of contents by clicking on the corresponding icon that is displayed in the middle of the contents box as shown in Figure 16. If instead you intend to use the contents box for text, just click anywhere on the box to get a cursor.
[image: ]

[bookmark: _bookmark60]Figure	16:	Selecting	the	desired	contents	type	for	a contents box
[image: ]To select or change the layout, place the slide in the work area and select the


desired layout from the layout drawer in the Task Pane.
If you have selected a layout with one or more contents boxes, this is a good time to decide what type of contents you want to insert.
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Modifying the slide elements
At present each slide will contain only the elements that are present in the slide master you are using such as background images, logos, header, footer and so on. It is however unlikely that the predefined layouts will suit all your needs. Although Impress does not have the functionality to create new layouts, it allows you to resize and move the layout elements. It is also possible to add slide elements without being limited to the size and position of the layout boxes.
To resize a contents box, click on the outer frame so that the 8 resizing handles are displayed. To move it place the mouse cursor on the frame so that the cursor changes shape. You can now click the left mouse button and drag the contents box to its new position on the slide.




Caution

[image: ]

Changes to any of the pre-packaged layouts can only be made using View > Normal, which is the default. Attempting to do this by modifying a slide master, although possible, may result in unpredictable results and requires extra care as well as a certain amount of trial and error.



At this step you may also want to remove unwanted frames. To do this:
· Click	the	element	to	highlight	it.	(The	green	squares	show	it	is highlighted.)
· Press the Delete key to remove it.

Adding text to a slide
If the slide contains text, click on Click to add an outline in the text frame and then type your text. The Outline styles from 1 to 10 are automatically applied to the text as you insert it. You can change the outline level of each paragraph as well as its position within the text using the arrow buttons on the Text Formatting toolbar. See ―Adding and formatting text‖ on page 19 for more information.
Modifying the appearance of all slides
To change the background and other characteristics of all slides in the presentation, it is best to modify the slide master or choose a different slide master as explained in the section Working with slide masters and styles on page 26.
If all you need to do is to change the background, you can take a shortcut:
1) Select Format > Page and go to the Background tab.
2) Select	the	desired	background	between	solid	color,	gradient, hatching andbitmap.
3) Click OK to apply it.
A dialog box will open asking if the background should be applied to all the slides. If you click yes, Impress will automatically modify the slide master for
[image: ][image: ]


you.




Note

Inserting and correctly formatting a background is beyond the scope of this chapter, but you can find all the information you need in Chapter 4 of the Draw Guide or in Chapter 6 of the Impress Guide.
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[bookmark: _bookmark61]Modifying the slide show
By default the slide show will display all the slides in the same order as they appear in the slide sorter, without any transition between slides, and you need some keyboard or mouse interaction to move from one slide to the next.
You can use the Slide Show menu to change the order of the slides, choose which ones are shown, automate moving from one slide to the next, and other settings. To change the slide transition, animate slides, add a soundtrack to the presentation, and make other enhancements, you need to use functions in the Task pane. See the Impress Guide for details on how to use all of these features.



[bookmark: _bookmark62]Adding and formatting text	

Many of your slides are likely to contain some text. This section gives you some guidelines on how to add text and how to change its appearance. Text in slides iscontained in text boxes.
There are two types of text boxes that you can add to a slide:
· Choose a predefined layout from the Layouts section of the Tasks pane and do not select any special contents type. These text boxes are called AutoLayout text boxes.
· Create a text box using the text tool in the Drawing toolbar.

Using text boxes created from the Layout pane
In Normal view:
1) Click in the text box that reads Click to add text, Click to add an outline, ora similar notation.
2) Type or paste your text in the text box.
Using text boxes created from the text box tool
In Normal view:
1) Click on the Text icon [image: ] on the Drawing toolbar. If the toolbar with the text icon is not visible, choose View > Toolbars > Drawing.
2) Click and drag to draw a box for the text on the slide. Do not worry about thevertical size and position—the text box will expand if needed as you type.



3) Release the mouse button when finished. The cursor appears in the

text box, which is now in edit mode (gray hashed border with green resizing handles shown in Figure 17).
4) Type or paste your text in the text box.
5) Click outside the text box to deselect it.

[image: ]

[bookmark: _bookmark63]Figure 17: Selected text box showing the green resizing
	handles and text toolbar	
In addition to the normal text boxes where text is horizontally aligned, it is possible to insert text boxes where the text is aligned  vertically.  This choice  is available  only  when  Asian

Note

languages are enabled in Tools > Options > Language Settings > Languages.
Click on the [image: ] button in the drawing toolbar to create a vertical text box. Note that when editing the contents, the text is displayed horizontally.



[bookmark: _bookmark64]Quick font resizing
Starting with OOo3.1, Impress has convenient buttons on the Formatting toolbar toincrease or decrease font size of selected text. The amount by which the font size changes depends on the standard sizes available for the font in use.

Pasting text
You can insert text into a text box by copying it from another document and pasting it into Impress. However, the pasted text will probably not match the formatting of the surrounding text or that of the other slides in the presentation. This may be what you want on some occasions; however in most cases you want to make sure that the presentation does not become a patchwork of different paragraph styles, font types, bullet points and so on. There are several ways to ensure consistency; these methods are explained below.

Pasting unformatted text
It is normally good practice to paste text without formatting and apply the formatting later. To paste without formatting, either press Control+Shift+V and then select Unformatted text from the dialog that appears, or click on the small black triangle next to the paste symbol in the standard toolbar [image: ] and  select  Unformatted text. The unformatted text will be formatted with the outline style at the cursor position in an AutoLayout text box or with the default graphic style in a normal text box.
Formatting pasted text
If you are pasting the text into an AutoLayout area, you need to apply the appropriate outline style to the text to give it the same look and feel as the rest of the presentation.
1) Paste the text in the desired position. Do not worry if it does not look right; it will in a minute.
2) Select the text you have just pasted.
3) Select Format > Default formatting from the menu bar.
4) Use the four arrow buttons in the Text Formatting toolbar [image: ] to move the text to the appropriate position and give it the appropriate outline level. The button with the arrow pointing left promotes the list entry by one level (for example from Outline 3 to Outline 2), the right arrow button demotes the list entry by one level, the up and down arrow buttons move the list entry.
5) Apply manual formatting as required to sections of the text (to change fontattributes, tabs, and so on).
[image: ][image: ]


If you are pasting text in a text box, you can still use styles to quickly format the text. Note that one and only one graphic style can be applied to the copied text. To dothat:
1) Paste the text in the desired position.
2) Select the text you have just pasted.
3) Select the desired graphic style.
4) Apply manual formatting as required to sections of the text.


[image: ]Presentation styles are very different from Writer styles and areapplied in quite a different way.


Creating bulleted and numbered lists
The procedure to create a bulleted or numbered list is quite different depending onthe type of text box used, although the tools to manage the list and customize the appearance are the same.
In text boxes created automatically by Impress (called AutoLayout), the outline styles available are by default bulleted lists, while for normal text boxes an additional step is required to create a bulleted list.

Creating lists in AutoLayout text boxes
Every text box included in the available layouts is already formatted as a bulleted list, therefore to create a bulleted list the only necessary steps are:
1) From the Layout pane, choose a slide design that contains a text box. Those are easily recognizable from the thumbnail.
2) Click in the text box that reads Click to add an outline.
3) Type the text, then press Enter to start a new bulleted line.
The methods for switching between bulleted and numbered lists are explained in―Changing the appearance of the list‖ on page 22.





Tip

Press Shift + Enter to start a new line without creating a new bullet or number. The new line will have the same indentation of the previous line. To switch off bullets altogether, click the bullets button on the text formatting toolbar. If the text formatting toolbar is not showing, enable it selecting View > Toolbar > Formatting in the menu bar.







Creating lists in other text boxes
To create a list in a text box, follow these steps:
[image: ][image: ]	1)  Place the cursor in the text box.	

2) Click the Bullets On/Off button [image: ] on the text formatting toolbar. If the text formatting toolbar is not showing, enable it by selecting View
· Toolbar > Formatting from the menu bar.
3) Type the text and press Enter to start a new bulleted line.
4) The default list type is a bulleted list. Methods for changing the appearance ofthe list are explained on page 22.
Creating a new outline level
1) If necessary, press Enter to begin a new line.
2) Press Tab. Each time you press Tab the line indents to the next outline level. Pressing Enter creates a new line at the same level as the previous one. To return to the previous level, press Shift+Tab.
In the AutoLayout text boxes, promoting or demoting an item in the list corresponds to applying a different outline style, so the second outline level corresponds to Outline 2 style, the third to Outline 3 style, and so on.




Note

Do not try to change the outline level by selecting the text and then clicking the desired outline style as you would in Writer. Due to the way that presentation styles work, it is not possible to apply them in this way.




[bookmark: _bookmark65]Changing the appearance of the list
You can fully customize the appearance of a list, changing the bullet type or numbering for the entire list or for single entry. All of the changes can be made using the Bullets and Numbering dialog, which is accessed by selecting Format > Bullets and Numbering or by clicking on the Bullets and Numbering icon on the text formatting toolbar.
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For the entire list:
1) Select the entire list or click on the gray border of the text box so that the green resizing handles are displayed.
2) Select Format > Bullets and Numbering or click on the
Bullets and Numbering icon [image: ].
3) The Bullets and Numbering dialog contains five tabs: Bullets, Numbering type, Graphics, Position, and Customize.
· If a bullet list is needed, select the desired bullet style from the default styles available on the Bullets page.
· If a graphics style is needed, select one from those available on the
Graphics page.
· If a numbered list is needed, select one of the default numbering styles on the Numbering type page.
For a single line in the list:
1) Click anywhere in the line to place the cursor in it.
2) Follow steps 2–4 of the previous instruction set.
If the list was created in an AutoLayout text box, then an alternative way to change the entire list is to modify the Outline styles. Changes made to the outline style will apply to all the slides using them. Sometimes this is what you want; sometimes it is not, so some care must be taken.


[bookmark: _bookmark66]Adding pictures, tables, charts and media

As we have seen, besides text a contents box can contain also pictures, tables, charts or media clips. This section provides a quick overview of how to work with these objects, however for a more detailed description you are invited to consult the Impress Guide.

[image: ]Adding pictures
To add a picture to a contents box:

· Click the Insert Picture icon.
· Use the file browser to select the picture file you want to include. To see a preview of the picture, check Preview at the bottom of the Insert picture dialog.
· Click Open.
The picture will resize itself to fill the area of the contents box. Follow the directions in the Caution note below when resizing it by hand.



Caution

[image: ]

When resizing a graphic, right-click the picture. Select Position and Size from the context menu and make sure that Keep ratio is selected. Then adjust the height or width to the size you need. (As you adjust one dimension. both dimensions will change.) Failure to do so will cause the picture to become distorted. Remember also that resizing a bitmap image will reduce its quality; better by far to create an image of the desired size outside of Impress.




Adding tables
For displaying tabular data, you can insert basic tables directly into your slides by choosing the Table contents type. It is also possible to add a table outside a contentsbox in a number of ways:
· Choose Insert > Table from the menu bar
· With the Table button on the main toolbar [image: ]
· With the Table Design button on the table toolbar
· Select a Style option from the Table Design section of the Tasks pane.
Each method opens the Insert Table dialog, shown in Figure 18. Alternatively, clicking on the black arrow next to the Table button displays a graphic that you can drag and select the number of rows and columns for
[image: ]
your table.
[bookmark: _bookmark67]Figure 18. Creating a table with the Insert Table dialog




Note

Selecting from any of the styles in the Table Design section of the Tasks pane creates a table based on that style. If you create a table by another method, you can still apply a style of your choice later.




With the table selected, the Table toolbar should appear. If it does not, you can access it by selecting View > Toolbars > Table. The Table toolbar offers many of the same buttons as the table toolbar in Writer, with the exception of functions like Sort and Sum for performing calculations. For those functions, you need to use a spreadsheet inserted from Calc (discussed below).
After the table is created, you can modify it in much the same ways as you would modify a table in Writer: adding and deleting rows and columns, adjusting width and spacing, adding borders, background colors and so on. Detailed information on working with tables and the Table Properties dialog can be found in Chapter 9 of the Writer Guide.
By modifying the style of the table from the Table Design section of the Tasks pane, you can quickly change the appearance of the table or any newly created tables based on the Style options you select. You can choose to add emphasis to a header
and total row as well as the first and last columns of the table, and apply a banded appearance to the rows and columns.
Having completed the table design, entering data into the cells is similar to working with text box objects. Click in the cell you wish to add data to, and begin typing. To move around cells quickly, use the following key options:
· The arrow keys move the cursor to the next table cell if the cell is empty, otherwise they move the cursor to the next character in the cell.
· The Tab key moves to the next cell, skipping over the contents of the cell;
Shift+Tab move backwards in this manner.
[bookmark: _bookmark68]Adding charts
To insert a chart in a slide you can either use the Insert Chart feature or select Chart as type for one of the contents box. In both cases Impress will insert a default chart. To modify the chart type, insert your own data and change the formatting refer to the Impress Guide.

Adding media clips
You can insert various types of music and movie clips into your slide by selecting the Insert Movie button in an empty contents box. A media player will open at the bottom of the screen and you can preview the media. In case of an audio file, the contents box will be filled with a loudspeaker image.


[image: ]Caution  In Linux-based systems such as Ubuntu, media do not work straight out of the box. You need to download the Java Media Framework API (JMF)
and add the path to jmf.jar to the Class Path in Tools >


Options >OpenOffice.org > Java.
Adding graphics, spreadsheets, and other objects
Graphics such as shapes, callouts, arrows, and so on are often useful to complement the text on a slide. These objects are handled much the same as graphics in Draw.
Spreadsheets embedded in Impress include most of the functionality of spreadsheets in Calc and are therefore capable of performing extremely complex calculations and data analysis. If you need to analyze your data or apply formulas, these operations are best performed in a Calc spreadsheet and the results displayed in an embedded Impress spreadsheet or even better in a native Impress table.
Alternatively, choose Insert > Object > OLE Object from the menu bar. This opens a spreadsheet in the middle of the slide and the menus and toolbars change to those used in Calc so that you can start adding data, though you may first need to resize the visible area on the slide. You can also insert an already existing spreadsheet and use the viewport to select the data that you want to display on your slide.
Impress offers the capability of inserting in a slide various other types of objects such Writer documents, Math formulas, or even another presentation.

[bookmark: _bookmark69]Working with slide masters and styles

A slide master is a slide that is used as the starting point for other slides. It is similar to a page style in Writer: it controls the basic formatting of all slides based on it. A slide show can have more than one slide master.




Note

OOo uses three terms for a slide that is used to create other slides: master slide, slide master, and master page. This book uses the term slide master, except when describing the user interface.
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A slide master has a defined set of characteristics, including the background color, graphic, or gradient; objects (such as logos, decorative lines, and other graphics) in the background; headers and footers; placement and size of text frames; and the formatting of text.

Styles
All of the characteristics of slide masters are controlled by styles. The styles of any new slide you create are inherited from the slide master from which it was created. In other words, the styles of the slide master are available and applied to all slides created from that slide master. Changing a style in a slide master results in changes to all the slides based on that slide master, but you can modify individual slides without affecting the slide master.
Slide masters have two types of styles associated with them: presentation styles and graphic styles. The prepackaged presentation styles can be modified, but new presentation styles cannot be created. In the case of graphic styles, you can modify the prepackaged ones and also create new ones.
Presentation styles affect three elements of a slide master: the background, background objects (such as icons, decorative lines, and text frames), and the text placed on the slide. Text styles are further divided into Notes, Outline 1 through Outline 9, Subtitle, and Title. The outline styles are used for the different levels of the outline to which they belong. For example, Outline 2 is used for the subpoints of Outline 1, and Outline 3 is used for the subpoints of Outline 2.
Graphic styles affect many of the elements of a slide. Notice that text styles exist inboth the presentation and graphic style selections.

Slide masters
Impress comes with several prepackaged slide masters. They are shown in the Master Pages section of the Tasks pane. This section has three subsections: Used in This Presentation, Recently Used, and Available for Use. Click the + sign next to the name of a subsection to expand it to show thumbnails of the slides, or click the – sign to collapse the subsection to hide the thumbnails.
Each of the slide masters shown in the Available for Use list is from a template of the same name. If you have created your own templates, or added templates from other sources, slide masters from those templates will also appear in this list.

[image: ]
[bookmark: _bookmark70]Figure 19: Available master pages (slides)
Creating a slide master
Creating a new slide master is similar to modifying the default slide

[image: ]
master. To start, enable editing of slide masters by View > Master
· Slide Master.
On the Master View toolbar, click the New Master icon. [image: ]
A second slide master appears in the Slides pane. Modify this slide master to suit your requirements. It is also recommended that you rename this new slide master: right-click on the slide in the Slides pane and select Rename master from the pop- up menu.
When you are done, close the Master View toolbar to return to normal slide editingmode.

Applying a slide master
In the Tasks Pane, be sure the Master Pages section is showing.
To apply one of the slide masters to all slides in your presentation, click on it in thelist.
To apply a different slide master to one or more selected slides:
1) In the Slide Pane, select the slides you want to change.

2) In the Tasks Pane, right-click on the slide master you want to apply to the selected slides, and click Apply to Selected Slides on the pop-up menu.

Loading additional slide masters
Sometimes, in the same set of slides, you may need to mix multiple slide masters that may belong to different templates. For example, you may need a completely different layout for the first slide of the presentation, or you may want to add to your presentation a slide from a different presentation (based on a template available on the hard disk).
The Slide Design dialog makes this possible. Access this dialog either from the menu bar (Format > Slide design) or by right-clicking on a slide in the Slides pane.
The main window in the dialog shows the slide masters already available for use. Toadd more:
1) Click the Load button.
2) Select in the new dialog the template containing the slide master. Click
OK.
3) Click OK again to close the slide design dialog.
The slide masters in the template you selected are now shown also in the Master Pages section of the Tasks pane in the Available for use subsection.
[image: ]

Figure 20: Loading slide masters from a presentation template
Modifying a slide master
The following items can be changed on a slide master:
· Background (color, gradient, hatching, or bitmap)
· Background objects (for example, add a logo or decorative graphics)
· Size, placement, and contents of header and footer elements to appear onevery slide
· Size and placement of default frames for slide titles and content
Before	working	on	the	slide	master,	make	sure	that	the	Styles	and Formatting window is open.
To select the slide master for modification:
1) Select View > Master > Slide Master from the menu bar. This unlocks the properties of the slide master so you can edit it.
2) Click Master Pages in the Tasks pane. This gives you access to the pre- packaged slide masters.
3) Click on the slide master you want to modify among the ones available (Figure 19).
4) Make changes as required, then click the Close Master View icon on the Master View toolbar. For details, see Chapter 2 of the Impress Guide
5) Save the file before continuing.




Cautio n

[image: ]

Any changes made to one slide when in Master View mode will appear on all slides using this slide master. Always make sure you close Master View and return to Normal view before working on any of the presentation slides. Select View > Normal from the menu bar, or click Close Master View in the Master View toolbar to return to the normal slide view.




The changes made to one of the slides in Normal view (for example changes to the bullet point style or the color of the title area and so on...) will not be overridden by subsequent changes to the slide master. There are cases, however, where it is desirable to revert a manually modified element of the slide to the style defined in the slide master: to do that, select that element and choose Format > Default Formatting from the menu bar.
Using a slide master to add text to all slides
Some of the supplied slide masters have text objects in the footer. You can add other text objects to the master page for your slides to act as a header or a footer.
1) Choose View > Master > Slide Master from the menu bar.
2) On the Drawing toolbar, select the Text icon.

3) Click once and drag in the master page to draw a text object, and then type or paste your text into the object or add fields as described below.
4) Choose View > Normal when you are finished.

The Impress slide master comes with three pre-configured areas for date, footer andpage number.
[image: ]

Select Insert > Page Number or Insert > Date and Time to open a dialog boxwhere you can configure these three areas.
[image: ]
Figure 21: Configuring the slide footer areas





Tip

To change the number format (1,2,3 or a,b,c or i,ii,iii, etc.) for the page number field, choose Format > Page and then select a format from thelist in the Layout Settings area.
To change the paragraph style modify the Background Objects Presentation style.


To add a other information, such as the Author of the presentation or the name of the file, choose Insert > Fields. and select the required field from the submenu. If you want to edit a field in your slide, select it and choose Edit > Fields.
The fields you can use in Impress are:
· Date (fixed)
· Date (variable)—updates automatically when you reload the file
· Time (fixed)
· Time (variable)—updates automatically when you reload the file
· Author—First and last names listed in the OpenOffice.org user data
· Page number (slide number)
· File name


Adding comments to a presentation

Starting with OOo 3.2, Impress supports comments (formerly called sticky notes) similar to those in Writer and Calc.
In Normal View, choose Insert > Comment from the menu bar. A small box containing your initials appears in the upper left-hand corner of the slide, with a larger text box beside it (see Figure 22). Impress has automatically added your nameand the date at the bottom of this text box.
Type or paste your comment into the text box. You can optionally apply some basic formatting to parts of the text by selecting it, right-clicking, and choosing from the pop-up menu. (From this menu, you can also delete the current comment, all the comments from the same author, or all the comments in the document.)
[image: ]

[bookmark: _bookmark71]Figure 22: A comment
You can move the small comment markers to anywhere you wish on the page. Typically you might place it on or near an object you refer to in the

comment.
To show or hide the comment markers, choose View > Comments.
Select Tools > Options > User Data to configure the name you want to appear inthe Author field of the comment, or to change it.
If more than one person edits the document, each author is automatically allocated adifferent background color.



Setting up the slide show

As mentioned in ―Modifying the slide show‖ on page 19, Impress allocates reasonable default settings for slide shows, while at the same time allowing for customizing many aspects of the slide show experience. This section covers only some aspects; advanced techniques are explained in Chapter 9 (Slide Shows) in the Impress Guide.
Most of the tasks are best done in Slide Sorter view where you can see most of the slides simultaneously. Choose View > Slide Sorter from the menu bar or click the Slide Sorter tab at the top of the workspace.

One slide set – multiple presentations
In many situations, you may find that you have more slides than the time available to present them or you may want to provide a rapid overview without dwelling on the details. Rather than having to create a new presentation, you can use two tools that Impress offers: hiding slides and custom slide shows.
To hide a slide, right-click on the slide thumbnail either in the Slide pane or in the work area if you are using the Slide Sorter view and choose Hide Slide from the pop- up menu. Hidden slides are marked by a slashed slide number.
If you want to reorder the presentation, choose Slide Show > Custom Slide Show. Click on the New button to create a new sequence of slides and save it.
You can have as many slide shows as you want from a single slide set.

Slide transitions
Slide transition is the animation that is played when a slide is changed. You can configure the slide transition from the Slide Transition drawer in the Tasks pane. Select the desired transition, the speed of the animation, and whether the transition should happen when you click the mouse (preferred) or automatically after a certain number of seconds. Click Apply to all slides unless you prefer to have different transitions in the presentation.




Tip

The	Slide	transition	section	has	a	very	useful	choice:
Automatic preview. Select its checkbox. Then when you make

a	nges in a slide transition, the new slide is previewed in the n	Slide Design area, including its transition effect.
y c h a


Automatic slides advance
You can set the presentation to automatically advance to the next slide after a set amount of time (for example kiosk mode or carousel) from the Slide Show > Slide Show Settings menu or to advance automatically after a pre-set amount of time different for each slide. To set up the latter, choose Slide Show > Rehearse Timings. When using this tool, start the slide show; a small timer is displayed in the bottom left corner. When you are ready to advance to the next slide, click on the timer. Impress will memorize the timings and at the next slide show will advance automatically after the timer expires.

Running the slide show	

To run the slide show, do one of the following:
· Click Slide Show > Slide Show.
· Click the Slide Show button on the Presentation toolbar.
[image: ]

· Press F5 or F9 on the keyboard.
If the slide transition is Automatic after x seconds, let the slide show run by itself.
If the slide transition is On mouse click, do one of the following to move from oneslide to the next:
· Use the arrow keys on the keyboard to go to the next slide or to go back to the previous one.
· Click the mouse to move to the next slide.
· Press the spacebar on the keyboard to advance to the next slide.
Right-click anywhere on the screen to open a menu from which you can navigate theslides and set other options.
To exit the slide show at any time including at the end, press the Esc key.



Questions and answers Open Office
Question 1: Choose the correct option:
(a) In a Writer document, text is aligned to the	margin by default.
i. Left
ii. Right
iii. Center
(b) Rahul will use the	keyboard shortcut to find and replace a word in his document.
i. Ctrl+J ii.Ctrl+R
iii. Ctrl + F
(c) The	option helps to improve vocabulary by providing a list of synonyms and antonyms.
i. Directory
ii. Thesaurus
iii. Dictionary
(d) The	tool copies the formatting of one section of a text and applies the same to another.
i. FormatPaintbrush
ii. FormatPainter
iii. None of these

	2. The suit of free software offered by Apache foundation for document preparation, spreadsheet, presentation, drawing and database management is called 	.
(a) OpenOffice.org
(b) Microsoft Office
(c) Star Office
(d) K Office Ans. a

3. In OpenOffice.org, text document can be prepared using 	.
(a) writer
(b) calc
(c) draw
(d) impress Ans. a



4. In OpenOffice.org, presentation can be prepared using 	application.

	(a) writer
	

	(b) calc
	
	

	(c) draw
	



(d) impress Ans. d

Question 5: Fill in the blanks.
(a) An application that can be used to organized numerical data in the form table and perform calculations	on	it	called	a Spreadsheet application.
(b) The Cell is	a	fundamental	element	of	a	worksheet.
(c) A	workbook	is	a	collection	of Worksheet.
(d) The scientific cell	format	displays	the	content	of	cell	in	exponential	notation.
(e) In open office calc, the Autofill feature is used to fill a series of numbers such as 2,4,6,8 and so on.
(f) The Name	Box displays	the	name	of	the	active	cell.
(g) Formula	Bar contains	the	Name	Box	and	the	Input	Line	textbox.
(h) By	default,	in	Calc,	the	numbers	are	aligned	to	the right within	a	cell.
(i) The	first	cell	in	the	upper	left	corner	is A1.
(j) Redo is	a	feature	that‘s	opposite	to	undo.
(k) By default, the name of the first workbook is Untitled1.
.
6 In Calc, Rename Sheet option available in which menu?


A) File
B) Format
C) Data
D) Sheet


7 In calc the Formula which shows 16% of the value in A1 is 	
A)	=A1*16%
B)	=A1%16
C)	=A1#16%
D)	A1%16


8 In Calc the default number of sheets is 	

A)	2
B)	3
C)	1
D)	5


9 In LibreOffice Calc what is the default Title name?


A) Book1
B) Title1
C) Untitled1
D) Sheet1


10. In Calc the default font size is 	


A) 10
B) 11
C) 12
D) 15


11. In Calc which shortcut key is use to open the cell format dialog box?


A) Shift + 1
B) Ctrl + 1
C) Alt + 1

D) Ctrl+Alt+1


12. In Calc, which shortcut key is use to insert the Time?


A) Ctrl + ;
B) Ctrl+Shift+;
C) Ctrl + T
D) None of these


13. Which shortcut key is use to open a new Spreadsheet?


A) Ctrl+Shift+N
B) Ctrl+N
C) Shift+N
D) Shift+Alt+N


14. In Calc which shortcut key is use to save as a program?
A) Ctrl+Shift+S
B) Ctrl+S
C) Shift+Alt+S
D) None of these


15. In LibreOffice Calc, Merge Cells command available in which menu?
A) Format

B) Style
C) Sheet
D) Edit


16. Which shortcut key is use to delete a cell in LibreOffice Calc?


A) Ctrl + +
B) Ctrl + -
C) Ctrl + D
D) Delete


17. In Calc, Freeze Rows and Columns option available in which menu?


A) File
B) View
C) Format
D) Data


18. In Calc, the last Column label is 	


A) AMJ
B) AMA
C) ALZ
D) ALX

19. The total number of Columns in Calc is 	


A) 10241
B) 1024
C) 48523
D) None of these


20. In Calc, the name of the Cell made by the intersection of last column and last row is 	
A) AMJ65536
B) AMX1048576
C) AMJ1024
D) AMJ1048576


21. In Calc which shortcut key you press to change the number format as date ?
A) Ctrl+1
B) Ctrl+Shift+3
C) Ctrl+Shift+5
D) All of these


22. In Calc which shortcut key is used to insert a function?


A) F2
B) F3

C) Ctrl+F2
D) Ctrl+F3


23. What is the default height of a Row in Calc?


A) 0.18
B) 0.23
C) 0.25
D) 0.21


24. What is the default width of a column in Calc?


A) 0.79
B) 0.84
C) 0.89
D) None of these


25. In Calc the maximum zoom size is 	


A) 200%
B) 400%
C) 500%
D) 600%


26. Which shortcut key is use to open the Format Cell?


A) Ctrl+2
B) Ctrl+3
C) Ctrl+4
D) Ctrl+1


27. Which is the last menu in Calc?
A) Format
B) Help
C) View
D) Sheet


28. Font Size, Font Face, Bold, Italic etc. options available in which Toolbar?


A) Standard
B) Formatting
C) Drawing
D) None of these


29. In Calc which shortcut key is use to select the whole worksheet?

A) Ctrl+A
B) Ctrl+Shift+Space
C) Ctrl+Space
D) Both A and B


30. You can change the user interface in Calc Program with ….?
A) Single Toolbar
B) Tabbed
C) Tabbed Compact
D) All of these




31. The shortcut key to open a new Template in Calc program is 	.
A) Ctrl+Shift+N
B) Ctrl+Alt+N
C) Ctrl+N
D) None of these


32. Protect Sheet option available in which menu?


A) View
B) Tools
C) File
D) Sheet

33. The shortcut key to hide the sidebar in Calc is 	
A) Ctrl+F3
B) Ctrl+F5
C) Ctrl+F7
D) Shift+F5


34. In Calc, the shortcut key to convert a number in a Cell into Date is?
A) Ctrl+Shift+F3
B) Ctrl+Alt+3
C) Ctrl+Shift+3
D) None of these


35. What you press to exit from Calc?


A) Ctrl+X
B) Ctrl+W
C) Ctrl+R
D) None of these


36. In Calc the maximum Cell in a worksheet is ?
A) 1,073,741,824
B) 1,073,741,842
C) 1,073,824,741

D) No Limit


37. In Calc, you press which key with Ctrl to insert a new line or paragraph in a Cell?


A) Shift
B) Alt
C) Tab
D) Enter


38. What is the default file extension for a spreadsheet in Calc?
A) .odp
B) .ods
C) .odd
D) .odt


39. In Calc a formula start with a symbol 	


A)	%
B)	$
C)	&
D)	=


40. What is the result of the formula =COUNT(B1:B3)? Where B1=5,B2=4,B3=6

A) 15
B) 3
C) 4
D) 5


41. What is the result of the formula =MAX(B1:B3)+MIN(B1:B3)? Where B1=5,B2=2,B3=7


A) 7,2
B) 7+2
C) 9
D) 5,7


42. In Calc if the value is large then the Cell, then what is the result?
A) ####
B) %%%%
C) &&&&
D) #Name?


43. In Calc the address of any Cell is shown in?


A) Formula Bar
B) Address Book
C) Name Box
D) None of these

44. What is the result of the Formula =Product(80,-5)?


A) 400
B) -400
C) Null
D) None of these


45. In Calc the Alignment of a Non numeric value is 	


A) Right
B) Left
C) Center
D) Justified





46. If the Cell address is changed when you copy a formula then the formula is known as 	


A) Relative Address
B) Absolute Address
C) Mixed Address
D) Dynamic Address

47. In Calc, the maximum number of Row and Column is 	


A) 1048576 & 1024
B) 1048576 & 16384
C) 16384 & 1048576
D) 1024 & 1048576


48. In Calc which shortcut key is use for print preview?


A) Ctrl+F12
B) F12
C) Ctrl+Shift+O
D) Ctrl+O


49. In Calc, the toolbar which has the commands like save, open, print, cut, copy etc. is called?
A) Formatting Toolbar
B) Standard Toolbar
C) Drawing Toolbar
D) None of these


50. Which shortcut key is use to select the complete Row?


A) Ctrl+Space
B) Shift+Space

C) Ctrl+Shift+End
D) None of these


51. In calc which shortcut key is use for comment?


A) Ctrl+Shift+C
B) Ctrl + C
C) Ctrl+Shift+T
D) Ctrl+Alt+C


52. In Calc, the shortcut key to convert a number into currency format is?


A) Ctrl+Shift+1
B) Ctrl+Shift+5
C) Ctrl+Shift+4
D) Ctrl+Shift+3


53. How many maximum sheets you can insert in Calc?


A) 1000
B) 1024
C) 10000
D) No Limit

54. In Calc you can write maximum 	characters in a Cell.


A) 32767
B) 32654
C) 356547
D) None of these


55. In Calc which shortcut key is use to clear direct format?


A) Ctrl + V
B) Ctrl + M
C) Ctrl + Shift + F
D) Ctrl + 1
56. Where is the name box in Calc?


A) Left side under the Menu bar
B) Left side over the Menu bar
C) On the Status bar
D) Right side under the Menu bar


57. Which shortcut key is use to move to the next sheet?
A) Tab
B) Ctrl + Tab
C) Ctrl + Shift + Tab

D) Shift + Tab


58. In Calc which shortcut key is use to highlight a value?
A) Ctrl + F6
B) Ctrl
C) Ctrl + F8
D) Ctrl + F1


59. In Calc the address of the last Cell is 	
A) $D$10
B) AMJ1048576
C) XFD1048576
D) $AMD$1048576


60. In Calc, to split a merged cell click 	button after selecting the cell
A) Center
B) Split
C) Split and Merge
D) Merge and Center


61. In Spreadsheet which shortcut key is use to select the row of the selected cell.


A) Ctrl+Space Bar
B) Shift+Space Bar

C) Shift+ +
D) Ctrl+ +


62. In Calc the process to combine two cells in one, is called 	


A) Join Cells
B) Merge Cells
C) Join Table
D) Merge Table


63. In Calc which shortcut key is use to move to the left of a cell?


A) Alt + Tab
B) Tab
C) Alt
D) Shift + Tab


64. In Calc, the intersection of a Row and Column is called 	


A) Cell
B) Table
C) Sheet
D) Book

65. In Calc which Symbol shows after a Formula Error?


A)	$
B)	@
C)	\
D)	#



	66.
	
A)
	What is the default font size in libreoffice?
6

	
	B)
	10

	
	C)
	12

	
	D)
	15

	
67.
	


A)
	What is the shortcut key for Unformatted Text in Libreoffice? Ctrl + Alt + V

	
	B)
C)
D)
	Ctrl + Shift + V
Ctrl + Alt + Shift + V None of these

	
68.
	


A)
	What is the shortcut key for Paste Special in LibreOffice? Ctrl + Shift + V

	
	B)
C)
	Ctrl + V
Alt + V


D) None of these


	69.
	
A)
	Which shortcut key is used to move to the last of the document?
Shift + End

	
	B)
C)
D)
	Alt + End Ctrl + End End

	
70.
	


A)
	Where does the page number appear in the status bar? Right Side

	
	B)
C)
D)
	Left Side In Middle
None of these

	
71.
	


A)
	What is the shortcut key for New Style in LibreOffice? Ctrl + Shift + F11

	
	B)
C)
D)
	Shift + F12 Ctrl + F12 Shift + F11

	
72.
	


A)
	Which of the following is used to change the font size? Standard Toolbar

	
	B)
	Menu Bar


C) Formatting Bar
D) None of the above

73. What is the file extension of Libreoffice Writer Template?
A) .odt
B) .ott
C) .otp
D) .opt


74. How many scrollbars will appear when we Zoom the document to 200%?
A) 1
B) 2
C) 3
D) 4


75. What is the Default page orientation in LibreOffice?
A) Portrait
B) Landscape
C) Legal
D) A4


76. Which of the following Information can be given in the Header?
A) Date
B) Time
C) Page number
D) All of the above

77. What is the use of Signature in Libreoffice?
A) Authentication
B) Integrity
C) Non-Repudiation
D) All of the above


78. The default name by which the File saved in Libreoffice?
A) Document
B) Untitled
C) Doc
D) None of these


79. Which shortcut key is used to break the Line in LibreOffice Writer?
A) Shift + Enter
B) Ctrl + Enter
C) Alt + Enter
D) None of these


80. In Libreoffice the shortcut key Ctrl + F3 is used for?
A) Sentence Case
B) Capitalize Each Word
C) Toggle Case
D) Cycle Case

81. What is used for the Line above the Text?
A) Top Line
B) Underline
C) Overline
D) Upper Line


82. Which shortcut key is used to Insert a Table?
A) Alt + Ctrl + F12
B) Ctrl + F11
C) Ctrl + F12
D) Ctrl + Shift + F12


83. By using which submenu Libreoffice accept the donation?
A) Transfer to Libreoffice
B) Donate to Libreoffice
C) Help to Libreoffice
D) Give to Libreoffice


84. Which of the following shortcut key is used to save a file with a different name?
A) Save
B) Ctrl + S
C) Ctrl + Shift + S
D) Save All

85. Which shortcut key is used to increase the font size in Office?
A) Ctrl + <
B) Ctrl + [
C) Ctrl + ]
D) Ctrl + >


86. What is the shortcut key to Exit from LibreOffice?
A) Ctrl + T
B) Ctrl + Q
C) Ctrl + W
D) None of these


87. Macros command is available in which menu of LibreOffice?
A) File
B) View
C) Edit
D) Tools


88. Which of the following appears blurred behind the Text in a Document?
A) Image
B) Front land
C) Water mark
D) Background

89. What is the shortcut key for jump to the last Edited Slide in LibreOffice Impress?
A) Ctrl + J
B) Ctrl + Shift + F5
C) Ctrl + E
D) Ctrl + Shift + T


90. The ‗Wizard Option‘ located at which of the following menu?
A) File
B) View
C) Edit
D) Insert





91. The Auto Text command is available in which menu?
A) File
B) Format
C) Editor
D) Tools


92. Which one of the following options is not available in the print dialog box?
A) Copy
B) Save
C) Page Number

D) Paper Size


93. Which menu is used to change the color of the Font?
A) Insert
B) Design
C) Edit
D) Format


94. What is the shortcut key to close the current window in LibreOffice?
A) Ctrl + T
B) Ctrl + W
C) Ctrl + Q
D) None of these


95. What is the File extension of Base Data in LibreOffice?
A) .ods
B) .odb
C) .odf
D) None


96. What is the correct option to insert the Header in LibreOffice?
A) Edit -> Header
B) Insert -> Header
C) Format -> Header

D) View -> Header


97. How many Languages does the LibreOffice Support?
A) 120
B) 115
C) 125
D) 100


98. What will be the shortcut key to use Heading 1?
A) Alt + 1
B) Ctrl + 1
C) Alt + 2
D) Ctrl + 2


99. Which shortcut key is used to Insert a Page break in LibreOffice?
A) Ctrl + C
B) Tab
C) Shift + A
D) Ctrl + Enter


100. Which of the following shortcut key is used to directly upload a document to Google Drive?
A) Ctrl + U
B) Shift + U
C) Ctrl + L

D) Shift + L





101. Which menu has add Pages option in LibreOffice writer?
A) Format
B) File
C) Insert
D) Edit


102. Which shortcut key is used to go to the beginning of the Line in LibreOffice Writer?
A) Ctrl + Home
B) Home
C) Shift + Home
D) Alt + Home


103. In Libreoffice the shortcut key Ctrl + G is used for?
A) Go to Text
B) Go to Page
C) Go to Line
D) Go to Heading


104. Where is the File name displayed in LibreOffice?
A) In the Taskbar
B) In the scrollbar

C) In the Title Bar
D) In the status bar


105. What is the shortcut key for Save as?
A) F8
B) F6
C) F12
D) F10


106. In which menu the Digital Signature Option available in Libreoffice?
A) File
B) View
C) Tools
D) Windows


107. In which menu the cut, copy and paste commands are?
A) File Menu
B) View Menu
C) Edit Menu
D) None of the above


108. In Libreoffice the shortcut key for Ruler is?
A) Ctrl + Shift + R
B) Ctrl + R

C) Window + L + R
D) Alt + Shift + C


109. Which shortcut key is used for Superscript?
A) Ctrl + P
B) Ctrl + Shift + P
C) Shift + P
D) Ctrl + Shift + B


110. In which menu the add comments option available in Libreoffice?
A) View
B) Insert
C) Format
D) Style


111. Put the following in order- Status bar, Title bar, Standard bar.
A) Title bar, Status bar, Standard bar
B) Status bar, Title bar, Standard bar
C) Title bar, Standard bar, Status bar
D) Standard bar, Status bar, Title bar


112. Which of the following is not an example of the page margin?
A) Left
B) Right

C) Center
D) Top


113. What is the minimum font size in Libreoffice?
A) 4
B) 6
C) 8
D) 10


114. What is the shortcut key for Past Unformatted Text in LibreOffice?
A) Ctrl + Shift + Alt + V
B) Ctrl + Shift + V
C) Ctrl + V
D) None of these


115. What is the shortcut key for double underline in LibreOffice?
A) Ctrl + D
B) Ctrl + L
C) Ctrl + Shift + D
D) None of these
116. What is the maximum number of views you can add to a Slide?
A) 2
B) 4
C) 6

D) 10


117. Which shortcut key in LibreOffice Impress is used for Paste Unformatted Text?
A) Ctrl + Alt + Shift + V
B) Ctrl + Shift + V
C) Ctrl + Alt + V
D) None of these


118. What is the slide transition in LibreOffice Impress?
A) Letter
B) A special effect used to show a slideshow
C) Over head
D) A type of slide


119. In LibreOffice Impress the shortcut key for print preview of a presentation is?
A) Ctrl + P
B) Ctrl + Shift + P
C) Ctrl + Shift + F12
D) None of these


120. LibreOffice Impress presentation can be exported in which format?
A) BMP
B) PDF
C) GIF

D) All
LibreOffice Impress MCQ Questions in Hindi and English



121. In LibreOffice Impress the default Title name of a presentation is?
A) Presentation 1
B) Untitled 1
C) Untitle
D) Document1


122. In LibreOffice Impress the minimum zoom size is?
A) 5%
B) 10%
C) 15%
D) 20%


123. The slide sorter option available in which menu of LibreOffice Impress?
A) Insert
B) View
C) Format
D) Slide show


124. Which transition effect is not available in LibreOffice Impress?
A) Fade

B) Dissolve
C) Fly in
D) Diagonal


125. Using which option do all the slides appear simultaneously?
A) Slide sorter
B) Print preview
C) Handouts
D) None of these
LibreOffice Impress MCQ Questions in English



126. In LibreOffice Impress which shortcut key is used for duplicate slide?
A) Ctrl + S
B) Ctrl + D
C) Ctrl + Shift + D
D) None of these


127. Which shortcut key is used to add a new slide in Libreoffice Impress?
A) Ctrl + N
B) Ctrl + M
C) Ctrl + S
D) Ctrl + T

128. The default template in LibreOffice Impress Presentation is?
A) Image
B) Content only
C) Title and content
D) Title only


129. In LibreOffice Impress which shortcut key is used to repeat the slide show continuously?
A) Loop
B) Repeat
C) Move
D) None


130. Which of the following is used to organize or shorten the slides?
A) Slide Pan
B) Slide sorter view
C) Both A and B
D) None of these
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131. Which shortcut key is used to move to the next slide?
A) Ctrl + Page up
B) Ctrl + home
C) Ctrl + Page Down

D) None of these


132. In LibreOffice Impress which view contains only Text?
A) Normal view
B) Outline view
C) Notes view
D) Slide shorter view


133. In LibreOffice Impress which option is used to remove the slide transition?
A) None Transition
B) Split Transition
C) Wipe Transition
D) Push Transition


134. In LibreOffice Impress the maximum number of hand outs in a slide is?
A) 3
B) 4
C) 6
D) 9


135. Which shortcut key is used to perform a slide show in LibreOffice Impress?
A) Alt + F5
B) Ctrl + F5
C) Shift + F5

D) F5

136. In LibreOffice Impress the default page orientation is?
A) Portrait
B) Vertical
C) Landscape
D) Horizontal


137. Which slide is used as a starting point for other slides?
A) First slide
B) Last slide
C) Master slide
D) None of these


138. In LibreOffice Impress which key is used to go to the previous slide?
A) Page down
B) Page up
C) Enter
D) Home


139. How can we go directly to the menu while the slide is running?
A) By clicking on the Ribbon
B) By Right click on the slide
C) By mouse click

D) All of the above


140. How to create a text box in a slide?
A) Slide -> Textbox
B) Insert -> Textbox
C) Insert -> Table -> Textbox
D) None of these



141. Which shortcut key is used to navigate in LibreOffice Impress?
A) Alt + F5
B) Ctrl + F5
C) Ctrl + Shift + F5
D) None of these


142. Which type of sound file from the following can be added to LibreOffice Impress?
A) .dat
B) .log
C) .wav
D) .drv


143. The macros command is available in which menu of LibreOffice Impress?
A) Tools menu
B) Insert menu

C) View menu
D) Slide menu


144. In LibreOffice Impress which shortcut key is used to go to the first slide of the presentation?
A) Ctrl + Home
B) Home
C) Shift + Home
D) Both A and B


145. Which of the following view is not available in LibreOffice Impress?
A) Slide sorter view
B) Slide show view
C) Sorter view
D) None of these



146. Which of the following option is used to set the time for each object in a slide?
A) View -> Animation
B) Slide show -> Custom Transition
C) Format -> Animation
D) Slide show -> Slide Transition


147. In LibreOffice Impress the shortcut key Ctrl + E is used for?
A) Right Align

B) Left Align
C) Center Align
D) None of these


148. Which menu has the option of master slide in LibreOffice Impress?
A) Format
B) Slide show
C) View
D) Slide


149. In LibreOffice Impress the slide transition option available in which menu?
A) View
B) Slide
C) Insert
D) Both A and B


150. In LibreOffice Impress which file format is not added in a presentation?
A) GIF
B) HTML
C) JPEG
D) WAV
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151. The first slide of a presentation is known as?
A) Main Slide
B) Home Slide
C) Title Slide
D) None of these


152. Which alignment is not available in LibreOffice Impress?
A) Right Alignment
B) Central Alignment
C) Left Alignment
D) Justification


153. What is used to determine the timing on a slide in a presentation?
A) Slide Timer
B) Rehearsal
C) Slide Tool
D) Slide Timing Tool


154. We can add a table in LibreOffice Impress?
A) True
B) False


155. The first slide of a presentation in LibreOffice Impress is called Master Slide?
A) True

B) False
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156. We cannot rename slides in LibreOffice Impress?
A) True
B) False


157. When we insert a new slide, it insets according to its previous slide layout?
A) True
B) False


158. We can create a photo Album in LibreOffice Impress?
A) True
B) False


159. In LibreOffice Impress there is no option of mail merge?
A) True
B) False


160. If you add a graphic in a Master Slide it will appear on every slide of your presentation?
A) True
B) False
161. We can insert 	in presentation.
a. Image

b. Video
c. Audio
d. All of the above

Ans. d. All of the above
162. 	is used in teaching the concepts that are difficult to explain.
a. Writer
b. Calc
c. Impress
d. None of the above

Ans. c. Impress
163. 	is a free, open source and widely used by large community to create presentation.
a. Microsoft PowerPoint
b. Impress
c. Both of the above
d. None of the above Ans. b. Impress
164. Which of the following is not the component of LibreOffice?

a. Impress
b. Calc
c. Writer
d. Internet Explorer
Ans. d. Internet Explorer
165. The presentation created in LibreOffice Impress can be opened in MS PowerPoint.(T/F)

a. True
b. False Ans. a. True
166. LibreOffice Impress runs on 	operating system.
a. Windows
b. Linux
c. Mac
d. All of the above
Ans. d. All of the above
167. 	is/are an online presentation software.
a. MS-Office 365 PowerPoint
b. Google Presentation
c. Microsoft SkyDrive PowerPoint
d. All of the above
Ans. d. All of the above
168. A good presentation is one which 	
a. can convey the message clearly to the audience
b. has 5 – 8 lines in one slide.
c. has good color combination.
d. All of the above

Ans. d. All of the above
169. Font size used in presentation depends on 	
a. Size of the room where we have to play the presentation
b. Distance between the audience and the screen.
c. Both of the above
d. None of the above Ans. c. Both of the above
170. Characteristics of a good quality presentation is/are 	
a. The grammar and language should be correct in your presentation
b. Avoid inserting more than two graphics (images, drawings, tables or charts) in any slide.
c. Pay attention to target group
d. All of the above
Ans. d. All of the above

171. To start LibreOffice Impress in Windows

a. Double click its shortcut icon on the desktop
b. Click on Windows button, select LibreOffice → LibreOffice Impress.
c. Both of the above
d. None of the above Ans. c. Both of the above
172. Components of Impress Windows is/are 	
a. Title bar
b. Workspace
c. Slide Pane
d. All of the above
Ans. d. All of the above
173. Which of the following shows the name of the presentation file?

a. Status bar
b. Menu bar
c. Title bar
d. None of the above Ans. c. Title bar
174. Which of the following bar shows Minimize, Maximize/ Restore and Close buttons.

a. Blue bar
b. Title bar
c. Standard Toolbar
d. None of the above Ans. b. Title bar
175. Extension of file in Impress is 	
a. .odf
b. .odn
c. .odp
d. .opd

Ans. c. .odp
176. Which menu contains functions for copying, cutting and pasting text segments.

a. File
b. View
c. Insert
d. Edit Ans. d. Edit
177. 	menu is used to insert various objects like tables, shapes, textbox, and charts into a presentation.
a. File
b. Edit
c. Insert
d. View
Ans. c. Insert
178. 	menu is used to insert new slide, duplicate slide or delete slide.
a. Slide
b. Slide Show
c. Insert
d. View Ans. a. Slide
179. Which of the following menu is used to control spelling of text in a presentation?

a. Slide
b. View
c. Insert
d. Tools
Ans. d. Tools
180. 	menu is used for saving a file, opening an existing file, creating a new file etc.
a. File
b. Edit
c. View
d. Tools Ans. a. File
181. 	bar displays information about the active presentation, the current position of the cursor and also contain zoom slider.
a. Status
b. Zoom
c. Menu
d. None of the above Ans. a. Status
182. 	toolbar, helps to make various artistic works in the presentation.
a. Insert
b. View
c. Slide
d. Drawing

Ans. d. Drawing
183. Shortcut to close the Impress application is 	
a. Alt+F4
b. Ctrl+Q
c. Both of the above
d. None of the above Ans. c. Both of the above
184. In LibreOffice Impress, 	shortcut is used to open new presentation.

a. Ctrl + O
b. Ctrl + N
c. Ctrl + P
d. Ctrl + S
Ans. b. Ctrl + N
185. Which menu has the option to open a new presentation?

a. File
b. Edit
c. Slide
d. Slideshow Ans. a. File
186. We can select a slide layout by clicking on 	
a. Slide → Slide Layout
b. Slideshow → Slide Layout
c. Insert→ Slide Layout
d. Edit → Slide Layout
Ans. a. Slide → Slide Layout
187. Shortcut to save presentation is 	
a. Ctrl + P
b. Ctrl + S
c. Alt + S
d. Ctrl + R Ans. b. Ctrl + S
188. Which toolbar has icon to save the presentation?

a. Formatting
b. Standard
c. Status
d. None of the above Ans. b. Standard
189. To save the presentation with a different name select 	
a. File→ Save As
b. File→ Save
c. Both of the above
d. None of the above

Ans. a. File→ Save As
190. Shortcut for Save As is 	
a. Shift+Ctrl+S
b. Alt+Ctrl+S
c. Shift+Alt+S
d. None of the above Ans. a. Shift+Ctrl+S
191. Which of the following method is used to run slide show in LibreOffice Impress is/are 	
a. Click Slide Show→Start from First Slide
b. Click the Slide Show icon on the Presentation toolbar
c. Press F5
d. All of the above
Ans. d. All of the above
192. During slide show, we can move to the next slide by 	
a. Clicking the mouse button
b. Pressing right arrow keys on the keyboard.
c. Press the Spacebar key on the keyboard
d. All of the above
Ans. d. All of the above
193. Just after the last slide of presentation, you will get a message 	
a. Click anywhere to exit presentation.
b. Click to exit presentation.
c. Press any key to exit presentation.
d. None of the above
Ans. b. Click to exit presentation.
194. To exit the slide show at any time, just press the 	key

a. Escape
b. Enter
c. Space
d. None of the above Ans. a. Escape
195. To publish the presentation on the web save it in 	format.
a. PDF
b. PNG
c. HTML
d. None of the above Ans. c. HTML
196. To save the presentation in html format 	
a. Click on File → Export
b. Click on File → Save As
c. Click on View → Export
d. None of the above
Ans. a. Click on File → Export
197. PDF stands for 	
a. Portable Document Frame

b. Print Document Format
c. Portable Document Format
d. Portable Document Form
Ans. c. Portable Document Format
198. Keyboard shortcut to close the presentation is 	
a. Ctrl + C
b. Ctrl + E
c. Ctrl + Q
d. Ctrl + W Ans. d. Ctrl + W
199. Keyboard shortcut to open File menu is 	
a. Ctrl + F
b. Alt + F
c. Ctrl + M
d. Ctrl + E Ans. b. Alt + F
200. Keyboard shortcut to open an existing presentation is
a. Alt + O
b. Ctrl + O
c. Alt + N
d. Ctrl + N
Ans. b. Ctrl + O
201. Keyboard Shortcut to open Help in LibreOffice Impress is
a. F1 Key
b. F2 Key
c. Ctrl + H
d. None of the above
Ans. a. F1 Key
202. New slide can be inserted in Impress by 	

a. Slide → New Slide
b. Ctrl + M
c. Both of the above
d. None of the above Ans. c. Both of the above
203. To move the slide to another location use 	process.
a. copy and paste
b. cut and paste
c. Both of the above
d. None of the above Ans. b. cut and paste
204. To copy the slide to another location use 	process.
a. copy and paste
b. cut and paste
c. Both of the above

d. None of the above Ans. a. copy and paste
205. Which of the following shortcut is incorrect?

a. For Cut –-> Ctrl + X
b. For Copy –-> Ctrl + C
c. For Paste –-> Ctrl + V
d. None of the above
Ans. d. None of the above
206. Slides can be deleted by 	
a. Right click the mouse button on the selected slide & select the Delete Slide option from the context menu.
b. Select the slide and press the Delete button from the keyboard
c. Both of the above
d. None of the above Ans. c. Both of the above
207. By default the name of the first slide is 	
a. Slide 1
b. Slide I
c. S 1
d. None of the above Ans. a. Slide 1
208. Which of the following keys help to delete the text from the slide?

a. Delete
b. Backspace
c. Both of the above
d. None of the above Ans. c. Both of the above
209. 	button deletes the character on the left of the cursor.
a. Backspace
b. Delete
c. Home
d. End
Ans. a. Backspace
210. Pressing delete key or backspace keys deletes one 	at a time
a. Word
b. Line
c. Paragraph
d. Character Ans. d. Character
211. Slide Layout option is available in 	menu.
a. Slide show
b. Slide
c. View
d. Insert Ans. b. Slide

212. Duplicate slide can be inserted by 	
a. Selecting Slide → Duplicate Slide
b. Right-click on the slide and select Duplicate Slide from the context menu
c. Both of the above
d. None of the above Ans. c. Both of the above
213. Sometimes we may delete some text or image by mistake. To revert this mistake, there is an option called 	
a. Undo
b. Redo
c. Reverse
d. None of the above Ans. a. Undo
214. Undo and Redo options are available in 	toolbar.
a. Formatting
b. Standard
c. Drawing
d. None of the above Ans. b. Standard
215. Keyboard Shortcut for Undo is 	
a. Ctrl + Y
b. Ctrl + R
c. Ctrl + Z
d. Ctrl + U Ans. c. Ctrl + Z

216. Keyboard Shortcut for Redo is 	

a. Ctrl + Z
b. Ctrl + R
c. Ctrl + Y
d. Ctrl + M Ans. c. Ctrl + Y
217. If you want to rollback your undo command, you can use 	.
a. Edit —> Redo
b. Ctrl + Y
c. Both of the above
d. None of the above Ans. c. Both of the above
218. Zoom slider on the Status bar has 	marked sections.
a. 1
b. 2
c. 3
d. 4
Ans. b. 2
219. Which of the following view is not available in LibreOffice Impress?

a. Normal
b. Outline
c. Notes
d. Slide Notes

Ans. d. Slide Notes
220. 	view is used to format and design and to add text, graphics, and animation effects.
a. Outline
b. Notes
c. Normal
d. Slide Sorter Ans. c. Normal
221. 	view shows only slide text inside the Workspace in the form of a structure.
a. Normal
b. Outline
c. Notes
d. Slide Sorter Ans. b. Outline
222. Which of the following view is used to add notes to a slide?

a. Slide Sorter view
b. Normal View
c. Outline View
d. Notes View Ans. d. Notes View
223. 	view is suitable for rearranging the slide order by drag and drop.
a. Slide Sorter
b. Normal
c. Notes
d. Outline
Ans. a. Slide Sorter
224. Which of the following text alignment is not available in LibreOffice Impress?

a. Left
b. Right
c. Central
d. Justified Ans. c. Central
225. To make the text bold 	
a. Press Ctrl + B
b. Select Format —>Text —> Bold
c. Both of the above
d. None of the above Ans. c. Both of the above
226. Keyboard Shortcut of Increase Font Size is 	
a. Ctrl + >
b. Ctrl + ]

c. Ctrl + [
d. Ctrl + < Ans. b. Ctrl + ]
227. Decrease Font Size icon shows 	arrow.
a. Upward
b. Downward
c. Left
d. Right
Ans. b. Downward
228. Which of the following option help us to write the formula of water.

a. Superscript
b. Subscript
c. Font Style
d. None of the above Ans. b. Subscript
229. Keyboard Shortcut of Superscript is 	
a. Ctrl + Shift + P
b. Ctrl + Shift + S
c. Shift + P
d. Ctrl + P
Ans. a. Ctrl + Shift + P
230. Which of the following option raises the selected text above baseline?

a. Superscript
b. Subscript
c. Both of the above
d. None of the above Ans. a. Superscript
231. A bulleted list is called 	
a. Ordered List
b. Unordered List
c. Nested List
d. None of the above Ans. b. Unordered List
232. When we have to write the steps of doing a task , we preferred 	
a. Bulleted or Unordered List
b. Numbered or Ordered List
c. Both of the above
d. None of the above
Ans. b. Numbered or Ordered List
233. Insertion point or cursor can be moved to next column in table by 	
a. Pressing Tab key from Keyboard
b. Pressing Right arrow key
c. Both of the above
d. None of the above

Ans. c. Both of the above
234. In LibreOffice Impress, to select a cell within a table, position the mouse cursor along its left edge, and when the cursor changes to a sloped white arrow, press 	mouse button.
a. Left
b. Left and Right together
c. Both of the above
d. None of the above Ans. a. Left
235. We can not adjust the row height or column width in LibreOffice Impress.(T/F)

a. True
b. False Ans. b. False
236. Which of the following is not the vertical alignment of text?

a. Top align
b. Bottom align
c. Left align
d. None of the above

Ans. c. Left align
237. 	dialog box helps to apply border and background in a table.
a. Table Properties
b. Properties of Table
c. Table Formatting
d. None of the above Ans. a. Table Properties
238. Which of the following tab is not available in Table Properties dialog box?

a. Font
b. Font Effects
c. Font Color
d. None of the above Ans. c. Font Color
239. Keyboard Shortcut to insert text box in Impress is 	
a. F1
b. F2
c. F3
d. F4
Ans. b. F2
240. We can insert a new column 	side of selected cell.
a. only left
b. only right
c. Either left or right
d. None of the above Ans. c. Either left or right

241. In LibreOffice Impress Images can be inserted from 	
a. Gallery
b. local hard disk of Computer
c. Both of the above
d. None of the above Ans. c. Both of the above
242. Insert image dialog box can be opened by clicking 	
a. Insert → Image
b. View → Image
c. Format → Image
d. None of the above Ans. a. Insert → Image
243. To insert an image from the gallery:

a. Select Insert → Image → Gallery
b. Select Insert → Picture → Gallery
c. Select Insert → Media → Gallery
d. None of the above
Ans. c. Select Insert → Media → Gallery
244. The Image toolbar can be displayed by selecting 	
a. View → Toolbars → Image
b. Insert→ Toolbars → Image
c. Format → Toolbars → Image
d. None of the above
Ans. a. View → Toolbars → Image
245. To activate drawing toolbar, select 	
a. View → Media →Drawing
b. Tools → Media →Drawing
c. View → Toolbars →Drawing
d. None of the above
Ans. c. View → Toolbars →Drawing
246. When we create a group of two objects then it is treated as a 	object
a. different
b. single
c. multiple
d. None of the above Ans. b. single
247. Keyboard shortcut to select all objects of a slide in LibreOffice Impress is 	
a. Ctrl + O
b. Ctrl + A
c. Ctrl + T
d. Ctrl + R Ans. b. Ctrl + A
248. To select all the objects, go to 	
a. Edit → Select All
b. Edit → Select All Objects

c. Insert → Select All
d. Insert → Select All Objects Ans. a. Edit → Select All
249. To group all objects together after selecting the objects go to 	
a. Edit→Group
b. View→Group
c. Insert→Group
d. Format→Group Ans. d. Format→Group
250. Keyboard shortcut for making group of objects is 	
a. Ctrl + Shift + G
b. Ctrl + G
c. Ctrl + Alt + G
d. None of the above Ans. a. Ctrl + Shift + G
251. To ungroup objects in LibreOffice Impress go to 	
a. Format → Group → Ungroup
b. Format → Ungroup
c. Insert → Group → Ungroup
d. None of the above
Ans. a. Format → Group → Ungroup
252. Keyboard Shortcut to ungroup objects is 	
a. Ctrl + Alt + Shift + U
b. Ctrl + Shift + U
c. Ctrl + Alt + Shift + G
d. Ctrl + Alt + U
Ans. c. Ctrl + Alt + Shift + G
253. We can ungroup objects in LibreOffice Impress by 	
a. Format → Ungroup
b. Ctrl + Alt + Shift + U
c. right-click on the group and select Ungroup from the context menu.
d. All of the above
Ans. c. right-click on the group and select Ungroup from the context menu.
254. From the side bar in LibreOffice Impress, we can open 	
a. Slide Transition
b. Animation
c. Master Slide
d. All of the above
Ans. d. All of the above
255. To apply transition to all slides, click 	
a. Apply to All Slides.
b. Apply Transition to All Slides.
c. Apply to ALL
d. None of the above
Ans. b. Apply Transition to All Slides.
256. Shortcut to open Format menu is 	
a. Ctrl + F

b. Ctrl + O
c. Alt + F
d. Alt + O Ans. c. Alt + F
257. Shortcut to begin Slideshow from Current slide is 	
a. F5
b. Shift + F5
c. Ctrl + F5
d. Alt + F5
Ans. b. Shift + F5
258. Slide masters are available in the Master Pages section of the 	.
a. Sidebar
b. Title bar
c. Status bar
d. None of the above Ans. a. Sidebar

259. To play the sound repeatedly during presentation, the 	is used.

a. loop until next
b. until next sound
c. loop until next sound
d. None of the above
Ans. c. loop until next sound
260. There can be 	slide master in a presentation.
a. Only 1
b. 2
c. 3
d. 4
Ans. a. Only 1
261 What do you mean by alignment of text? How many types of alignments are available in Writer? Answer: The alignment of text means how text is placed on the screen with respect to the margins. There are	four	types	of	alignment. They are left, right, center and justify alignment.
262: Neha is working on a document in OpenOffice 4 Writer. He needs to perform the following tasks in Writer. Help her by suggesting the correct options.
i. Increase the space between lines in various paragraphs. Answer: Line Spacing option under the ‗Indent & Spacing tab‘.
ii. Align the paragraph properly. Answer: Text Alignment
263: Amit has deleted a paragraph from a document. Which option in Writer will help him get back the deleted text.
Answer: Undo or Ctrl + Z
264: What do you mean by indentation in a document? List the two types of indentation.
Answer: Indentation refers to the distance of text or paragraph from either the right or the left margin. The	two	types	of	indentation	are: Decrease Indent – This option moves the text towards the left margin of the document by a certain

amount.
Increase Indent – This option moves the text towards the right margin of the document by a certain amount.
265: Anika has typed an essay in Writer. How will she identify the grammatical and spelling errors in his document? How will she correct the same?
Answer: OpenOffice Writer has a build-in dictionary and a set of grammatical rules to check the spelling and grammar of the text document. So, Anika can use that to check grammatical and spelling errors in his document. If a word is incorrectly spelt, you can see a single red wavy line under it. A   simple   way   to   check   the   spellings   of   any   word   is   as   follows: Step 1: Right-click on the word with a red wavy line. A shortcut menu will open with various suggestions. Step 2: Click the word with the correct spelling in the suggestion list. The incorrect word will be replaced with the correct spelling in the document.
266: Differentiate between a bulleted list and a numbered list. Answer:
· A bulleted list is used for typing unordered lists where items in the list are not in a sequence.
· A numbered list is used for ordered lists where the sequence of the items is important.
267: Ali typed an essay on the topic ‗Our Environment‘. While reading the document, he found that he had typed the word ‗wonderful‘ instead of ‗beautiful‘ in the entire essay. How will he replace the word
‗wonderful‘ with ‗beautiful‘ throughout the document?
Answer: Ali will use the ‗Find and Replace‘ feature to replace the word ‗wonderful‘ with ‗beautiful‘ throughout	the	document. Steps:
Step  1: Click  the  ‗Find  &  Replace‘  option.  A  Find  &  Replace  window  appears. Step    2: In    the    Search    for    box,    type    the    word    ‗wonderful‘. Step   3: In   the   Replace   with   box,   type   the   word   ‗beautiful‘. Step 4: Click the ‗Replace All‘ button to replace the word ‗wonderful‘ with ‗beautiful‘ throughout the document.
268. List the types of data that can be entered in the calc.
Ans: Data that can be entered in a calc can be of following types:

· Text
· Numbers
· Formula
269. Mention the keyboard keys to perform the following in OpenOffice Calc.
(a) Go to the next column Ans: Tab

(b) Go to next row Ans: Enter

(c) Enter a new line in the same column. Ans: Ctrl + Enter

270: What is a spreadsheet? List its uses.

Answer: A spreadsheet application is in the form of a grid or a table that organizes data into rows and columns. It is used to analyze and make projections using the numeric data. A spreadsheet application is generally used for the following –
· Enter data
· Edit data
· Format data
· Perform calculation on the data
· Present data in graphical form
271: Which feature of Open-Office Calc should be used for the following?
(a) To display the content in multiple lines in the same cell when it exceeds the width of the cell.
Ans: Warp Text

(b) To display a series of values such as Monday, Tuesday and so on. In a selected range of cells. Ans: Autofill

272: Explain workbook and worksheet. Ans:
Workbook:
In calc workbook is a file that contains many worksheets, that you can use to organize various kinds of related information. By default, workbook contains three worksheets namely ‗sheet 1‘, ‗sheet 2‘, and
‗sheet	3‘.

Worksheet:

In calc worksheet is a single spreadsheet that contains cell, rows and columns. A worksheet begins with row number ‗1‘ and column A. Each cell can contain a number, text or formula.
273: Which cell format Calc should be used to display the numbers as shown below?
(a) 4.5E + 01
Ans: Scientific

(b) $50
Ans: Currency
274: Observe the following Calc worksheet and answer the questions:
	
	A
	B
	C
	D

	22
	Student Name
	Stu-ID
	Exam 1
	Exam 2

	23
	Neha
	00-1
	95
	86

	24
	Aman
	00-2
	97
	90

	25
	Shikha
	00-3
	94
	77

	26
	Neetu
	00-4
	87
	80



	27
	Gaurav
	00-5
	90
	82

	28
	Ankush
	00-6
	77
	85


(a) Cell address of Aman.
Answer: A24
(b) Which cell format should be used for Stu-Id?
Answer: Text
(c) Which function should be used to find the total marks of Neha in Exam 1 and Exam 2?
Answer: Sum() function
(d) Specify the cell range of the selected area. Answer: A26:C26
275. What's the maximum number of rows and cells for a spreadsheet file? The limitations of Apache OpenOffice Calc are
· maximum number of rows: 1,048,576
· maximum number of columns: 1,024
· maximum number of sheets: 256
276. How do I protect cells in my spreadsheet?

Cell protection is active for all cells by default. If only certain cells are to be protected, this setting must be turned off.
To exclude cells from the protection:

1. Select    the    cells    to    be    excluded    from    protection Hold down the  Ctrl  key while clicking on non-adjacent cells to highlight the ones that are to	be	protected. If you only want to protect a small number of cells, it may be easier to clear the protection for all cells and the re-activate protection for the appropriate cells. For this, select the entire
spreadsheet: press  CTRL  +  A  or click on the little gray box above row 1 and to the left
of column A.
2. Select Format → Cells from the main menu
3. Click on the Cell Protection tab
4. Clear the check mark for the Protected option
5. ClickOK


Initially, however, the protection is not activated. To activate the protection:

· Select Tools → Protect Document → Sheet to protect the current sheet only
· Select Tools → Protect Document → Document to protect all sheets in the current document 277.How can I rename a sheet?

· Right-click the sheet tab you wish to rename and select Rename Sheet from the popup menu, or
· Select Format → Sheet → Rename from the main menu, or
· Double-click the sheet to rename it (OOo 3.1 and higher)


278. How can I change the order of sheets in my spreadsheet?

You can move a sheet to a different position, click and hold the sheet tab at the bottom of the screen with the mouse and drag it to its new position.
You can also move sheets (even across different documents) using the menu:

1. Right-click the sheet you want to move and select Move/Copy Sheet... from the pop-up menu,	or
select Edit → Sheet → Move/Copy from the main menu.
2. Specify	the	new	position	of	the	sheet	in	the	dialog. You can even move the sheet to a different document that is opened in Calc.
3. Click	.OK

279. How can I see the row and column captions as I scroll through a sheet that is larger than my display?

There are two ways to obtain this result:
Mode 1 (with a single row or column caption): Freeze the caption.

1. Click on the cell just below and to the right of the row and column that will contain your caption.
2. Select Window → Freeze from the main menu.
If you have either row captions or column labels, you can create a cross freezing by clicking on the uppermost left side cell that does not contain a caption. For example, in a sheet with single row and column captions, choose the B2 cell. The position of all cells above and to the left of the cell where the Freeze was activated will be frozen.
Mode 2 (with multiple row or column captions): Split the sheet.

1. Click on the cell just below and to the right of the row and column that you want to contain your caption.
2. Select Window → Split from the main menu.
The sheet window will be split. The result is different from Mode 1 because you can scroll all sections of the split window, showing the caption according to your needs.
There is another (almost hidden) way to split a sheet window:
At the top of the right scroll bar and at the right of the bottom one, you can see little black lines. When the mouse is over one of these zones, the mouse pointer changes into a dragging icon.

1. When this icon shows, click and hold down the left mouse button to display a borderline in the grid of cells.
2. With the mouse, drag the line on the grid to the row or column that will contain your caption.
3. Release the mousebutton. The sheet will be split at this border.

280. How can I use cells from different Calc files?


1. Open the source file
2. Select the cells and press  CTRL  +  C  to copy them to the clipboard
3. Open the target file
4. Select a target cell and select Edit → Paste Special from the main menu
5. Check the Link box in the Options section
The inserted data are now linked to the original document. Whenever the data changes in the source document this will be reflected in the target document

Chapter 5
What is Digital Marketing?
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Digital Marketing refers to the marketing of products and services of a company or business through digital channels such as search engines, websites, email, social media, mobile apps, etc. It involves the use of electronic devices and the internet
Digital marketing mainly comprises Search Engine Optimization (SEO), Social Media Optimization (SMO), and Search Engine Marketing (SEM). We can say that it can be divided into three parts SEO, SMO, and SEM. However, Email Marketing and Affiliate Marketing have also become important components of digital marketing over the past few years. So, in digital marketing, we mainly deal with the following components:

· SEO

· SMO

· SEM

· Email Marketing

· Affiliate Marketing
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Characteristics of digital marketing


1. Two Way
Unlike traditional marketing, digital marketing uses a unidirectional message encouraging the customers to interact with the brand instantaneously. It is a great way to involve the audience in your promotion and advertising process rather than them being a mere recipient. Social users interested in the product form a network of interactions, spreading the word wider and developing a platform of queries and clarification in the form of comments. The new digital marketing era has made it simpler for a brand to advertise multiple products in a single ad through ‗People also bought‘ and for customers to save them in their ‗wishlist‘ and revisit later.

2. Measurable: One important characteristic of a digital marketing campaign is measurability. The word digital in itself has ‘digit.’ So whether you are putting up a social media ad or inviting clients to an offline event to play around with the installation, you should be able to collect the reach of these ads and responses numerically. The collection of this data is more straightforward in digital marketing and acts as an asset for future marketing purposes. It helps to know which audience you can narrow how, how effective your copy was and which strategy worked well or failed in the past.




3. Targeted

Every digital or online marketing strategy is targeted, meaning it focuses on a specific audience group. The data collected helps the marketers to target specific key demographics. For instance, a vegan cosmetics brand would target a female audience between the ages of 16 to 45, previously known to search for vegan brands and a particular region if the company only delivers in certain areas. It also helps gain numerical of the number of times the ad is viewed and determine the strategy that works well. The aim should be to deliver a meaningful message and enhance user and brand engagement.



4. Personalization
When your digital marketing copy is measurable, you can also track your customer‘s shopping habits, frequently viewed products, and preferences. It helps you personalize product suggestions for each customer and recommend related goods or services. You can also send a user personalized, one- time-use discount vouchers based on their ‗Watch list‘ or ‗wishlist‘, which they cannot share with another. The internet enables you to match the customers‘ requirements, making digital marketing budget-friendly and user-friendly.



5. Remarketing
Another significant characteristic and digital marketing tactic is Remarketing. It stems from previous marketing advertisements wherein the company shows ads specifically to those who have visited their page earlier or showed interest. It is mainly used for services or products for which the customer frequently visits the website. Remarketing could be of three types: Audience based, behavioural and contextual. For instance, you might have noticed that you see advertisements from merchants whose products you‘ve seen but not bought. It is a great feature to increase brand awareness and traffic drive directing them to the target landing page of your website. Now that you know what to show whom, you could add richer product information and details in the form of frequently answered questions and descriptions.



6. Multi-channel:
A digital marketing strategy needs to be used on multi-channels. Not all of the audience uses all of the platforms, or maybe they act selectively active on some. The goal is to reach the prospective buyer through various modes of online communication. The communication method should be easier and simpler to navigate through. For instance, would your audience want to complete product checkout through a reminder on Instagram or a personalized checkout link sent through email? It engages the prospect with the brand on an ongoing basis and cuts down printing and posting costs. The goal is to make the content accessible and easy to respond to.

Tip: Rather than spending time on all channels, learn the ones that benefit you the most and utilize your time on the chosen one or two platforms to build an engaging empire.


7. Adaptability
Digital marketing demands flexibility and adaptability to the changing technological, customer, and media requirements. The campaign is supposed to adapt to the evolving situations of the target audience. Being a digital marketer could be pretty challenging, although it calls for creative minds to track and match the buyer signals and create an adaptable call-to-action message. Companies need to be flexible as new trends come and go quickly in the fast-changing environment.

Tip: Considering the changing industry needs does not mean you need to forget the true brand ethnicity, which must be maintained while matching the market trend.

8. Integration:
It realizes the perfect integration between the front desk and to the back office. This integration is the basis for quickly responding to the personalized needs of consumers. It can be achieved from the product information to collections and after-sales service in one go, so it is also a full-range marketing channel. On the other side, enterprises can use the Internet to carrying out unified design planning and coordinated implementations of different communication and marketing activities, to avoid the negative effects caused by the inconsistency of different communication.
9. Richer product information:
The Internet can tell us detailed specifications, technical indicators, warranty information, usage methods, etc. of current products, and even answers to the common questions. Users can easily find out products, prices, brands, etc. via the Internet.
10. Larger selection space:
Digital marketing won‘t be limited by shelves and inventory and provides an enormous products display and sales ballroom so that consumers provide almost unlimited choice space.
11. Lower cost advantage:
Publishing real information on the Internet has a limited cost, selling products directly to consumers, which can shorten the distribution link, and anyone can get the published information independently and can expand the scope of the sale, which can also save the promotional costs, Thereby reducing costs and making products competitive in price will prove beneficial. Most customers who come to visit are highly interested in such products. The audience is accurate, which avoids many useless information transfers and can also save costs.
Digital marketing also has similarities and characteristics of multimedia, time and space, interactive, anthropomorphic, advanced, efficient, and economical. Due to the use of specific attributes of digital

products, digital marketing has added many new characteristics and features based on transforming traditional marketing techniques.
Important tools of digital marketing:
1. Social Media
This one is the most powerful one as we all know that Social media is the collection of communication, interactions, and collaboration. Apps and Websites will dedicate the social networking blogging, and many more are there. This technique supports the understanding of your brand and content on your social media channels; it will drive traffic and generates directions for your company.
Some important digital marketing tools of Social media:
· Facebook: As we all know, Facebook is one of the popular and top levels of the social network. Facebook allows users to create their own profile on the site from that you can connect with your friends and family, and the important point is that you can share and upload the photo and video with your friend, family, and colleagues with just one click.
· Twitter: This is another popular and powerful network. Twitter is a microblogging service that is free for registered members. We can also say that Twitter Tweets are the most powerful in the world. In Twitter, we can follow any registered twitter member to see their tweets using multiple platforms.
· Google Plus: Google plus is also one of the famous networks which Google manages. To Join with Google plus, first of all, we need an account on Google. When you first sign up, some groups, including Friends and colleagues, have been set up by Google. You can add your own as well. In this, you can share images and links with your friends and relatives.
· LinkedIn: This one is famous for business purposes. This LinkedIn network is specifically designed for business uses. The purpose of the site is to allow registered members to set up and document network-aware from trusted networks of people.
· Instagram: According to the search, about 850 mill users are active, with that 1.8 billion like have been given to post. There are also a lot of influencers with a lot of supporters on the site. And you can also become an important brand with the correct strategy. To keep applicable to the present supporters, you must post the correct kind of data and also add fresh ones.
There are some powerful tips from you that can make more visitors to your platform.
1. Switch your account to the business account
2. There are some free tools of Instagram use them
3. You can use Instagram stories to promote business and attract customers.
4. Take an interactive brand hashtag.
5. You have to post at the right time. e.g. Monday and Thursday. Don‘t post on Sunday because it is the worst day to post
2. SEO
SEO stands for Search Engine Optimization. Seo is a technique to get traffic for the website. This is one of the best parts of Digital marketing tools. From this, you can drive more traffic to the sites. This is the way to ―rank‖ your website in search engine scores, thereby improving the percentage of organic traffic. The organization uses the SEO technique to grow their business over the world wide web.In order to create qualified traffic to your website, there are several methods to approach SEO.
1. ON page SEO

In this, you can answer reader questions by searching for keywords for your search volume and greater on the SERPs, resulting in the search results pages.
2. OFF Page SEO
This type of SEO is to Optimize your websites; managing backlinks out-links the number of publishers that you know. You can get backlinks that you want to transfer your website up to the correct SERPs by networking with other editors, writing your articles on these websites, connecting them to your website, and giving external attention.
3. Technical SEO
This kind of SEO focuses on the backend of your website and also focuses on how a website is built. Technical SEO means compression of the website‘s image structure and CSS file optimization; this is all the most important factor of SEO ranking.
To perform SEO, there are many digital marketing tools available in the market. Below is a list of SEO tools.
· Yoast SEO: If you use WordPress, then Yoast SEO is the best plugin you can use. Yoast SEO is used to optimize the content, metatags, keyword density, SEO title, etc.
· Google Analytics: Google Analytics is a website analyzer tool. The organization uses this tool to analyze its website. It gives overviews of the traffic for the website. Google Analytics gives information about the website like the number of users visiting the site, how much time they spent, which page of the site the user visits, etc. It discovers and fixes any technical issues using the search console.
· Keywordtool.IO: Keywordtoll.IO is a keyword analyzer tool. This tool is used to get an idea about the keyword mostly used by the users for any web browser. It gives the keywords search volume over the web like Google, Amazon, youtube, bing, play store, Instagram, Twitter, and eBay.
· Ahrefs’ Backlink checker: The organization uses this tool to get backlinks for their web pages. It also shows DR, i.e. Domain Rating, and UR, i.e. URL rating.
3. Affiliate Marketing
Affiliate marketing has become one of the oldest ways of digital marketing tools where you refer somebody to an online product. If that person buys that product, you will get a commission based on that recommendation. The advertisements in affiliate programs are connected to websites of companies and are referred to as affiliate links. Affiliates usually have to apply for affiliate programs, while most affiliate programs have no price to join. Affiliates decide which banners or advertisements they will place on their websites within their affiliate programs. They will also agree to membership programs with the highest Commission structure for merchants, although the structure is not usually considered very paying or beneficial.
4. PPC
PPC means Pay Per Click. In this model of marketing, the owner pays money as per click. The most important PPC ad format appears on the search results pages of search engines like Google or Bing. Most, but not all, PPC ads appear in the search results. There are three major types of marketing ads PPC.
· Text Ads: Text Ads mean written content by the owner of the site. Format and character depend on the PPC platform on which you are working. Text advertisements are most frequently initiated through the Search Network when consumers search within your PPC campaign on Google or Bing for a keyword.

· Display Ads: this type of ad is in the form of an image or GIF. PPC platforms offering display advertising often have size, and advertisers need to comply with content requirements when creating their visual creative.
· Shopping Ads: Typically, a shopping advertisement is provided after a search engine or shopping engine submits a query. Typically shopping advertisements contain a picture of the item, its price, and any here specifications such as size, color, dimensions, etc.
5. Landing Page Tools
· Lead-pages: This Leadpages tool will help to make a user-friendly landing page. It will Offer lead magnets and collect email addresses and integrate your email automation software with your pages.
· Click-Funnels: You don‘t need a hosting platform, a domain name, a high-end theme, a coding developer, email automation software or any other technical expertise to make a shopping funnel. Click-Funnels create the levels of Landing pages to collect the Email address; Product sells and many more.
· Optimize-Press: This Optimize-press was designed to produce comparable look and feel pages for your WordPress website. You can edit your landing pages in real-time with loads of templates and customizable components to get your content up quickly.
6. Email Automation Tools
· Active-Campaign: Active-Campaign is an all-in-one packet platform for your CRM software for email marketing, marketing automation, and sales. It allows you to communicate with welcome posts, trigger campaigns, follow-up sales, and more with your contacts. In addition, you can ensure that you never miss a chance with a prospective lead with multiple data-driven automation.
· Hatch-buck: Hatchback automates the communication of lead generation and customers. Its CRM is intended specifically for small companies to allow you to see their activity in real-time and trigger hot leads when they are prepared to purchase.
· HubSpot Sales: HubSpot Sales gives you the opportunity to see who opens your messages and when. It also pulls up the professional background, business data, and recent tweets of the contact and even allows you to schedule messages to be sent later.
· Omniscient: This is the bonus tool for marketing for E-commerce. You can reach your clients by email, SMS, Web Push or Facebook Messenger, depending on their behavior.
7. Visual Design Tools
· Canva: It will help you to design a beautiful image with the help of the Drag and drop option. Choose one of their countless different templates, or choose a pre-sized blank design for your chosen platform. Even the branding section can be customized, so you always have your choice of colors, fonts, and logos on your platform.
· Animoto: From this, you can create a professional video, GIF, Custom Text Visual effect, and many more things that you make from this Animoto.
· Design Wizard: Design Wizard is outstanding graphic design software that helps you modify pictures and videos of high quality within seconds. This tool is best suited for advertisers of social media, company owners and party planners! The tool‘s standard features include a custom color palette, a free font library, and resize functionality.
· FreePik: FreePik has a collection of images, and it is free for everyone. Be aware that Freepik‘s resources have their own copyright (Freepik), so you will not be able to register an image containing any of our resources. This will give you millions of pictures, icons, photos, and many

more. You can find the ideal stock photo for your blog or your Company logo icon without worrying about the authorship.
8. Content Curation Tool
· Feedly: Feedly picks up all of your favorite blogs in one location so you can quickly scroll through them. It even says how many shares an article has, helps you to explore the most famous stocks for social media sharing.
· Buffer: Buffer is the quick way to share anything you read. Simply download the chrome extension or application, and there are links to the device, and the social media platform of your choice will automatically add your post.
· Snip.ly: Snip.ly will create a call-to-action for each shared blog post and social media post. With topics, colors, logos, and more, you can personalize your connections, making it a wonderful way to boost conversions.

What is Social Media?
Social Media is a platform that lets us participate in social networking. We can share our posts on various social media platforms to improve business visibility. Today it is the best source for news updates, marketing, education, and entertainment.

Importance and Features of Social Media
The importance of social media is undebatable. It is a powerful channel of marketing − a game changer for any business. It provides us the flexibility to communicate at both personal as well as business levels.
Business owners can improve search rankings, leads, sales, and traffic using search media. This can be done at reduced marketing expenses. Besides business, it is a cool platform to connect with friends and dear ones.
1. Social media are interactive Web 2.0 Internet-based applications.
2. 	User-generated content—such as text posts or comments, digital	photos or videos, and data generated through all online interactions—is the lifeblood of social media.
3. Users create service-specific profiles for the website or app that are designed and maintained by the social media organization.
4. Social media helps the development of online social networks by connecting a user's profile with those of other individuals or groups.


There are the following three Social Media Classification tools -

1. Social Publishing
Social publishing allows us to publish information in the content form(written text and videos).
Example: Blog, YouTube.

2. Social Networking
Social Networking helps us to stay connected with our friends, business partners, relatives, and customers.
Example: LinkedIn, Twitter, Facebook

3. Photo-based Social Networking
Photo-based social networking is used to share photos using social networking sites.
Example: Pinterest, Snapchat, Instagram

Effective use of Social Media Platforms
Social Media Marketing includes various social media platforms to reach new customers, promote their business, create brand awareness, and increase sales.
Some most common social media platforms that we frequently used in social media marketing are given below -

1. Facebook
[image: Social Media Marketing Tutorial]

Daily active users - 1.45 billion Monthly active users - 2.20 billion
Facebook is the best social media marketing platform, which is founded by Mark Zuckerberg on February 4, 2004. It allows us to invite and connect with our friends, relatives, colleagues, and customers by sending them messages, images, audios, and videos. It also allows us to like and comment on the posts, which are shared by them.
Most of the small as well as large organizations use Facebook as a "center" of their social media marketing. Organizations use Facebook to promote their brand, create awareness about their product, and reach out to a wider audience. Facebook also helps the audience to see our latest content, our

working hours, write their reviews on a particular product, and also see our organization's location on a map.
There are the following advantages of using the Facebook platform for social media marketing -

· Facebook helps us to easily reach the targeted audience.
· It allows us to share budget-friendly ads to the audience.
· Using Facebook, we can learn and use a new market strategy at a low cost.
· It provides various marketing platforms.
· It allows organizations to communicate with clients.

2. Twitter
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Daily active users - 145 million Monthly active users - 320 million
Twitter is one of the most effective, popular, and fast-paced social media marketing platform created by Jack Dorsey, Noah Glass, Biz Stone, Evan Williams, and launched in July 2006. It is an SMS- based communication platform, which allows registered users to read and write small messages called "tweets." Using Twitter, marketers can easily reach hundreds and thousands of customers to share the latest news and promote their brand. The main disadvantage of using twitter is that we can use only use 280 characters for the message.
There are the following advantages of using the Twitter platform -

· It helps us to increase customer satisfaction.
· It allows us to continuously send information in the form of small messages called "tweets."
· It helps us to establish a stronger relationship with customers.
· It improves organic search engine ranking.
· It is a very efficient platform for gathering feedback from customers.

3. Instagram
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Daily active users - 500 million Monthly active users - 800 million
Instagram is maintained by Facebook. It is an effective tool to reach the audience and allows the marketer to share images, memes, and videos to promote their business. According to a survey, 80% of accounts follow a business on Instagram. It works flawlessly on mobile phones and tablets. Recently Instagram introduces a new feature that is shared stories every day. This feature helps marketers to easily update their customers about new products on a daily basis.
There are the following reasons to use Instagram platform -

· Instagram's Global rank (Worldwide rank) is 5th on the internet.
· Instagram helps marketers to enhance their branding.
· It is a marketer-friendly platform.
· It helps marketers to drive traffic and grow their business.
· It helps marketers to acquire customers easily.
· On Instagram, content is available in the form of images and videos, which helps customers to understand the product in a very simple way.
· Instagram's brand engagement and visual content are ten times higher than Facebook.

4. LinkedIn
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No. of registered users - 562 million Monthly active users - 303 million
LinkedIn is the best B2B (Business 2 Business) social media marketing platform, which was founded in 2002. It allows us to create profiles as a fresher or as a professional. It is a place that helps us to search for jobs, stay connected with professionals, recruit new employees, and discuss business ideas with experienced employees to promote our business. A company profile on LinkedIn not only helps us to generate the local leads but also helps us to draw global leads.
There are the following reasons which make LinkedIn as a very effective platform for social media marketing -

· It provides an opportunity to stay updated about new technologies.
· It helps us to display and update our resume to search for new job opportunities.
· It is a free platform that mainly focused on career development.
· It helps to build and promote business brands.
· It is used to generate more leads.

5. Pinterest
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Monthly active users - 320 million

Daily active users - 120 million
Pinterest is a combination of the two words "Pin" (Thumbtack) and "Interest" (Interesting). It is quite different from all other social media marketing platforms. It is an image-pinning website introduced in 2009. Currently, Pinterest becomes one of the largest visual social networks to share and discover ideas, images, recipes, videos, new brands, infographics, and more.
There are the following reasons to use Pinterest for social media marketing -

· Pinterest is the fastest-growing platform for online content distribution.
· It is mostly used to create brand awareness and increase website leads.
· Its user-friendly platform allows us to create a visual profile for business and publish news.
· Its visual-heavy social network helps us to build more traffic on our website at a low cost.
Note: pins are the ideas that users on Pinterest create, find, and save from the browser.

6. YouTube
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No. of daily active users - 1 billion No. of monthly active users - 2 billion
YouTube is an excellent free video-sharing platform for social media marketing. It was created in 2005. YouTube helps us to create and upload our videos on the valuable content and deliver it to the audience in the form of tutorials. YouTube is like a platform where we can show our talent to attract the audience. In YouTube, content mainly available in the form of Podcasts, Infographics, Presentations, and video series.
There are the following advantages of YouTube in social media marketing -

· YouTube is the 2nd largest search engine and the 3rd most visited website.
· It is the best and easiest way to learn new technologies.
· It helps us to promote and sell our products worldwide.
· It is completely free to use and helps to acquire qualified traffic.

· It will expose you to connect with a huge audience.

Note: YouTube is a mixture of both social media marketing and content marketing.
7. Snapchat
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No. of daily active users - 210 million No. of monthly active users - 360 million
Snapchat is a great platform for adults. It is free to download. It allows us to create a new type of social media on a network. Snapchat mobile app is used to share photos, videos, and doubles as messaging services for users. It is most known due to the fact that messages and content disappear on it. Users can either send the content directly to another user or upload this content as their "story," which is viewable to users till the next 24 hours.
There are the following reasons to use Snapchat in social media marketing -

· It allows us to share and collect snaps from specific events to create stories on the social media platform.
· It is used to add a filter on photos to make them more attractive.
· It allows customers to interact with other experienced customers to know about the pros and cons of a product.
· Using Snapchat, customers can directly communicate with companies.
· It is a user-friendly platform for newcomers.

8. Google+
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No. of registered users - 2 billion
No. of monthly active users - 395 million
Google+ was a powerful social media marketing tool, which was developed by Google. It helped us to improve our local search visibility, build relationships with customers, and other businesses.
There are the following advantages of using Google+ in social media marketing -

· Google+ allows us to follow other people.
· It allows us to share information, images to target customers.
· It helps us to find other people with similar interests.

9. Starbucks
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No. of daily active users - 10 million No. of monthly active users - 19 million
Starbucks is one of the engaging brands on Facebook. The main objective of introducing Starbucks is that it helps to build an online community of loyal fans and engage with them.

Recently, Starbucks introduced a strategy to launch new variants of its existing products based on consumer's suggestions on their Facebook page, so customers not only enjoy the clicks-ins, photographs put by marketers but can also enjoy live audiences on Facebook.

10. TikTok
[image: Social Media Marketing Tutorial]

No. of daily active users - 150 million No. of monthly active users - 300 million
TikTok is one of the best social media marketing platforms launched in 2018. It is a popular video streaming and sharing app which allows us to create and share a 15-second video on a particular topic.
There are the following reasons to use TikTok for social media marketing -

· It targets a huge audience in the easiest way.
· It creates better user engagement.
· It allows us to create a small video and share it with their followers to get more likes and comments to grow our business.
· Recently, Tiktok launches its own advertising platform to advertise business using Tiktok ads. Now, Tiktok advertisement becomes the best platform for producing and launching new products as well as services.


Advantages and Disadvantages of Social Media
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Advantages:

1. A Place for Noble Causes and Practices

Social media plays a critical role in assisting individuals. There are numerous communities dedicated to social work on social media, and people can join these communities and talk about their problems with them.

People in the communities can assist them and provide them with the best possible counsel and financial assistance.

Other types of government-sponsored communities undertake social work, assist individuals, and resolve societal concerns.

Most people use social media to help others and do charitable work. By doing so, they may assist people in solving difficulties and making their lives comfortable and happier.

2. Use of Social Media for Promotion and Advertising
Social media is beneficial for promotion and advertising. Because the entire world is connected and uses social media, people may share their business products and services with the whole world.

Both online and non-online businesses require promotions and advertisements to promote their products and services to the general public.

You can freely promote your product with individuals in groups on social media, or you can pay to have paid adverts appear. Others can use social media to promote their products and reach out to people interested in what they have to offer.

Influencer marketers are the new brand ambassadors.

3. People Can Connect Through Social Media
The true beauty and best advantage of social media are that it allows people to connect. With the help of social media, you may connect with the people you desire from anywhere in the world. Social networking platforms give you the ability to communicate with individuals all over the world.

You may make friends from anywhere or follow someone on social media. Others might also use social media to follow and contact you.

Social networking is the most refined platform for exchanging ideas with individuals who share your interests.

Most users use social media platforms such as Facebook, Instagram, and WhatsApp to quickly communicate with their friends, coworkers, and family members.

4. Social Media is a Good Source of Up-to-Date Information
Social media is also a great place to receive the most up-to-date information and news.

People used to wait for daily newspapers to acquire the latest news and updates from worldwide before using social media.

People no longer have to wait for a daily newspaper or a television newscast. They may simply obtain the most up-to-date information and updates on current events worldwide by going on social media.

Social media allows people to share and produce information.

5. Social Media Is Beneficial to Education
Social media is beneficial to education. You can learn from others on social media, and it delivers the best learning chances ever.

There are many professors and lecturers on social media that can assist you. People can follow them and contact them, and they can receive assistance in their profession without h aving to pay them.

Students primarily used social media to communicate with their friends and classmates and debate educational matters with one another.

70% of students use social media to discuss school tests and assignments with their friends and peers.

6. Use Social Media To Drive Traffic To Your Website
The most significant way to drive traffic to your website is to use social media.

It lets you publish on your timeline, bio, or in a group with a link to your websites, directing visitors to them. To generate visitors to their websites, most internet businesses and bloggers use social networking.

Visitors to your websites can read about your products and services and learn more about them.

You can increase the amount of relevant, organic visitors to your website. With a connection to your website, you may create adverts and market your business to a big audience.

7. Social Media Assists in the Formation of People’s Communities
Social media plays a critical role in the formation of communities. The majority of people use social media to create groups of people who share common interests.

People also form communities based on shared interests, religions, and beliefs. You can talk about anything relevant to your interest with other individuals in the community and groups who share your interests.

You can completely participate in talks with them. You can discover a lot more about your interests, beliefs, and religions this way.

As a result, social media plays an essential role in forming communities.

8. Social Media Can Reach Large Audiences:
One of the best and most valuable advantages of social media is swiftly reaching a large audience. Social networking allows you to promote your brand to a broad audience swiftly and simply.
There are millions of people who are interested in your business and goods who use social media. With the help of social media, you may contact them.

On social media, you have the option of creating social media adverts to promote your business and product to a broader audience.

You can target your audience in a specific place and radius on social media, and this greatly aids in attracting customers to your retail or online establishment.

9. Government Benefits from Social Media
The government benefits from social media as well.

It may be a reliable means for the government to communicate with the public and a communication and entertainment medium.

The use of social media reduces the amount of money spent by the government on crime -fighting. By using social media, companies can quickly monitor what people are doing.

Because the general population widely uses social media platforms, the government can use them to raise public awareness.

As a result, spreading public awareness through social media becomes quite simple for the government.

10. Entertainment with Social Media
Social media is a new form of entertainment, and the majority of people use social media to pass the time.

Humans  are  social  beings.  They  desire  to  communicate  with  other  individuals  and  initiate conversations about various topics with people from different regions.

People often spend 40 to 60 minutes on various social media networks. They can exchange images, comments, posts, videos, and other media with others.

They can also watch other people‘s photos, remarks, and videos for pleasure. They are pleased and content with the likes and comments on her social media post.

According to research, 88 percent of individuals consider social media platforms such as Facebook, Twitter, and Instagram a new kind of entertainment.

Disadvantages of Social Media

1. Cyberbullying
One of the worst aspects of social media is cyberbullying, which is one of the top disadvantages of social media.

Bullying that takes place on social media platforms is known as cyberbullying. The majority of people use false social media accounts to tease others.

They are untraceable and can do anything they want. They bully others by sending them derogatory photographs and videos, as well as mocking them.

Bullying is made much easier by the use of social media. They make other individuals feel uncomfortable by making unpleasant remarks and teasing them in different ways.

Cyberbullying primarily affects teenagers and children. People who are subjected to cyberbullying experience despair, anxiety, and a high level of stress-like symptoms.

2. Hacking on Social Media
Hacking is the most severe drawback of social media, and it affects the majority of people.

Hacking is a prohibited action, and it is the act of gaining access to another person‘s personal and limited information.

In my research and study on the pros and cons of Social Media, I discovered that hackers target the youngest youth and children.

Several people‘s personal Facebook, WhatsApp, and Twitter accounts were hacked in January 2019.

Typically, hackers hijack people‘s accounts and then blackmail them by revealing their personal information on social media.

3. Reduces Face-to-face Communication Skills
Nowadays, social media is the most prevalent form of communication. The majority of people use social media to communicate with others.

One of the worst aspects of social media is that it reduces the ability to communicate face to face. Everyone used social media to interact with others, and as a result, they gradually lost their ability to communicate face to face.

Only keyboard or voice communications are used to communicate on social media.

People who communicated over social media did not learn how to share face to face, and face-to- face communication became extremely difficult for them. This also increases the chances of being affected by bipolar and other mental sufferings.

4. Fake News
Fake News Spreads Rapidly on Social Media. This is definitely another demerit of social media nowadays.

People create false social media posts and share them with others worldwide, spreading them to groups.

Social media plays a significant role in the dissemination of fake news. Anyone can manufacture fake news on a hot topic and post it on social media networks without any verification.

Other people can also share and pass it on to other people and groups, spreading fake news around the globe.

5. People’s Addiction to Social Media
One of the worst aspects of social media is the ability to become addicted to it, and this is a severe disadvantage of social media in the world is facing.

Most individuals use social media so much that they become addicted to it. They are constantly browsing through their newsfeeds and contributing to them.

People who use social media excessively develop a significant addition to it. Addiction to social media has affected the majority of teens.

People were cut off from society and the natural world when social media was introduced. They didn‘t want to see what was going on in the real world around them.

6. Social Media Is Harmful to One’s Health
Social media also harm people‘s health.

Excessive usage of social media platforms has been linked to a variety of health issues in people. They become sedentary due to their constant use of social media platforms at all hours of the day and night.

Users who are addicted to social media become sedentary and gain weight. They disliked going for a walk outside or participating in activities and exercise games.

They are constantly on social media.

This causes a slew of problems in their everyday health routines and exposes them to various harmful ailments.

7. Spending Time on Social Media is a Waste of Time
The majority of people use social media platforms to unwind and kill time.

In my extensive research on the Advantages and Disadvantages of Social Media, I discovered that it is the most time-consuming activity for people.

The majority of those affected are youths and students. They only used social media to scroll through the newsfeed and share photos and videos.

They squander their valuable time on social media. And they failed to take any steps toward a better future and professional success.

8. Social Media Causes Sleep Issues
Excessive usage of social media platforms causes sleep problems for the majority of social media users.

Social media is highly addictive. People use social media extensively at all hours of the day and night. Excessive use of social media damages the sleeping cells in the human body, resulting in sleep disturbances.

Excessive usage of social media causes sleeping problems, primarily in students and teenagers. People who get less sleep are more likely to develop a variety of severe disorders.
9. Social Media Cause Depression and Loneliness
People who spend too much time on social media get depressed and lonely.

Our lives have become increasingly reliant on social media, and people nowadays use social media as their primary mode of communication.

The majority of people become addicted to social media. They are constantly occupied with social media users, which causes them to become depressed.

Constantly settling in The amount of time we spend in front of devices has a significant impact on our brain. We may have a headache, depression, or anxiety due to our excessive usage of social media.

10. Social Media Causes Distraction
People are diverted from their life goals and objectives by social media.

The use of social media is steadily expanding. People use social media in more significant numbers. However, they are unaware that social media was diverting their attention away from their objectives.

The majority of pupils are distracted by social media, They utilize social media for fun and pleasure, and they are constantly browsing through the newsfeed, wasting their time.

Social media distraction has a significant impact on people‘s futures and professional prospects.

Q1. How can you categorize Digital marketing?
[image: https://miro.medium.com/max/1400/1*HyfhIFH6jiQozGpXleeQTg.png]


Q2. Explain Digital marketing?

Ans: Digital marketing is all about the tactics for brand marketing via online channels. It includes various techniques like SEO, SEM, Link building, Email marketing, PPC, Affiliate Marketing, etc.

Q3. What are the different types of Digital Marketing?

Ans: Different Digital Marketing aspects -


· Search Engine Optimization (SEO)

· Search Engine Marketing (SEM)

· Content Marketing

· Email Marketing

· Social Media Marketing

· E-commerce Marketing


Q4. Name some useful Digital Marketing tools.

Ans:


· Keyword Discovery

· RankWatch

· Moz

· Alexa Ranking

· Google Analytics

· Crazy Egg Heatmaps

· Favicon Generator

· XML Sitemap Generator

· SubmitExpress Link Popularity

· Digital Point Keyword Tracker

· Google Trends

· Google Keyword Planner

· Kissmetrics

· SEMrush

· Ahrefs

· Buzzsumo

· AdExpresso

· Buffer App

· MailChimp

· Unbounce

· Hasoffers




Q5. What are various Characteristics of digital marketing?


Ans: Characteristics of digital marketing are:


1. Two Way
Unlike traditional marketing, digital marketing uses a unidirectional message encouraging the customers to interact with the brand instantaneously. It is a great way to involve the audience in your promotion and advertising process rather than them being a mere recipient. Social users interested in the product form a network of interactions, spreading the word wider and developing a platform of queries and clarification in the form of comments. The new digital marketing era has made it simpler for a brand to advertise multiple products in a single ad through ‗People also bought‘ and for customers to save them in their ‗wishlist‘ and revisit later.

2. Measurable: One important characteristic of a digital marketing campaign is measurability. The word digital in itself has ‘digit.’ So whether you are putting up a social media ad or inviting clients to an offline event to play around with the installation, you should be able to collect the reach of these ads and responses numerically. The collection of this data is more straightforward in digital marketing and acts as an asset for future marketing purposes. It helps to know which audience you can narrow how, how effective your copy was and which strategy worked well or failed in the past.




3. Targeted
Every digital or online marketing strategy is targeted, meaning it focuses on a specific audience group. The data collected helps the marketers to target specific key demographics. For instance, a vegan cosmetics brand would target a female audience between the ages of 16 to 45, previously known to search for vegan brands and a particular region if the company only delivers in certain areas. It also helps gain numerical of the number of times the ad is viewed and determine the strategy that works well. The aim should be to deliver a meaningful message and enhance user and brand engagement.

4. Personalization
When your digital marketing copy is measurable, you can also track your customer‘s shopping habits, frequently viewed products, and preferences. It helps you personalize product suggestions for each customer and recommend related goods or services. You can also send a user personalized, one- time-use discount vouchers based on their ‗Watch list‘ or ‗wishlist‘, which they cannot share with another. The internet enables you to match the customers‘ requirements, making digital marketing budget-friendly and user-friendly.



5. Remarketing
Another significant characteristic and digital marketing tactic is Remarketing. It stems from previous marketing advertisements wherein the company shows ads specifically to those who have visited their page earlier or showed interest. It is mainly used for services or products for which the customer frequently visits the website. Remarketing could be of three types: Audience based, behavioural and contextual. For instance, you might have noticed that you see advertisements from merchants whose products you‘ve seen but not bought. It is a great feature to increase brand awareness and traffic drive directing them to the target landing page of your website. Now that you know what to show whom, you could add richer product information and details in the form of frequently answered questions and descriptions.



6. Multi-channel:
A digital marketing strategy needs to be used on multi-channels. Not all of the audience uses all of the platforms, or maybe they act selectively active on some. The goal is to reach the prospective buyer through various modes of online communication. The communication method should be easier and simpler to navigate through. For instance, would your audience want to complete product checkout through a reminder on Instagram or a personalized checkout link sent through email? It engages the prospect with the brand on an ongoing basis and cuts down printing and posting costs. The goal is to make the content accessible and easy to respond to.

Tip: Rather than spending time on all channels, learn the ones that benefit you the most and utilize your time on the chosen one or two platforms to build an engaging empire.




7. Adaptability
Digital marketing demands flexibility and adaptability to the changing technological, customer, and media requirements. The campaign is supposed to adapt to the evolving situations of the target

audience. Being a digital marketer could be pretty challenging, although it calls for creative minds to track and match the buyer signals and create an adaptable call-to-action message. Companies need to be flexible as new trends come and go quickly in the fast-changing environment.

Tip: Considering the changing industry needs does not mean you need to forget the true brand ethnicity, which must be maintained while matching the market trend.

8. Integration:
It realizes the perfect integration between the front desk and to the back office. This integration is the basis for quickly responding to the personalized needs of consumers. It can be achieved from the product information to collections and after-sales service in one go, so it is also a full-range marketing channel. On the other side, enterprises can use the Internet to carrying out unified design planning and coordinated implementations of different communication and marketing activities, to avoid the negative effects caused by the inconsistency of different communication.
9. Richer product information:
The Internet can tell us detailed specifications, technical indicators, warranty information, usage methods, etc. of current products, and even answers to the common questions. Users can easily find out products, prices, brands, etc. via the Internet.
10. Larger selection space:
Digital marketing won‘t be limited by shelves and inventory and provides an enormous products display and sales ballroom so that consumers provide almost unlimited choice space.
11. Lower cost advantage:
Publishing real information on the Internet has a limited cost, selling products directly to consumers, which can shorten the distribution link, and anyone can get the published information independently and can expand the scope of the sale, which can also save the promotional costs, Thereby reducing costs and making products competitive in price will prove beneficial. Most customers who come to visit are highly interested in such products. The audience is accurate, which avoids many useless information transfers and can also save costs.
Digital marketing also has similarities and characteristics of multimedia, time and space, interactive, anthropomorphic, advanced, efficient, and economical. Due to the use of specific attributes of digital products, digital marketing has added many new characteristics and features based on transforming traditional marketing techniques.
Q6.What are various important tools of digital marketing?

Ans: Various tools of Digital marketing are:
1. Social Media
This one is the most powerful one as we all know that Social media is the collection of communication, interactions, and collaboration. Apps and Websites will dedicate the social networking blogging, and many more are there. This technique supports the understanding of your brand and content on your social media channels; it will drive traffic and generates directions for your company.
Some important digital marketing tools of Social media:
· Facebook: As we all know, Facebook is one of the popular and top levels of the social network. Facebook allows users to create their own profile on the site from that you can connect with your friends and family, and the important point is that you can share and upload the photo and video with your friend, family, and colleagues with just one click.
· Twitter: This is another popular and powerful network. Twitter is a microblogging service that is free for registered members. We can also say that Twitter Tweets are the most powerful in the world. In Twitter, we can follow any registered twitter member to see their tweets using multiple platforms.
· Google Plus: Google plus is also one of the famous networks which Google manages. To Join with Google plus, first of all, we need an account on Google. When you first sign up, some groups, including Friends and colleagues, have been set up by Google. You can add your own as well. In this, you can share images and links with your friends and relatives.
· LinkedIn: This one is famous for business purposes. This LinkedIn network is specifically designed for business uses. The purpose of the site is to allow registered members to set up and document network-aware from trusted networks of people.
· Instagram: According to the search, about 850 mill users are active, with that 1.8 billion like have been given to post. There are also a lot of influencers with a lot of supporters on the site. And you can also become an important brand with the correct strategy. To keep applicable to the present supporters, you must post the correct kind of data and also add fresh ones.
There are some powerful tips from you that can make more visitors to your platform.
6. Switch your account to the business account
7. There are some free tools of Instagram use them
8. You can use Instagram stories to promote business and attract customers.
9. Take an interactive brand hashtag.
10. You have to post at the right time. e.g. Monday and Thursday. Don‘t post on Sunday because it is the worst day to post
2. SEO
SEO stands for Search Engine Optimization. Seo is a technique to get traffic for the website. This is one of the best parts of Digital marketing tools. From this, you can drive more traffic to the sites. This is the way to ―rank‖ your website in search engine scores, thereby improving the percentage of organic traffic. The organization uses the SEO technique to grow their business over the world wide web.In order to create qualified traffic to your website, there are several methods to approach SEO.
1. ON page SEO
In this, you can answer reader questions by searching for keywords for your search volume and greater on the SERPs, resulting in the search results pages.
2. OFF Page SEO

This type of SEO is to Optimize your websites; managing backlinks out-links the number of publishers that you know. You can get backlinks that you want to transfer your website up to the correct SERPs by networking with other editors, writing your articles on these websites, connecting them to your website, and giving external attention.
3. Technical SEO
This kind of SEO focuses on the backend of your website and also focuses on how a website is built. Technical SEO means compression of the website‘s image structure and CSS file optimization; this is all the most important factor of SEO ranking.
To perform SEO, there are many digital marketing tools available in the market. Below is a list of SEO tools.
· Yoast SEO: If you use WordPress, then Yoast SEO is the best plugin you can use. Yoast SEO is used to optimize the content, metatags, keyword density, SEO title, etc.
· Google Analytics: Google Analytics is a website analyzer tool. The organization uses this tool to analyze its website. It gives overviews of the traffic for the website. Google Analytics gives information about the website like the number of users visiting the site, how much time they spent, which page of the site the user visits, etc. It discovers and fixes any technical issues using the search console.
· Keywordtool.IO: Keywordtoll.IO is a keyword analyzer tool. This tool is used to get an idea about the keyword mostly used by the users for any web browser. It gives the keywords search volume over the web like Google, Amazon, youtube, bing, play store, Instagram, Twitter, and eBay.
· Ahrefs’ Backlink checker: The organization uses this tool to get backlinks for their web pages. It also shows DR, i.e. Domain Rating, and UR, i.e. URL rating.
3. Affiliate Marketing
Affiliate marketing has become one of the oldest ways of digital marketing tools where you refer somebody to an online product. If that person buys that product, you will get a commission based on that recommendation. The advertisements in affiliate programs are connected to websites of companies and are referred to as affiliate links. Affiliates usually have to apply for affiliate programs, while most affiliate programs have no price to join. Affiliates decide which banners or advertisements they will place on their websites within their affiliate programs. They will also agree to membership programs with the highest Commission structure for merchants, although the structure is not usually considered very paying or beneficial.
4. PPC
PPC means Pay Per Click. In this model of marketing, the owner pays money as per click. The most important PPC ad format appears on the search results pages of search engines like Google or Bing. Most, but not all, PPC ads appear in the search results. There are three major types of marketing ads PPC.
· Text Ads: Text Ads mean written content by the owner of the site. Format and character depend on the PPC platform on which you are working. Text advertisements are most frequently initiated through the Search Network when consumers search within your PPC campaign on Google or Bing for a keyword.
· Display Ads: this type of ad is in the form of an image or GIF. PPC platforms offering display advertising often have size, and advertisers need to comply with content requirements when creating their visual creative.

· Shopping Ads: Typically, a shopping advertisement is provided after a search engine or shopping engine submits a query. Typically shopping advertisements contain a picture of the item, its price, and any here specifications such as size, color, dimensions, etc.
5. Landing Page Tools
· Lead-pages: This Leadpages tool will help to make a user-friendly landing page. It will Offer lead magnets and collect email addresses and integrate your email automation software with your pages.
· Click-Funnels: You don‘t need a hosting platform, a domain name, a high-end theme, a coding developer, email automation software or any other technical expertise to make a shopping funnel. Click-Funnels create the levels of Landing pages to collect the Email address; Product sells and many more.
· Optimize-Press: This Optimize-press was designed to produce comparable look and feel pages for your WordPress website. You can edit your landing pages in real-time with loads of templates and customizable components to get your content up quickly.
6. Email Automation Tools
· Active-Campaign: Active-Campaign is an all-in-one packet platform for your CRM software for email marketing, marketing automation, and sales. It allows you to communicate with welcome posts, trigger campaigns, follow-up sales, and more with your contacts. In addition, you can ensure that you never miss a chance with a prospective lead with multiple data-driven automation.
· Hatch-buck: Hatchback automates the communication of lead generation and customers. Its CRM is intended specifically for small companies to allow you to see their activity in real-time and trigger hot leads when they are prepared to purchase.
· HubSpot Sales: HubSpot Sales gives you the opportunity to see who opens your messages and when. It also pulls up the professional background, business data, and recent tweets of the contact and even allows you to schedule messages to be sent later.
· Omniscient: This is the bonus tool for marketing for E-commerce. You can reach your clients by email, SMS, Web Push or Facebook Messenger, depending on their behavior.
7. Visual Design Tools
· Canva: It will help you to design a beautiful image with the help of the Drag and drop option. Choose one of their countless different templates, or choose a pre-sized blank design for your chosen platform. Even the branding section can be customized, so you always have your choice of colors, fonts, and logos on your platform.
· Animoto: From this, you can create a professional video, GIF, Custom Text Visual effect, and many more things that you make from this Animoto.
· Design Wizard: Design Wizard is outstanding graphic design software that helps you modify pictures and videos of high quality within seconds. This tool is best suited for advertisers of social media, company owners and party planners! The tool‘s standard features include a custom color palette, a free font library, and resize functionality.
· FreePik: FreePik has a collection of images, and it is free for everyone. Be aware that Freepik‘s resources have their own copyright (Freepik), so you will not be able to register an image containing any of our resources. This will give you millions of pictures, icons, photos, and many more. You can find the ideal stock photo for your blog or your Company logo icon without worrying about the authorship.
8. Content Curation Tool

· Feedly: Feedly picks up all of your favorite blogs in one location so you can quickly scroll through them. It even says how many shares an article has, helps you to explore the most famous stocks for social media sharing.
· Buffer: Buffer is the quick way to share anything you read. Simply download the chrome extension or application, and there are links to the device, and the social media platform of your choice will automatically add your post.
· Snip.ly: Snip.ly will create a call-to-action for each shared blog post and social media post. With topics, colors, logos, and more, you can personalize your connections, making it a wonderful way to boost conversions.



Q7. What is Social Media?
Social Media is a platform that lets us participate in social networking. We can share our posts on various social media platforms to improve business visibility. Today it is the best source for news updates, marketing, education, and entertainment.

Q8. What are various Features of Social Media?
The importance of social media is undebatable. It is a powerful channel of marketing − a game changer for any business. It provides us the flexibility to communicate at both personal as well as business levels.
Business owners can improve search rankings, leads, sales, and traffic using search media. This can be done at reduced marketing expenses. Besides business, it is a cool platform to connect with friends and dear ones.
1. Social media are interactive Web 2.0 Internet-based applications.
2. 	User-generated content—such as text posts or comments, digital photos or videos, and data generated through all online interactions—is the lifeblood of social media.
3. Users create service-specific profiles for the website or app that are designed and maintained by the social media organization.
4. Social media helps the development of online social networks by connecting a user's profile with those of other individuals or groups.


Q9. What are various Advantages and Disadvantages of Social Media?


	Pros of Social Media
	Cons of Social Media

	A Place for Noble Causes and Practices
	Cyberbullying



	Pros of Social Media
	Cons of Social Media

	Use of Social Media for Promotion and Advertising
	Hacking on Social Media

	People Can Connect Through Social Media
	Reduces	Face-to-face	Communication Skills

	Good Source of Up-to-Date Information
	Fake News

	Social Media Is Beneficial to Education
	People‘s Addiction to Social Media

	Use Social Media To Drive Traffic To Your Website
	Social Media Is Harmful to One‘s Health

	Assists in the Formation of People‘s Communities
	Spending Time on Social Media is a Waste of Time

	Social	Media	Can	Reach	Large Audiences
	Social Media Causes Sleep Issues

	Government Benefits from Social Media
	Social	Media	Cause	Depression	and Loneliness

	Entertainment with Social Media
	Social Media Causes Distraction





Objective Questions
1) Which of the following is the correct depiction of Digital Marketing?

a. E-mail Marketing
b. Social Media Marketing

c. Web Marketing
d. All of the above Hide Answer Workspace
Answer: d) All of the above
Explanation: Digital marketing refers to a process of promoting content, videos, products, services, etc., thru social media marketing, e-mail marketing, web marketing, affiliate marketing, etc.


2) 	doesn't fall under the category of digital marketing.

a. TV
b. Billboard
c. Radio
d. All of the above
Answer: d) All of the above
Explanation: All the given options are totally irrelevant to the concept of digital marketing.


3) Which of the following is incorrect about digital marketing?

a. Digital marketing can only be done offline
b. Digital marketing cannot be done offline.
c. Digital marketing requires electronic devices for promoting goods and services.
d. In general, digital marketing can be understood as online marketing, web marketing, and e-mail marketing.
Answer: b) Digital marketing cannot be done offline.
Explanation: Digital marketing can be done both online and offline.


4) How many types of pillars do we have in digital marketing?

a. 1

b. 2
c. 3
d. 4
Answer: b) 2
Explanation: There are two main pillars in digital marketing such as online marketing and offline marketing.


5) Which of the following is involved in the digital marketing process?

a. RSA
b. Voice Broadcasting
c. Podcasting
d. All of the above
Answer: d) All of the above
Explanation: Digital marketing includes e-mail marketing, RSS, voice broadcast, fax broadcast, blogging, podcasting, video streams, wireless text messaging, affiliate marketing, social media marketing, and instant messaging.


6) What is considered while creating a front page of the website or homepage?

a. References of other websites
b. A brief elaboration about the company
c. Logos portraying the number of awards won by the web designer
d. None of the above
Answer: d) None of the above
Explanation: All the options explained above are irrelevant in terms of the company's front or homepage.


7) What is the name of the process in which marketing is achieved by incorporating tools, techniques, electronic devices, technologies, or systems?

a. Internet Marketing
b. Direct Marketing
c. Electronic Marketing
d. Interactive Marketing
Answer: c) Electronic Marketing
Explanation: Electronic marketing refers to the application of marketing principles and techniques via electronic media and, more specifically, the Internet.


8) Which of the following is not specifically required by the search engines?

a. Poor user experience
b. Keyword stuffing
c. Buying links
d. All of the above
Answer: d) All of the above
Explanation: The search engine does not necessitate poor user experience, keyword stuffing, and buying links.
9. Which social media company has released its first annual human rights report? [A]Twitter
[B]Meta [C]LinkedIn
[D] Snapchat
Correct Answer: B [Meta]

10. Which social media platform recently introduced ‗Unmentioning‘ feature? [A]Facebook
[B]Twitter [C]LinkedIn
[D] Koo

Correct Answer: B [Twitter]
11. What is the time limit for the resolution of an appeal under the new social media legislation developed by the central government?

[A] 5Days [B]30Days [C]15Days
[D] 20 Days

Correct Answer: B [ 30 Days]
Notes:
Centre has come up with new social media laws because the companies had violated Indians‘ constitutional rights. The government brought back a proposal to amend the rules that govern social media companies. It also includes a plan to set up a new government-appointed committee.

12. Which social media platform launched SMBSaathi Utsav to support small businesses? [A]Facebook
[B]WhatsApp [C]Twitter
[D] Koo
Correct Answer: B [WhatsApp]
Notes:
WhatsApp India announced an initiative named SMBSaathi Utsav that aims to support small businesses by helping  them  adopt  digital  mediums  such  as  the  WhatsApp  Business  App. SMBSaathi Utsav commenced with a pilot in Jaipur where over 500 small businesses are being trained on running their business online. The initiative was launched in collaboration with Josh Talks.

13. Which social media company just announced the global launch of ‗Take a Break‘, which includes India? [A]Instagram
[B]Twitter [C]Pinterest
[D] LinkedIn Hide Answer
Correct Answer: A [Instagram ]
Notes:
Instagram has announced the launch of ‗Take a Break‘ in all countries, including India, to empower people to make informed decisions about the way they are spending their time.

14. Which country proposed the ‗Social Media (Basic Expectations and Defamation) Bill 2021‘? [A]USA
[B]Australia [C]China
[D] India

Correct Answer: B [Australia]
Notes:
The Australian government released the draft of ‗Social Media (Basic Expectations and Defamation) Bill 2021‘.
The Bill aims at holding social media companies accountable for the content posted on their platforms, and protecting users from trolls. The reforms will consider social media companies as publishers and they

can avoid this liability if they provide information so that the victim can identify and begin defamation proceedings against the troll.

15. Which social media platform has launched two cyber safety campaigns named ‗Safe Stree‘ and ‗My Kanoon‘?
[A] SnapChat [B]Instagram [C]Facebook
[D] Twitter Hide Answer
Correct Answer: B [Instagram]
Notes:
Instagram has launched two campaigns named ‗Safe Stree‘ and ‗My Kanoon‘ to provide online safety to young	users.
Instagram has partnered with a youth media and insights-company and a women‘s rights and laws platform to launch ‗Safe Stree‘. It aims to spread awareness about the safety features available on the platform. ‗My Kanoon‘ will inform users about the legal rights and protection available to them.

16. Which famous personality has announced to launch a new social media network, called TRUTH Social? [A]DonaldTrump
[B]NarendraModi [C]HillaryClinton
[D] Kim Jong-un
Correct Answer: A [Donald Trump]

17. Recently, Ministry of Information and Broadcasting has launched its account in which social media platform to counter fake news?
[A] WhatsApp [B]Telegram [C]Instagram
[D] Twitter
Correct Answer: B [Telegram]
Notes:
The Information and Broadcasting Ministry has launched its account on social media platform Telegram to counter fake news. It was launched as ‗PIB Fact Check‘, which is one of the few government entities to have a telegram channel, and aims to verify information related to the Centre and disseminate to its subscribers. Earlier, fake channels were being run on Telegram in the name of fact check.

18. Who Social networks are organized primarily 	. a.brands
b.people c.discussions d.interests
Answer	 B
image6.png
Central processing unit

Control
unit

Arithmetic
logic
unit

Registers





image59.jpeg
===
—
— O <O
e
B[ T
™| o g
e [T e
=
R D | x| ©
T T
A I v | D [y
s e e lF\uwlmes 1
o | O p—





image60.jpeg




image7.jpeg




image61.png
Yes

Sequence Selaction:




image62.png
The Country of the Blind

Theee hundred miles md more o FEISERAR, anc hundred rom the snows of Cotopai, nthe wildest
VRS thre s tha mysteious moutain vally. cut off For althe world ofmen, the
Long ycars ago tht valley lay so far open o the world that men might como ot bt
{hrough fighthul orges i over anicy prs nto i cauablemendows, and thither indocd men can,  frily

or s00f Peruvian hl Phreeds e rom the lust and tyranny of an ovil SEPNEIEA. Then came he.
stupendous outbresk of Mindobarmba, hen it was night in W for seventeen days. and the water was boiling
1 Yaguachi and all he fsh floting dying even s fr o5 s s IR oy o
‘were landtslipsand swvif thiwings nd sudden floods, md one whale side of the oldSRERH crest lipped and
ame down in thunder, nd cut fc SRPMPYPIYTIYEIRIE for ever rom the explocing fet of men. But ane of

these carly setlers had chanced o beon the hither side of the gorges when the world had so teribly shaken
ltsel, and he perforce had to forget his wife and his child and all the friends and possessions he had left up





image63.png
January Marchq|
April Juneq

July September
October Decemberd




image64.png
English (USA) 100% [INSRT | STD





image65.png
January Marchq|
April Juneq

July September
October Decemberd




image66.png
English (USA) 100% [INSRT | STD





image67.png




image68.png




image69.png




image70.png
Blldiv-0- &xs

‘OpenOfice.org Wiiter
DPEink

HTML (HyperText Markup Language)
‘Formatted text RTF]

Unformatted text





image8.png
2

Byted | Bytel Byte2 1 Byted ]

Bit3) [Bic3

16

2

i

25

3

16777216





image71.png
Find & Replace

Search for

Replace vith

i]
:
i
i

[ simiarity search
] Search for Styles





image72.png




image73.png
§‘
<17 |5 |2
HIERERE
< >
wlsa]o|<| 2] |o|@
e [ e[ [
5| =|o|al-|e|a]z]a
BB R BE R
HIENPEERER
@ || o= b | EH
alp]e|a|-|=lg
clele[= =]
s [m[a][ =] e[ [=]=
e e wlw |
5 [ === ef=]A]e
H clofe|r|@|m|m
mwiv -] olsm]=
HiN N PERRRE
3| e[l e ]~
wm | ]s| 2o |m =

racters: afiyac





image74.jpeg
13
i
1
I

[}
m
L]

Defaut





image75.png
Left aligned text
Centre aligned text
Right aligned text
Justified text inserts spacing between words to force the text to reach from
margin to margin.




image76.png
Four options are available for the alignment of the last line of a paragraphs with justified alignment
applicd.

Four options arc available for the alignment of the last line of a paragraphs with justified alignment
applicd.

Four options arc available for the alignment of the last line of a paragraphs with justified alignment
applicd. This is an example.

Four options arc available for the alignment of the last line of a paragraphs with justified alignment
a » » 1 i e




image77.png
|_indents & Spacing | Alignment _Text Flow | Numbering |, Tabs | Drop Caps. | Borders
Options
OER
—
I
Left E —
. Left
[ Expand single word -
Justified





image78.png
Default-lab-settings-at-U.0™ntervals:7
12333 4>5>86>1T75>285>9
Same-paragraph-when-default-Tab-settings-are-chan ged to-0.75":1

1 5 9 5 8 5 4 5 B 5 B8 5 7 5 8 3




image79.png
Default-lab-settings-at-U.0™ntervals:7
12333 4>5>86>1T75>285>9
Same-paragraph-when-default-Tab-settings-are-chan ged to-0.75":1

1 5 9 5 8 5 4 5 B 5 B8 5 7 5 8 3




image80.png
Settings.

Messurement unit

Teb stops

0.50°




image9.png
Cost

Access seed

Storage capacity

Registers

Semiconductor
Cache memory
Primary memory or
‘main memory
Mageetic disk and
optical disk.
Secondary
‘memory

Magneic tape





image81.png




image82.jpeg
M BrURKIKIRA-¥-2-4Af

[v] [

| Times New Roman

]

|87 [pefeute

[—

_—





image83.png
ns for lang

Replace | Exceptons [Options | Custom Quotes | Viord Conpleton |

Delete spaces and tabs at begining and end of paragraph
Delete spaces and tabs at end and start ofne.

B
TIRIIKIRITTIRIRIRIRY

R
P
H
5

‘Combine sngi ine paragraphs flength grester than 50%

M Replace whie modifying existing text
[VJ: AutoFormat/AutoCorrect whie typing

(o (e J[eep ) [peset ]





image84.png




image85.png
Format | Teble Tools Window tielp
Defaut Fomattng Cilsshiftsspace | @+ of | 45 + b -

M B 7 UK

Character..





image86.jpeg
T8 %88





image87.png
Numbering Style: Numbering 1

‘rganiser | Bulets | Numberng Ste_[Outine | raphics | Postion | Optons |
Selction

1. 1. 1. 1.
1 a) (@ 1.
a) . i 1
. . A 1
. . . 1
1. A 1 >
A I 1.1 >
i 111 *
a) 111 .
- . 11111 .

(o (e J[eep ) [peset ]





image88.png
| Organiser | ullts | Numbering Stle | Outine | Graphics | positon [Options |

Format





image89.png
[Organser | utets || urberng e | outine | Gaphics | oston [options |

Format

Level





image90.png
#B-O- ki EE e E-B

| indexes and Tabes "%

=R

[insert Footnote Directly]





image10.jpeg
,
-





image91.png
Insert Footnote

[
© gt e ]
Ogporscr

™

o

O Endnote





image92.png
Troatnotes |endnotes |

AutoNumbering

Numbering





image93.png
RBL




image94.png
N




image95.png
Spelling: English (USA)

i
Not in dictionary.

Here is a bit of text to test the spelling shecker, to brifly see if it is

relly good enough.

Suggestions

& English (USA)

<

shocker
shucker

‘Sherlocke
Honecker





image96.png




image97.png




image98.png
Default languages for documents
Western % English (UsA) 2

[£] For the current document only

Enhanced language support




image99.png
{noun) dweling (generic term) |dweling (generic term) A
(roun) legissure (geneic tem) = |home (generc term)

(noun) buiding (generic tem) mwm) 3
|(noun) family

(2 — [)]





image100.png
Ot

BNOEE

tary dose

DS

1111}

tomatc





image11.jpeg
Hard disk RAM Cache CPU with
fan





image101.png
Paragraph Style: Default

| tmbeng | Tas | DopCas scground | gorders |
| Organser_|_indents :Spacng_|_Abgrment. | Tt Flow | Font. | FontEffets | Positon |

[ E [ ——
Crracers tlne begnng
e




image102.png
<

"Minimum rumber of characters for hyphenation: 5.
Characters before Ine break: 2

Characters after e break: 2

Fiyphenate without inquiry

Hyphenate specia regions.





image103.png
AutoCorrect %]
Replacements and exceptins for language:  [Engish (UG

Replace | Exceptons | Optons | Custom Quotes [ Word Completion |

7 Enable word completon
[ Append space
Oshowastp

O colect words

\hen dosing a document, save the It
Forlater use In other documents,

Acceptuith

Miimum word length

o J[Cems J[eep ) [Coeset ]





image104.png
XS RCre

Line numbering-puts line numbersin thema
areprinted. Figure'] shows an-example-with
Click Tools'>Line-Numbering-and-sclect t
corner. Then-click OK.€

Yourcan-choose-how many lines-are number
‘numbering-type-and-whether-numbers-restart




image105.png
Separator
Text

Every

[L23.. [v]
et 5
050m i3
5 (& ines
Cont
[“IBlank ines.
[inesin text frames




image106.png




image107.png
) Untitled1 - OpenOffice.org Writer

e |Edt Vew Insert Fomat Table T

Delete rabbit Ctrl+Z
cl+y





image108.png
b - &

Paste cipboard
Delete 51

Change style: araphics 17
nsert graphics

Delete graphics

Undo 1 acton





image109.png




image110.png




image12.jpeg




image111.png




image112.jpeg
Hyperink e

Target

Further settngs
Frame

Text

Name.

L gl Feem

OTehet





image113.png




image114.png
& Insert Table

Name [raplex
size

Columns 3 <l
Rows 3 <l

Options
Heading

Repeat heading

Thefirst 1 ] rows

[ Don't split table

Border

Cancel

Help





image115.png




image116.png
Convert Text to Table

Separatetextat ————————
©ffabs] O semicolons.
O paragraph O other:

Equal width for allcolumns.

Wil

Autoformat...





image117.png
& Table Format )

Table Text Flow | Columns | Borders| Background

Properties Alignment
Name rabies © Automatic
Bl O Left
© Erom left
Spacing
Fom T OFer
O Center
em 4
© Manual
Above pooeam — [7]
Below pa2am  [1]

ok J[[cancel |[ e | [ Reset |





image118.png
mmmmm

[ dapt tabie widh!
[ Adist cokamns proportoraly
Remaiing space
Column width
< 1 2

o @[ 8] [oor Equu' EH ][





image119.png
Table Format

[ Table | TextFon | Couns /_W ]

pe— p—
oetait = R |
s

TOBEE | == ®) | o
f
Shadow style

: =

S5 = ] o N T | [l
Properties

[ werge adjacentine styles

(o (e J[eep ) [peset ]





image120.png
Table Format

Tabie | Text Fow | Columns | Borders [Background |

A [oec = o [Tabe O]
Fie

D

Unlnked araphic

~

e

© o) [ — -

Onea

Otie - -

P
14‘”4 e m—





image13.jpeg




image121.jpeg
lect table ro





image122.png
Table Format

Tabe [Text Fow | ol | orders | ackground |

TextFion
©epage O colm
@pefore O after

it page e Ropege [v] e [+ (2]

Ao tabe to it across pages and columns
Ao row to break agross pages and coumrs
[ eep with next paragraph

%] rows
[se superordinete abject settngs O]

3 v
(o (e J[eep ) [peset ]





image123.png
Suspron oyzouy

Susproy ooy

Susproy ooy

Susproy ooy

Bugproy papnios v |

Suspwoy Fuoy soyjouy

suoy sysmyr,





image124.png
Fle Edt Vew Insert Fomat Table Toos Wndow Hep.
CR-sl=RFRSR VXD o608

&) [feconents ] [centsemoner I B/ U|E=

AL f * K & |=sum Br>4<c2>

w2 . 3 4

=sum <Bl1>+<02> 4





image125.png
Caution




image126.jpeg
Format
et
£

B
= L
Lavender

Yelow

Gy

Green

Red

Back 1

Bk v

Add AutoFormat

tame





image127.png
T 2 35 4 O 6 7 38
| | | 1 | | ] | ]|

|
e Y ¥V Y Y YVYY VYW
E-R- - 0-2- 6 e [E6E
HEEE RS

e

12 13 14 15 16 17 18 19 20 21 929

™





image128.jpeg
Insert picture =]
D:\Profies\rgs02cMy Documents\My Pictures 6]

e [oate modfed
,‘  nedzna s Graphics (pg) S779Bytes 07/05/2006, 20:39:0¢
E |23 republican oo Graphics (g) 72.3KB 05/08/2006, 18:014
a 2010 Graphics (pg) 80438ytes 04/16/2008, 18:35:5
|55 t1_005 jpg. g Graphics (o) 1877Bytes 06/10/2006, 04:29:1(
|24 United States.gif Graphics (gif) 4086 Bytes 04/11/2006, 22:03:1(
Fie gane: [incon_reek et proto.pg ¥ e ]

ste: [sraptics v Sancel
e tye: e e

Ounk

Preview





image129.png
Edit Links X
Source e Element: Type Status
calc-autoformat.bmp <Al formats> Graphic Manual
calc-delete.bmp <Al formats> Graphic Wanual
cortists L.bmp <Al formats> Graphic Manual
Break Link
‘Source file file:///D:aaaa)calc-autoformat.brmp.
Element: <Al formats>
Type:





image130.png
Colegamento
5 [





image14.jpeg
Computer




image131.png
Colegamento
5 [





image132.png




image133.jpeg
W 9o 0@

- 1)

| Backorounds - dasy (E\Program Fis\pendffc.org 22\share\galey\ b





image134.png
Fm=a
s ®





image135.png
Color
Ao
Plow
Al
o
O
Yo

x

@ @ 8 @

@




image136.png
Fm=a
s ®





image137.png
Color
Ao
Plow
Al
o
O
Yo

x

@ @ 8 @

@




image138.jpeg




image139.jpeg




image140.jpeg




image15.jpeg
Gbjecine Quesion:

1.2 complment o  inary b s ound by siing__
et nary bt

i o e digis, mumbor may conalns__snd
. The sign it s thefmosrighimes i

4. The alus o sgn bit for  ositvssumber s

S The valne o sign it o egative mmber i

6 The range o data

e represcated wing s it igned e,

I et dae wigncd




image141.jpeg




image142.jpeg




image143.jpeg




image144.jpeg




image145.jpeg
Ay

s‘ii\

o g




image146.png




image147.png




image148.png




image149.png




image150.jpeg




image16.jpeg




image151.png




image152.png




image153.jpeg




image154.png




image155.png
Frd




image156.png
@l @&




image157.png
& Picture [X])

Type| Options | Wrap | Hyperlink | Picture | Crop Borders| Background | Macro

Crop
©Keep scale)

O Keep Image size

Left [0.0pt Top [o.opt: 7]
Right [0.0pt 2|  Bottom  [0.0pt B

Scale
Width [53% B
Height  [63% B

Image size
Width [415.4pt <l 448.6pt x 239.8pt
Height  P22.1pt 3]





image158.jpeg
EXAMPLE 1
This image shows the BSD Daemon.

Linux users probably are already familiar with it.

Itis loaded in its natural size from a .JPG file.

EXAMPLE 2

In this example the figure is reduced proportionally holding
the [Shift] pressed while dragging the mouse

EXAMPLE 3

Example of non proportional reductions
obtainedjust dragging the mouse without
holding [Shift]





image159.jpeg
EXAMPLE 1
This image shows the BSD Daemon.

Linux users probably are already familiar with it.

Itis loaded in its natural size from a .JPG file.

EXAMPLE 2

In this example the figure is reduced proportionally holding
the [Shift] pressed while dragging the mouse

EXAMPLE 3

Example of non proportional reductions
obtainedjust dragging the mouse without
holding [Shift]





image160.png




image17.jpeg
iGoogle |





image161.jpeg
.

My Computer_asio word

q) Latinch Reaione Piaver

S
fn
=

Gren O Dacument
vinze

Netscope 7.1

) search

(] ot sfovnncmisen

1) Accmssories
() AcsHTML S Freswars
(@) Apromar
) CorporateTine
() S8 T valdstor s v3.5
(2 ) xecmai 5.1
R
() 23va 2 Runtime Enveonmant
I sawssss
) Logiimch
@ wacomsds
) Mcrosatt offce Torks
) etscape 7.3
(@) Netscape Commuricator
) novel Commor)

i3 seaait ©
b ) St
@ Woamps
I3 winscez
+ B Acrobe Dister 5.0
23 Adobe acrobat 5.0
66 Cammand Antirie
B it i
D Microsaft Mause
€ Hoise Hesitny Computing Guide
Outiook Exrese

) ResiOne Playsr
© vidons veds piayer

6] OpmnOfice crg ML Eetar

[ Goenottis.ors terese

5] Onenomze org Mot

18 Cperficn ora Setun
Openofca.ara writer





image162.png
=18(x|

PH B L eE ST +erk|a
O 8| ==

BTN

A [ s | ¢ o E [ F [ e [ = =
1
2
5
)
5
A
7
=
e
e [0
ol vy
= —
s
1
Do
o s
= [z
Sl
N ED
|
=
==z
2

Al 1] I sheets (Sreez [Shess 1l |
Bheet1/3 Pefauit [oo% [ [sm [+ Sum=0





image163.png




image164.png
=18(x|

PH B L eE ST +erk|a
O 8| ==

BTN

A [ s | ¢ o E [ F [ e [ = =
1
2
5
)
5
A
7
=
e
e [0
ol vy
= —
s
1
Do
o s
= [z
Sl
N ED
|
=
==z
2

Al 1] I sheets (Sreez [Shess 1l |
Bheet1/3 Pefauit [oo% [ [sm [+ Sum=0





image165.png




image166.jpeg
W s

B #2200





image167.png




image168.png
sdecton —————
ol (=G
W stings e |
7 timbers e

¥ Date & time
¥ gomiss
¥ Notes
™ Formats
™ objects





image169.png




image170.jpeg
Diats

©

o

R E——

O - |
e —
L —
™ Besdorly

ikl





image171.jpeg
Diats

©

o

R E——

O - |
e —
L —
™ Besdorly

ikl





image172.png




image173.jpeg
adone

Camtasia videos

cce
Dourloads

T Televsed Tstructor Mancal

Smutorets

S
Ewebtrain

ECHP 355 eiectranic port

ke
Meetngs
vy rosic
iy Pictures
My iceos
iy Webs
NICOLE
Other
personal
Posters

o E =D
o T 5l T
[OpenOffice.org 1.0 Spreadshest Template: =
P o
Wierosch Excel 95
et1 (Sheets. A Microsoft Excel 95 Template:
O Moo _—

et T g




image174.png




image175.png




image176.png




image177.png
[Times New Rom 7] [12 7]




image178.png
]




image179.png




image180.png




image181.png
=




image182.png
U




image183.png




image184.png
=3




image185.png




image186.png
=]

Levea Genter area Rehtarea o« |

[Bheet? g
tep

Al zlol BBl n|s|

Note [Pace]
Use the buttons to change the font or nsert ied commands such as date, time, etz





image187.png
=]

Levea Genter area Rehtarea o« |

[Bheet? g
tep

Al zlol BBl n|s|

Note [Pace]
Use the buttons to change the font or nsert ied commands such as date, time, etz





image188.png




image189.png




image190.png
< perr ] AP = Pl = Abw = il = ©Ob= = ¥w 5 2bw =6 3





image191.png




image192.png




image193.png




image194.png




image195.png
[=i
Numbers | Font | Font Effects | Algnment Borders | Backgraund | CellPotecten |
e

Line arrangement

CIEmEr

ot
e 2500t
[
| — 5,00 ot
110pt
0pt

0ot 7
[ e -

BEIEE
m 3:

o ] o | b | s





image196.png
2.50 pt




image197.png
Orgorizer | Page | Borders | Background | Header| Foster Shoet |

Page order
 Top o bafiom, then ight

€ Lefto ight then down

F Firstpage number [
Print

I Colurn and ow headers W Charts

I Gid F Draving objects

I Notes I™ Formulas

¥ Objocts/graphice W Zorovaluos
Sealo

& Reduce/enlerge prntout |
C Fitpinfouton numbar o pages El

Cancsl | Help | Beset





image198.png




image18.jpeg




image199.png
e
=

o Concel
Bk

a2

e too |
oo

[Curency 10
[Curency Gray
|Curency Lavender

[Curtency Turquoise

Delete

]





image200.png
{=




image201.jpeg
Slide 1,

Click to add text

= Untitled 1- OpenOFfice.org Impress. [
File Edit View Insert Format Tools Slide Show Window Help
B-EBH> Ba v hEE- @ @R 0O, |B-E-E &
IR Cofv|0.00cm [ MMBlack | & [Color [ JBlue8 | @ _
Slides Normal Outline| Notes | Handout| Slide Sorter Tasks WED T
= b Master Pages
1 T  Layouts
Click to add title

£59.16/-1.49 it

< >
/=T ¢ 190« B P % <, n@a 0kE-2-

0.00 x0.00

Slide 1/1 | Default

» Table Design N
» Custom Animation
» Slide Transition

e+ a%




image202.png
Parts of the main Impress window




image203.png




image204.png
Normal |outine | Notes

Sorter





image205.png




image206.png
1.56/4.63 :14.95x2.90 *
1 1 — |
Information Position Unsaved  Digital
changes  signature

Rectangle selected




image207.png
slide /1 (Layout) | Default o—+e——@ | 75% ‘

1 1
slide Page Zoom slider ~ Zoom
number style percent




image19.jpeg




image208.png
£ Navigator

K9 §-® -

~ @ Slide 1
Shape 1

&= Shape 2
~ @ Slide 2

&= Shape 1

5 Object 1
~ @ Slide 3

& Shape 1

& Shape 2
Shape 3
Shape 4
~ @ Slide 4

& Shape 1

5 Object 2

ShapesAndObjects





image209.png




image210.png
[Normal |Outline Notes | Handout | Side Sorter |

‘wJanuary
=sFebruary
‘mMarch





image211.png
&= F 8




image212.png
Workspace views




image213.png




image214.png
Frststep

ek o add rofes





image215.png
~ Layouts





image216.jpeg
Siide [Notes and Handouts|
includeonpage TR

Header

T

Date and time
O Fixed
® Variable Language:
(081010 < J [English (UK)

Footer

Footer text

Page number





image217.png




image218.png
Getting Started with Impress




image219.png
[Normal |[Outine |Notes [ Handout [Siide Sorter

1

2

e ~ e
Side 1 Side 2
4
- e
Side 3 Side 4





image220.png
®

@ [isides 3],





image221.png




image222.png




image223.jpeg
e
© Empty presentation

O From template:
O Open existing presentation

[0 not show ths wizard again

o [ ae= )





image224.png
Creating a new




image225.png
presentation




image226.png
Creating a new




image227.png
presentation




image228.png




image229.jpeg
Select a side design

<Orignal>
Dark Blue with Orange.
Subtie Accents

Selectan output medum
Original ©sazen
OoOyerheadsheet O side
o

review

) [Cssmx [

s

Create





image230.png




image231.png
Getting Started with Impress




image232.jpeg
Selectaside ranston ————————————

o
-

Select the presentation type ——————————
@ pefault

O automatic

Dustonofpece  [00:00:10

Duation ofpause  [00:00:10

Shawlego

Ce o e

Next >>

G





image233.png




image234.png
Presentation v x

%islide [E/Slide Design (&l Slide Show




image235.png
~ Layouts





image236.png
Formatting a




image237.png
presentation




image238.png
Formatting a




image239.png
presentation




image240.png




image241.png
Click to add title

« Click to add text

Insert Table Insert Chart

Insert Picture

Insert Media clip





image242.png




image243.png




image244.png
A M e S i

7)Click and drag to draw a box forthe text o Text ¥ X
theslide. Do not wory sbowt theverticd size [T | ©
and position—the text box will expand if =
 meeded as you type. To change the horizontal

Ha
size see “Resizing a text box ™ to reposition the | ——————
rext box to a different part of the slide see
“Moving a text box”

 DRelease the mouse button when finished. The
_ cirsor ppearsin the text box, whichis nowin
it mode (gray hasheod border with green
;:slzmg handles).

})‘1\/1;: or paste your text in the text box.

7A)Click outside the text box to de-sdlect it
7 )Cick outside e text box to de-selectit, =~ -

O R T RIS

N





image245.png




image246.png




image247.png
D F




image248.png




image249.png
Tip




image250.png




image251.png




image252.png
& b
UH

Insert Picture|





image253.png




image254.jpeg
Insert Table

Number of columns;

Number of rows:

o @

Heb

oK

Cancel





image255.png




image256.jpeg
Tasks View
< Master Pages
IlUsed in This Presentation

Recently Used

==

= Available for Use





image257.png
Master View

Close Master View





image20.png
Word Search Data  What to Search Example
Singleword  Enter word To search information about cricket cricket
Combination ~ AND, + To search two or more words. For e.g. Ashima + Goel
of words Ashima, Goel
OR To search either or both words. Fore.g.  Ashima OR Goel
Ashima or Goel
NOT, ~ To search for first word but not the second.  Ashima — Goel
For e:g. All Ashima's but not Goel's
Symbols s To search for exact phrase. For e.g. Ashima  “Ashima Goel”
Goel
* To search for word with all its forms For  Ashi*

e.g. Ashita, Ashiwani, Ashiwari, Ashibhuti





image258.png




image259.png
S slide Design

Select a slide design

Cancel

EIHE

Default

Exchange background page

[ Delete unused backgrounds

5 Load slide Design

Categories Templates oK
My Templates Introducing a New Product

MediaWiki Recommendation of a Strategy Cancel
Presentation Backgrounds

Presentations Help

More ¥





image260.png




image261.png
S Header and Footer

Slide _Notes and Handouts

Include on slide Apply to All
Date and time
i Apply.
© Variable Language oo
10/10/10 <) [Engiish (Australia) v Help

ooter

Footer text

lide number:

[ Do not show on first slide





image262.png
Normal Outline | Notes| Handout | Slide Sorter

W 1| This is a comment

i

Jean Hollis W eber
Today. 04:43





image263.jpeg




image264.png
Search Engine
Optimaization

Digital
Marketing

Affiliate Marketing

Email Marketing




image21.jpeg




image265.png




image266.png
Twitter




image267.png
Instagram




image268.png




image269.png
Pinterest




image270.png
e




image271.png




image272.png




image273.png




image274.png
TikTok




image275.png
Inbound Marketing Outbound Marketing

Pulls in interested costumers Pushes regardless of interest

Written according to the consumer’s needs Written according to the product’s needs

A part of content consumption Disrupts content consumption

Natural habitat: blogs, social media,
search, influencer marketing, opt-in
emails.

Natural habitat: display ads, telemarketer
scripts, magazines, TV ads, billboards.





image22.jpeg
[ R

* e e A G e B e 8 s
PO S e

s o S < Bt o - s s s ks

®

FEype

EaBUES ST s




image23.jpeg
3 nbox
* Starred
© snoozed
» Important
> Sent
B Drafts
- @ Categories
=% Social
o Updates
Olenna ~

F¥® Do Not Disturb

5 Invites

William Lintott, aakash jha, M.

2 9 <

Q, Search mail

[ R Cc : NS
~ Unread
Facebook

' Elena Casarosa

' Elena Casarosa

jfillory
1 no-reply

21 ~ Everything else

Google

Google

1-50f 54 :
Olenna, you have 27 new notifications and 18 friend ... 11:08 AM
Let's have dinner on Sunday - Hi Olenna, Silva, and Ti.. Sep 27
EC Photography Grand Opening! - - Elena Casarosa E... Sep 27

B EC Photography...

The Littlest Toad Feedback - I've invited you to fill out.. Sep 18
Your Account Information with GCFLearnFree.org - H.. 9/1/17

1-50f73 %
Security alert - Olenna Mason New device signed in t... Sep 12
Security alert - Olenna Mason New device signed in t. Sep7





image24.png
Gmail Images == w




image25.jpeg
First name Last name

Elena Casarosa

Username
Elena.m.casarosa @gmail.com

You can use letters, numbers & periods

Available:
ecosarosa cosarosaelena25 elenacosarosa661

Use my current email address instead

Password Confirm password

secscens seecsens k

Use 8 or more characters with a mix of letters, numbers &
symbols

Sign in instead m





image26.png




image27.png




image28.png




image29.png




image30.png




image1.jpeg




image31.png
Google
& Drive

=

| ~ 3 MyDrive
8 Budget Proposals

| Work
I Worksheets

Incoming
Recent

Starred

LR NCH <]

Trash

44 MB used (0%)
Buy more storage

Search Drive

My Drive ~ @ &
Name Owner
B Budget Proposals me
B work me
B Worksheets me
B AtClubinterest Letter me

rterly Report me

[0 Lake Stone Montessori Art Club me

Student Contract Form me

Gradebook = me

+Olenna

Last modified

Jan12

Jang

5/11/12

Jan12

Jang

o/25/14

o234

[ I

File size





image32.png




image33.png




image34.png




image2.jpeg




image35.png




image36.png




image37.png
= Enter site name

Your page title





image3.jpeg




image38.png




image39.png
0000

B Change image ~ B Header type

Font style




image40.png




image41.png




image42.png
Google Search Drive

& Drive My Drive ~
Name
get Proposals

File

ile upload
B GcoogleDocs ’
Google Sheets

@ ksheets

[ Gcoogle siides

More 5 3lubfinal project

ArtClubRoster 20112012 &





image43.png
& MyDrive- GoogleDrive X [] Untitied spreadsheet - Go.. X | +

€ ) ® @ | https://docs.google.com/spreadsheets/d/1 1Bjee7F3wPYawh0DTod9sgLePyl

Untitled spreadsheet

File Edt View Iset Fomat Data Tools Addons Help

B AT s % oo o A - w0 - B2
A 5 c ) B

1
2
:
n




image44.png
1
2
3
4
B

Add-ons

Help




image45.png
=) Field Trip Checklist [}
File Edt View Inset Fomat Data Tools Addons Help

S~ T s oo ogme Am - w0 -

S

A B c [

1




image46.png
Search Drive

My Drive ~
Name
BB Handouts
My Drive
Shared withme B8 sudget Proposals
Google Photos M| work
© Recent B8 Worksheets
Y Stared
Field Trip Checkls
1S
B Tesh
B Open House Planning Notes
115 MB of 15 6B used

I | ake Siene Monteccnr Art Clib Onen Horee Precentation 2%




image4.jpeg




image47.png
Field Trip Checklist [ ]
File Edit View Inset Format Data Tools Add-ons Help | All changes saved in Drive

H e AT s % oo 00123 Anal - w0 - BZsA. %-H

1
2
3
4
B




image48.jpeg




image49.jpeg
Present

join now

%2 Join and use a phone for audio




image50.jpeg
10:09 AM |




image51.jpeg
10:09 AM |




image52.jpeg
o Viniteboard

Change layout

I3 Fullscreen

R

Change background

Tum on captions.

Report a problem
Report abuse

Troubleshooting & help

& O®OuU B

Settings




image53.jpeg




image54.jpeg




image55.jpeg
Meeting details

2, People (3)

You 3:49PM
Hi!

B chat

&GX




image56.jpeg
o Viiteboard

Change layout

Full screen

R

Change background

Tum on captions.

Report aproblem

Report abuse

Troubleshooting & help

& ®OouU B

Settings





image5.jpeg




image57.jpeg
Settings

B Ao Microphone
Default - Microphone (High Definition Audio ...

[ Video
Speakers

83 General Default - Speakers (High Definition Audio De...




image58.png
CC|





